After 2.3 upgrade - no WLAN



  • Hello!

    after upgrad to 2.3 I v problems with the WLAN - I  cant tee the wlan network on my laptop and smartphone. The configuration looks finde (for me) - and unchanged.

    On APU 1D4

    I also miss the setting for the antenna (1 or 2) -

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 04:f0:21:17:4a:47
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: running
    pflog0: flags=100 <promisc>metric 0 mtu 33160
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: 224.0.0.240 maxupd: 128 defer: on
            syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
            nd6 options=21 <performnud,auto_linklocal>ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 04:f0:21:17:4a:47
            inet6 fe80::6f0:21ff:fe17:4a47%ath0_wlan0 prefixlen 64 scopeid 0x9
            inet 172.16.8.254 netmask 0xffffff00 broadcast 172.16.8.255
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: running
            ssid dritterstock channel 11 (2462 MHz 11b) bssid 04:f0:21:17:4a:47
            regdomain ETSI country DE ecm authmode WPA2/802.11i privacy MIXED
            deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 scanvalid 60
            wme burst -apbridge dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></promisc></hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>



  • I played abit around, but nothign changes…
    I selected now ath0_wlan1 in Interfaces -> assign.

    maybe some of you has an idea how to get wlan running again

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 04:f0:21:17:4a:47
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: running
    pflog0: flags=100 <promisc>metric 0 mtu 33160
    pfsync0: flags=0<> metric 0 mtu 1500
            syncpeer: 224.0.0.240 maxupd: 128 defer: on
            syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
            nd6 options=21 <performnud,auto_linklocal>lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
            nd6 options=21 <performnud,auto_linklocal>ath0_wlan1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 04:f0:21:17:4a:47
            inet6 fe80::6f0:21ff:fe17:4a47%ath0_wlan1 prefixlen 64 scopeid 0x9
            inet 172.16.8.254 netmask 0xffffff00 broadcast 172.16.8.255
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: running
            ssid dritterstock channel 11 (2462 MHz 11b) bssid 04:f0:21:17:4a:47
            regdomain ETSI country DE ecm authmode WPA2/802.11i privacy MIXED
            deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 30 scanvalid 60
            wme burst -apbridge dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></promisc></hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>



  • What version did you upgrade from? You're on 802.11b, which makes me think the combination of config options isn't valid with the driver for newer versions. If you go to Interfaces>WLAN (whatever your WLAN interface is named) and click Save, do you get prompted with any errors? If so, fix them so it's happy with the config.

    If not, how do you have things configured on the interface page there?

    The antenna setting was removed because it didn't actually do anything.



  • Hi, I upgraded from the version before, which I dont know ;)
    (I always use the newest version..)

    There`s no error, only the normal message:

    "The WLAN configuration has been changed.
    The changes must be applied to take effect.
    Don't forget to adjust the DHCP Server range if needed after applying."











Log in to reply