Port forward for internal ftp server in passive mode



  • Hi,
    I have a vsftpd server on an internal host of my lan, thus I have added a nat portward on port 21 to port 21 of my internal ip with autoadd firewall rules. The ftp server works well in active mode but not in passive. What's im wrong ?
    I read around the forum to enable the ftphelp, but I really dont understand how to do that.
    Under Interfaces->wan-> ftphelp I have:
    Disable the userland FTP-Proxy application (enabled)
    Block private networks (enabled)
    Block bogon networks (disabled)

    and under interface->lan->ftphelp I have:
    Disable the userland FTP-Proxy application  (disabled)

    Any help ?



  • http://devwiki.pfsense.org/FTPTroubleShooting
    keyword for a search: passiv +ftp

    Last but not least. Why not switch to SFTP.
    The why
    The how


Log in to reply