WEB configurator simply vanished



  • I've had pfsense running as a firewall for years without issues.
    Today, I come to log into the webconfigurator and it's simply not there.
    I scanned the machine to see if there were any open ports and there aren't any which I think is normal. Never scanned it before.
    I ran a traceroute to make sure my default gateway didn't change by accident or something and it has not, the same pfsense machine is reaching the Internet just fine.

    Wondering what could suddenly cause this to happen?

    I restarted webconfigurator and that made no difference.
    I restarted the firewall and that made no difference.
    I can ssh into it but I've not used the command line much so am not sure what to look for.
    Ssh'd into it, I can see which ports are open but the webconfigurator port isn't in the list.

    I've made no changes for months other than extending the DHCP range and that's why I was logging in, to see what IP a device got.

    When something weird like this happens, I always get a tiny bit nervous wondering if someone has gained access somehow.

    Help!



  • Which version of pfSense?
    Did you try  https://



  • pfSense 2.0-RC1-pfSense



  • I know, it's older but I've not had the chance to upgrade it fearing that some things would break that I don't have the time to fix right now.



  • @mprog:

    I know, it's older but I've not had the chance to upgrade it fearing that some things would break that I don't have the time to fix right now.

    You're not even running a release. You've been saying "I'm afraid to upgrade" for 4.5 years now. 2.0 -> 2.3 would be a big upgrade, but 2.0 RC1 -> 2.0 should have been fine.



  • As I recall, I upgraded at one point and it broke a number of things so I had to downgrade and never got around to it again.

    Either way, are you saying this older version has this problem then and upgrading would fix it? If I don't really need to upgrade, I'd love not to.



  • There's usually not point in debugging old-non-release-versions. If you want support, update to 2.3.

    Check the 2.1, 2.2, 2.3 upgrade guides for things to look for (mostly ipsec and additional packages that might give you issues), backup your configuration and try the upgrade.

    Or better yet, install 2.3 on a new disk, recover the config on it and put it into the production machine. If you can't fix things in time pop the old disk in.



  • I still need to fix the webconfigurator so I can upgrade otherwise, it's going to be extra difficult I think. I do have a backup so maybe that's the route to go as you also suggest.

    Thanks for the input, it's most appreciated.



  • You can probably upgrade via the console upgrade option.

    Reinstall starting with 2.3 and config restore would be easy if you're more comfortable with that.



  • I'm fine with CLI also. I think I've upgraded some devices from CLI once or twice. Just have to find some docs that will show the steps.

    As mentioned, I tried upgrading this particular device a while back and everything broke so I rebuilt it and never touched it since. At worse, I guess I could build a whole new device as suggested then rebuild my rules.

    Still, I'd love to know why webconfigurater simply vanished overnight and there is no service for it now when looking at netstat. Restarting webconfigurator doesn't do it either.



  • So I'll give upgrading a shot.

    Looking all over the net however and cannot seem to find something that looks official, just a lot of folks asking questions, trying things, good and bad. Cannot even find the older versions that I need.

    The official download site doesn't seem to have old versions, the dev site says it should be used by devs only.
    The upgrade information has some mention of going from 1.2.3 to 2.0 but nothing else and no links to older versions.

    I have found this but not sure if 'old' means still usable.
    http://files.nyi.pfsense.org/mirror/downloads/old/

    I want to do a console firmware upgrade from 2.0 RC1 to 2.0, then from there keep upgrading, as far as I can tell.
    I don't have any special packages, only DHCP server is enabled.

    This is installed on an old HP DL360 I believe so even looking in the /old/ list, I'm not sure which version I would need. Still looking on the net for that but I used an ISO to build onto the RAID1 drives.

    uname -mrs

    FreeBSD 8.1-RELEASE-p2 i386

    *** Welcome to pfSense 2.0-RC1-pfSense (i386) on pf5 ***



  • Ok, I've since read that the memstick version is the one to be used with drives. Just pick your architecture.
    I went with;
    http://files.nyi.pfsense.org/mirror/downloads/old/pfSense-memstick-2.0-RELEASE-i386.img.gz

    Weird;
    WARNING! ACHTUNG! DANGER!
    This image is not digitally signed.

    yet, it's coming from a pfsense.org site

    Anyhow, it went through it's upgrade process but… when I logged back in...

    *** Welcome to pfSense 2.0-RC1-pfSense (i386) on pf5 ***

    Same old version as it was before?



  • Starting a new post since this is now a different problem.
    https://forum.pfsense.org/index.php?topic=111449.0

    Thanks for the help.


Log in to reply