Chelsio S320E-CXA Not working - RESOLVED with a Band-Aid



  • Hi All,

    It seems that something was left out of the 2.3 release that is preventing cxgb from working properly with the S320E-CXA.  According to the documentation all hardware supported by the underlying FreeBSD version is supported by PFSense.  This chipset/driver is on the 10.3-RELEASE list.  What do I have to do to get this card to work?  Here are the specific errors I am getting:

    May 6 22:26:13 kernel cxgb_t3fw: could not load firmware image, error 2
    May 6 22:26:13 kernel cxgbc0: Could not find firmware image cxgb_t3fw
    May 6 22:26:13 kernel cxgb_t3fw: could not load firmware image, error 2
    May 6 22:26:13 kernel cxgbc0: Could not find firmware image cxgb_t3fw

    I will provide any other information that is needed.

    These same cards work great on FreeNAS 9.10 which is based on FreeBSD 10.3-RELEASE.

    Thank you for any help that you can provide.



  • That's built into the kernel, should have all the pieces. The Chelsio T520 cards definitely work. Does that exact card work with stock FreeBSD 10.3?



  • I have not tried yet with stock FreeBSD 10.3-RELEASE.  I have tried FreeNAS 9.10 which works fine.  It does complain about needing a newer version of the firmware but the card still works, IE passes frames, fine.  I did manage to dig up an old Chelsio archive site and found the 7.11.0 firmware package.  I dropped that into the firmware directory on FreeNAS and it updated the cards.

    http://service.chelsio.com/legacy.html

    I also booted off SystemRescueCD 4.7.1.  It loaded fw 7.12.0 and the cards linked up.  I didn't try passing any traffic though.

    I have not yet tried to boot back into PFSense to see if the cards will now at least get link.  I will try that in the morning.  I will also give FreeBSD 10.3-RELEASE a shot.

    Is there any other output/logs that you'd be interested in seeing?

    EDIT, Yes, I am working with the exact same physical cards.  There are 2 in the system I am testing.



  • So now PFSense gets link and passes traffic just fine.

    PFSense lacks the ability to update and/or the firmware itself on the S320E-CXA

    The solution, band-aid that it is, is to boot from systemrescuecd, let it update the firmware, and then go for PFSense.

    Wouldn't this be a regression because allegedly it worked in the past?



  • Without knowing why it doesn't update the firmware, I don't know. But that suggests if something you did booted on another OS made it work, that it wouldn't have worked on stock 10.3 either. The driver's completely stock and I don't see any components of it that aren't included.



  • I'll have to see if I can force a firmware downgrade and then try vanilla 10.3-RELEASE.

    Although I am not sure what firmware version I started at so it might be pointless.



  • If 10.3 loaded the firmware the same on the same system, then you rebooted into pfSense, then it would "just work". Unless maybe if you power cycle in between and it loses the firmware update in that process, though I don't think that would be the case. I'm not extremely familiar with the internals of what that driver does with firmware.


Log in to reply