PPPoE Default gateway not set



  • Been using pFsense now for over a year. Flawless! Hardware is a  Dell PowerEdge 2950.

    Just completed the in place upgrade to 2.3 - all looks good but for one thing.

    I have to manually set the default gateway on the WAN interface. WAN interface is PPPoE and credentials log into my Wi-MAX ISP.

    Now, funny thing is, the gateway IP shows up when I give an ifconfig (actual IPs are munged):

    pppoe0: flags=89d1 <up,pointopoint,running,noarp,promisc,simplex,multicast>metric 0 mtu 1492
    inet6 fe80::219:b9ff:fec0:1ffb%pppoe0 prefixlen 64 scopeid 0x7
    inet 69.137.75.31 –> 69.137.55.1 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Any ideas as to why it's not setting the default gw? This used to work a charm before the upgrade.

    It's likely something obvious I'm just not seeing from my Linux user perspective.

    edit: add version info:
    2.3-RELEASE (amd64)
    built on Mon Apr 11 18:10:34 CDT 2016
    FreeBSD 10.3-RELEASE</performnud,auto_linklocal></up,pointopoint,running,noarp,promisc,simplex,multicast>



  • System>Routing, gateway has to be marked as default.



  • Thanks!

    Yea - there was something totally erroneous set as default. Changed that - we'll see how it goes.

    Gads, that wasn't even a BSD vs Linux thing - just simply oblivious….


Log in to reply