Working IPv6 through Cox



  • I recently got IPv6 working through cox. As a side note, I bought my own modem, an SB6190. They had to manually push a firmware update before IPV6 was available.

    Here are the relevant settings:
    Interfaces:
    WAN:
    IPv6 Configuration Type: DHCP6
    DHCP6 Client Configuration:
    X Only request an IPv6 prefix, do not request an IPv6 address
    DHCPv6 Prefix delegation size: 64
    X Send an IPv6 prefix hint

    LAN:
    IPv6 Configuration Type: Track Interface
    IPV6 Interface: Wan
    IPv6 Prefix ID: 0

    Services:DHCPv6 Server & RA
    DHCPv6 Server:
    X Enable DHCPv6 Server on interface LAN
    Range: ::1000 to ::2000 (this can be whatever i'm sure.

    Prefix Delegation Size: 64

    Router Advertisements:
    Router Mode: Managed
    Router Priority: High

    DNS configuration: Same as DHCPv6 server

    This didn't work until I set this to Router Mode: Managed and to Only request an IPv6 prefix.
    In this configuration my WAN interface is given an FE80:: address while my LAN receives a 2600:: address.

    My pc is also given a working ipv6 address:
    Ethernet adapter Ethernet 3:

    Connection-specific DNS Suffix  . :
      IPv6 Address. . . . . . . . . . . : 2600:
      IPv6 Address. . . . . . . . . . . : 2600:
      Temporary IPv6 Address. . . . . . : 2600:
      Link-local IPv6 Address . . . . . : fe80::
      IPv4 Address. . . . . . . . . . . : 10.0.0.154
      Subnet Mask . . . . . . . . . . . : 255.255.255.0
      Default Gateway . . . . . . . . . : fe80::1:1%13
                                          10.0.0.1

    This also passes the ipv6 testing here with a 10/10:
    http://test-ipv6.com/

    Hope this helps you all out! I'm in the Phoenix area.



  • @PertFlavus:

    Interfaces:
    WAN:
    X Only request an IPv6 prefix, do not request an IPv6 address

    Did you find an explanation (and where) for what that the above option does versus leaving it unchecked?

    I have it unchecked on my Cox Cable setup here and haven't found a description of what it does.


  • LAYER 8 Netgate

    Sounds like it does just what it says. Like you, I have that option unchecked. I get a link-local (fe80::) address on WAN. I also get a globally-routeable address that is distinct from my prefix delegation as a /128 on WAN. I'm going to check that box and renew…

    Right. No routable /128 on WAN. Just link-local.

    The PD should be routed by Cox to the link-local address anyway so it shouldn't make any difference.

    Anything that has to listen on the firewall probably ought to come out of the delegation anyway.

    But not having an IPv6 address on WAN from Cox breaks that hop in a traceroute. I really can't see a reason to check that box using Cox.



  • I couldn't get this to issue ipv6 to the rest of my network without checking the option to request the prefix only. This let me assign the ipv6 address to the lan interface as well as the rest of the network.

    I did have to disable IPv6 though because after a while ipv6 would stop working. I couldn't make dns lookups because connections to pfsense's ipv6 address would time out and it effectively broke my internet. And since it happens after some time I'm really not in the mood to troubleshoot it.



  • I tried the settings you two were talking about and it seems to work much better. I still have DNS and ipv6 connectivity after a few hours. Now that I did a reinstall I see that they are basically the defaults too.



  • It may have been you were seeing a Cox modem firmware bug that was impacting IPv6 that has now been fixed. There was some discussion of that bug over at:

    http://www.dslreports.com/forum/coxhsi


Log in to reply