Firewall issue



  • Hello,

    I recently installed pfsense on a computer, and I am running the captive portal with squid/squidGuard.
    My setup is transparent mode and I have the default firewall config. Traffic comes through OPT1 and
    out the WAN side. Administration is done from the LAN side.

    Here is my two main problems.

    First, if I make any changes to the firewall(custom rule), it kills my squid. The only thing that seems
    to fix it is re-installing. I found out what the specific problem was though, when you change the firewall
    config from the gui, for some reason the firewall module doesn't seem to know about squid's addition to
    the firewall rules. Here is the rule that disappears. I found this in /tmp/rules.debug

    rdr on fxp0 proto tcp from any to !(fxp0) port 80 -> 127.0.0.1 port 80

    I could not "re-enable" Squid to get this rule added back, I had to re-install from from the packages menu.

    Second, only proxied traffic is able to get by the gateway now. All other traffic(other than IPSEC), gets
    dropped.

    My version is 1.2.

    -Reggie



  • That sounds a little odd.  I run squid, but not squid guard, with no problems adding rules.  Maybe your install is defective.  backup config and do a fresh install and restore it?  You said you are running 1.2, is it 1.2 rc? (1-4), 1.2 beta, 1.2 final…I run 1.2 final FYI with no issues.



  • I use 1.2-RELEASE.

    I have been through the install process 4 or 5 times with the same result. Are you running yours in transparent mode?

    -Reggie



  • Sorry for the late reply, yes, I'm running it in transparent mode.



  • Moving this to the packages board as it's squid related.


Log in to reply