After update, pfSense never obtains update status.



  • I updated to 2.3_1 yesterday, and pfSense hangs on 'Obtaining update status' in the dashboard, though I don't recall if I checked that yesterday or not.

    I also notice that pfSense never completes retrieving and formatting the list of available packages and returns 'Unable to retrieve package information.'

    Is this an issue with pfSense servers, or if it is local, where should I check?



  • openletter,  Did you check the stickies in the Installation section of the forum?

    https://forum.pfsense.org/index.php?topic=109690.0



  • Thanks, no, I hadn't seen that. However, that thread states:

    'If pfSense-base is present, check the version of pkg' and 'If the version shows 1.7.x on 2.3-RELEASE, reinstall pkg'.

    But for me,pkg info -x pkgoutput:```
    pkg-1.6.2

    
    I also just noticed that thread title is 'Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE' and I did not update from 2.3-RC. I updated from 2.3-RELEASE to 2.3_1.


  • Guessing you're probably read-only mounted. Diag>NanoBSD, switch to permanent rw.



  • I'm using a MicroSD card. Will that setting burn the card out?



  • Why does the default configuration cause problems?



  • If you search the forums, you'll find many threads on the issue of CF R/O vs R/W.

    From my understanding, R/W was made optional to allow for some underlying changes in the file system that were meant to prevent possible corruption in power loss cases.
    My experience has been that pfSense is very robust in self-fixes after power loss, but the development team tracked some edge cases that led to ugly corruption issues.

    As far as burning out your CF in R/W mode, the nano version of pfSense doesn't do any writes to the flash unless you save something explicitly.

    As I say, you can search the forums to get a more explicit description of the issue.  Honestly, I'd think about what it will take to migrate away from CF to SSD or m-SSD as the nano version will disappear sometime in the future.  Don't panic (you probably have a few years before it becomes critical) but SSD and the like are going to supersede CF and make the nano version pretty moot.



  • Keeping it read-write mounted isn't going to burn out anything. It was mounting it rw any time it was necessary anyway.

    nanobsd's always been ro mounted by default, because that was just the nature of how it was designed. But it also required a kernel patch that force unmounted it before the card actually returned that it was safe to do so. While we never confirmed any issues around that, it was unsafe to do so, so that patch was removed. That was fine for most flash media, but turns out some cards are very slow to rw->ro mount without that. Which leads to problems.

    In 2.3, that's creating more issues than it did in the last couple 2.2.x versions. 2.3.1 is permanently rw for all nano.



  • My opinion is that the nano version is completely broken. First is the fact that the default configuration causes pfSense to not function properly. Then, after switching to r/w, the web interface kept becoming unresponsive and crashing, so I rebooted from TTY. On reboot, pfSense could not boot from slice 1, so I booted from slice 2. After booting successfully into slice 2, I tried to copy the image of slice 2 to slice 1, which just causes the interface to crash. It is not clear to me that I can reboot successfully, so I broke down and purchased a 128GB SanDisk Z400s for $40 from Newegg that I'll probably install some time this weekend.



  • Well, on the one hand many (me included) would dispute that nano is "completely broken".
    I have a few in place and while they do require a little different care and feeding, they work very well.

    On the other hand as I wrote earlier, the long term future (years?) for nano is probably limited and a change to full install is one less thing to worry about going ahead.
    Should be a matter of backup your config, install SSD, install pfSense, restore config.

    Let us know how it goes…..



  • Thanks. The install, then upgrade to 2.3_1 went off without a hitch. I previously had pfSense installed onto a very, very old and cheap SSD and it ran without issue for 2 years, right up until the drive failed. Then I switched to Live CD, which was just fine for my use, then that was discontinued, so I tried nano, that was miserable.

    I'll see how long this cheap SanDisk SSD lasts. I've had a lot of their flash media over the years, and nothing has ever failed. Still even use my 15 year-old 256 MB flash drive for transferring small files.


Log in to reply