Squid now installs; doesn't seem to build cache?



  • 1.2.1 is progressing nicely, I read the cvstrac page every day.

    The squid package now installs; gives me an error when starting:

    squid[7814]: Bungled squid.conf line 21: cache_dir aufs /var/squid/cache 9000 16 256
    

    Looks okay to me?  But then I see the /var/log/cache directory is empty.

    Doesn't appear to be built with aufs?

    '--enable-storeio=ufs diskd null'
    

    I tried ufs and diskd but it still doesn't seem to want to start.

    I'm sure I'm missing something obvious… and pointing out the obvious.

    # squid -D
    2008/07/23 18:55:29| parseConfigFile: line 56 unrecognized: 'delay_pools 1'
    2008/07/23 18:55:29| parseConfigFile: line 57 unrecognized: 'delay_class 1 2'
    2008/07/23 18:55:29| parseConfigFile: line 58 unrecognized: 'delay_parameters 1 -1/-1 -1/-1'
    2008/07/23 18:55:29| parseConfigFile: line 59 unrecognized: 'delay_initial_bucket_level 100'
    2008/07/23 18:55:29| parseConfigFile: line 60 unrecognized: 'delay_access 1 allow all'
    

    Thanks!



  • Manually editing /usr/local/etc/squid/squid.conf to:

    cache_dir diskd /var/squid/cache 9000 16 256
    

    and then starting it:

    /usr/local/sbin/squid -D
    

    Seemed to work! Cool!



  • Hi,

    You only have this issue (with builds after the 24th July) if you install squidGuard after install squid.

    squid install .21 of the package but squidGuard comes along afterwards and install .20 over it which has an issue.

    Regards,

    Darren



  • Interesting.  I've never used squidGuard so I don't think that applied in my case.  Either way; the problem has not returned with subsequent builds so all is good.



  • Squid was installed, but how can i go to the 'log' & edit it?
    I search for whole days, there's no place that i can edit it  ???



  • I installed Squid and SquidGuard… and had the problem noticed by adrianhensler ...

    I uninstalled them and just reinstalled Squid : All went right ;D !


Log in to reply