[RESOLVIDO]Problema SQUID[não transparente] + Sistema ERP Protheus em DATACENTER



  • Boa noite pessoal. Deixa eu descrever meu cenário: Uso pfsense 2.3 + squid + squidguard

    Bom, não uso proxy transparente, devido algumas falhas de segurança, sendo assim todo usuário tem eu navegador marcado o servidor proxy. A regra default da LAN do pfsense eu desativo, e crio uma regra onde cada pessoa só poderá acessar a internet se passar pelo proxy, como podem ver na imagem em anexo. Até ai, tudo perfeito, navegação da internet está ok. Porém meu bendito sistema não funciona, já criei e recriei várias regras para poder liberar o acesso e nada!!! Só funciona quando eu libero a regra default da LAN do pfsense.

    Meu sistema ERP Protheus da TOTVS, fica em datacenter, deles próprio, digas-se de passagem.
    Em cada computador tenho apenas o smartclient do mesmo configurado apontando para o datacenter. Como descrevo aqui abaixo. Mais sempre me dá o bendito erro é o da 2021. Não sei mais qual regra criar, aonde liberar. Pelo PFtop, ele sempre fala que o endereço buscado pelo meu endereço de rede é o da porta 2021. Mais não vai.

    [PRODUÇÃO]
    server=18x.xxx.xxx.xxx
    port=2021

    [TESTTEE]
    server=18x.xxx.yyy.yyy
    port=2235

    [WORK]
    server=18x.xxx.xxx.xxx
    port=4621

    [BALANCE1]
    server=18x.xxx.xxx.xxx
    port=20212

    [BALANCE2]
    server=18x.xxx.xxx.xxx
    port=20213

    [BALANCE3]
    server=18x.xxx.xxx.xxx
    port=20214

    [B.I]
    server=nome.ficticio.com.br
    ;server1=18x.xxx.xxx.xxx
    port=20219

    [ESQUEMA]
    server=18x.xxx.xxx.xxx
    port=4621




  • Crie uma regra NAT com os ips da totvs
    crie uma outra com as portas.

    Ai antes da regra do proxy, crie uma regra que vem dos com a aliase dos ips para as portas da totvs.



  • @guitarcleiton:

    Crie uma regra NAT com os ips da totvs
    crie uma outra com as portas.

    Ai antes da regra do proxy, crie uma regra que vem dos com a aliase dos ips para as portas da totvs.

    Certo, deixa só vê se intendi…

    Vou ter que criar:

    1. Regra NAT com os Ips da TOTVs, beleza, mais a regra NAT é como encaminhamento? Se sim, vou ter que direcionar qual ip de cada pc que vai acessar?  :o Pois é minha empresa inteira que acessa ia ter que fazer 1 pra cada 1.

    2. Regra com as portas do Protheus, mais é encaminhamento também? Vou direcionar pra onde?

    3)A regra para colocar o Alias, é na LAN? Liberando a origem LAN subnet > destino ao Alias Ips totvs > Porta: Alias portas totvs?



  • Perdão amigo, escrevi na correria pensei em uma coisa e digitei outra.

    corrigindo:

    Onde citei "regra Nat" era para ser "Aliase"

    Vá em Firewall > aliases

    Crie uma aliase com os IPs da Totvs
    Crie outra aliase com as Portas da Totvs

    Vá em Firewall > rules

    Em LAN crie a regra semelhante a do seu proxy acima dela e em "Destination" insera a aliease dos ips e em ports a aliase com as portas



  • Se estiver passando pelo proxy deve cadastrar as porta 2021 em ACL, Safe Ports.



  • @guitarcleiton:

    Perdão amigo, escrevi na correria pensei em uma coisa e digitei outra.

    corrigindo:

    Onde citei "regra Nat" era para ser "Aliase"

    Vá em Firewall > aliases

    Crie uma aliase com os IPs da Totvs
    Crie outra aliase com as Portas da Totvs

    Vá em Firewall > rules

    Em LAN crie a regra semelhante a do seu proxy acima dela e em "Destination" insera a aliease dos ips e em ports a aliase com as portas

    Entendi, porém já tinha feito e mesmo assim não funcionou. Como pode ver na foto.
    Como o amigo Tomas Waldow, havia citado abaixo, eu tinha marcado la em ACL, Safe Ports. Já havia colocado a porta 2021 sozinha, todas as portas do sistema e nada. Podem conferir que pra desencargo de consciência coloquei todas, nas duas opções.




  • Tem que ver se as redes/IPs que cadastrou estão corretos.
    Tente filtrar o IP de origem no System Logs, Firewall para ver se está sendo bloqueado e qual destino está indo.



  • @Tomas:

    Tem que ver se as redes/IPs que cadastrou estão corretos.
    Tente filtrar o IP de origem no System Logs, Firewall para ver se está sendo bloqueado e qual destino está indo.

    BINGO!

    Maravilha chefe. Estava tão focado no problema que não me lembrava se quer, deste recurso. Visualizei o mesmo e vi que estava tudo correto com o ALIAS criado dos IPS e Portas, porém tinha uma regra UDP, que pega o IP do firewall na Porta 53, estava bloqueando lá. Adicionei este IP junto aos ALIAS dos IPS de destino, e adicionei a porta 53 junto ao ALIAS das portas de destino liberadas para o PROTHEUS. Fiz isso a regra funcionou e meu firewall liberou o acesso.

    OBRIGADO À COLABORAÇÃO DE TODOS!

    RESOLVIDO! ;D



  • @kleyverson:

    @Tomas:

    Tem que ver se as redes/IPs que cadastrou estão corretos.
    Tente filtrar o IP de origem no System Logs, Firewall para ver se está sendo bloqueado e qual destino está indo.

    BINGO!

    Maravilha chefe. Estava tão focado no problema que não me lembrava se quer, deste recurso. Visualizei o mesmo e vi que estava tudo correto com o ALIAS criado dos IPS e Portas, porém tinha uma regra UDP, que pega o IP do firewall na Porta 53, estava bloqueando lá. Adicionei este IP junto aos ALIAS dos IPS de destino, e adicionei a porta 53 junto ao ALIAS das portas de destino liberadas para o PROTHEUS. Fiz isso a regra funcionou e meu firewall liberou o acesso.

    OBRIGADO À COLABORAÇÃO DE TODOS!

    RESOLVIDO! ;D

    Amigo,

    se possível coloque resolvido no assunto do tópico

    que bom que solucionou o problema!

    abraços

    Diego



  • @didonsom:

    @kleyverson:

    @Tomas:

    Tem que ver se as redes/IPs que cadastrou estão corretos.
    Tente filtrar o IP de origem no System Logs, Firewall para ver se está sendo bloqueado e qual destino está indo.

    BINGO!

    Maravilha chefe. Estava tão focado no problema que não me lembrava se quer, deste recurso. Visualizei o mesmo e vi que estava tudo correto com o ALIAS criado dos IPS e Portas, porém tinha uma regra UDP, que pega o IP do firewall na Porta 53, estava bloqueando lá. Adicionei este IP junto aos ALIAS dos IPS de destino, e adicionei a porta 53 junto ao ALIAS das portas de destino liberadas para o PROTHEUS. Fiz isso a regra funcionou e meu firewall liberou o acesso.

    OBRIGADO À COLABORAÇÃO DE TODOS!

    RESOLVIDO! ;D

    Amigo,

    se possível coloque resolvido no assunto do tópico

    que bom que solucionou o problema!

    abraços

    Diego

    Opa Diego, perdoe-me amigo. Já fiz. Obrigado


Log in to reply