Can't Install 2.3



  • I'm hoping this is something silly that I'm overlooking. I recently purchased a QOTOM machine (the BIOS detects the mSATA and memory fine), but I can't get it to boot from the USB. A little background and some of the steps I've tried:

    • Mac OS X El Cap

    • Downloaded CE 2.3 64-bit ISO and verified the CHECKSUM

    • I've tried formatting the USB as FAT and both MBR and GUID Partition Map

    • Then I used dd if=/pfsense.iso of=/dev/mydisk bs=1m then ejected the disk

    • Put the drive into the machine and set the boot option to the USB drive

    • Extended the wait time to 1000 seconds

    In the BIOS the Boot Option is UEFI: Generic Flash Disk. However, after I restart the machine all I get is a "Reboot and Select proper Boot device". I've tried multiple USB drives and can't seem to get it to boot in the drive. Any ideas?

    Thanks!



  • If you're using a USB flash drive, you need the memstick not the ISO. The ISO is for optical media only. Otherwise looks like you have the process down.



  • Should I format as a MBR or GUID Partition?



  • You're writing out a disk image, no need to format it at all. The dd will overwrite anything you format on it.



  • Does the console type matter?



  • Yes. If you have a VGA console on the target hardware, use the VGA version. If it's a serial console, serial.



  • I do not know if this is related but I also had issues installing 2.3, so I decided to installed 2.2.4 using the memstick method and it worked.



  • I used the memstick version and let it run for a few minutes and it eventually recognized it; up and running now.

    Thanks for the help!


Log in to reply