SquidGuard + LDAP + GroupsACL - Regras do GroupsACL não estão Funcionando.



  • Bom dia pessoal,

    Estou começando a utilizar o PFsense agora, montem um servidor para utilizar o servidor como Firewall e Proxy com autenticação no LDAP.
    Em meu Proxy Server, selecionei o tipo de autenticação como LDAP com as devidas configurações (Nas estações, quando vou acessar alguma pagina, esta autenticando pelo LDAP corretamente.

    No Custom Options (Aba Geral - Proxy Server), coloquei a seguinte configuração para que seja direcionado o proxy para SquidGuard:

    url_rewrite_program /usr/pbi/squidguard-devel-amd64/bin/squidGuard -c /usr/pbi/squidguard-devel-amd64/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0

    NO SquidGuard, criei meus Gruops de ACL, porem nas estações, não esta barrando nenhuma das configurações de ACL (SquidGuard esta Started) no Log da Configuração do Proxy está em anexo (não aparece as regras de ACL criadas no SquidGuard).
    squid.txt



  • Qual versão do pfSense? Não precisa colocar manualmente, o squidGuard já faz a inserção dessa integração.



  • @Tomas:

    Qual versão do pfSense? Não precisa colocar manualmente, o squidGuard já faz a inserção dessa integração.

    A versão do pfSense é 2.2.6-RELEASE (amd64)

    • Squid 4.3.10
    • squidGuard 1.9.18

    Retirei as configurações manuais da integração e o problema continua….



  • Tem pelo menos uma Target criada?



  • @Tomas:

    Tem pelo menos uma Target criada?

    A imagem em anexo mostra que existe Target criada, estão todas como deny para todos GroupsACL e na CommonACL.

    No arquivo de configuração do Squid, não esta indo as configurações do SquidGuard, abaixo mostra o final do arquivo.

    acl password proxy_auth REQUIRED

    http_access allow password localnet
    http_access allow password allowed_subnets

    Default block all to be sure

    http_access deny all




  • @marcospiocolojr:

    @Tomas:

    Tem pelo menos uma Target criada?

    A imagem em anexo mostra que existe Target criada, estão todas como deny para todos GroupsACL e na CommonACL.

    No arquivo de configuração do Squid, não esta indo as configurações do SquidGuard, abaixo mostra o final do arquivo.

    acl password proxy_auth REQUIRED

    http_access allow password localnet
    http_access allow password allowed_subnets

    Default block all to be sure

    http_access deny all

    acesse o console do pfsense e na opção 8, digite squid -k reconfigure e veja se aparece alguma mensagem de erro.

    Abaixo alguns tutoriais de como configurar o squid + squidguard com autenticação LDAP

    http://www.pfsense-br.org/blog/2012/01/pfsensesquidsquidguard-logando-no-active-directory/
    http://pauloxmachado.blogspot.com.br/2012/02/pfsense-20-squidguard-autenticacao-ad.html
    http://pauloxmachado.blogspot.com.br/2012/07/pfsense-201-squid-squidguard.html

    Abraços

    Diego



  • @didonsom:

    @marcospiocolojr:

    @Tomas:

    Tem pelo menos uma Target criada?

    A imagem em anexo mostra que existe Target criada, estão todas como deny para todos GroupsACL e na CommonACL.

    No arquivo de configuração do Squid, não esta indo as configurações do SquidGuard, abaixo mostra o final do arquivo.

    acl password proxy_auth REQUIRED

    http_access allow password localnet
    http_access allow password allowed_subnets

    Default block all to be sure

    http_access deny all

    acesse o console do pfsense e na opção 8, digite squid -k reconfigure e veja se aparece alguma mensagem de erro.

    Abaixo alguns tutoriais de como configurar o squid + squidguard com autenticação LDAP

    http://www.pfsense-br.org/blog/2012/01/pfsensesquidsquidguard-logando-no-active-directory/
    http://pauloxmachado.blogspot.com.br/2012/02/pfsense-20-squidguard-autenticacao-ad.html
    http://pauloxmachado.blogspot.com.br/2012/07/pfsense-201-squid-squidguard.html

    Abraços

    Diego

    Bom dia Diego,

    O comando squid - k reconfigure esta retornando a seguinte mensagem:

    2016/05/16 09:23:46| aclParseAclLine: WARNING: empty ACL: acl throttle_exts urlpath_regex -i "/var/squid/acl/throttle_exts.acl"
    2016/05/16 09:23:46| parseConfigFile: squid.conf:73 unrecognized: 'url_rewrite_bypass'

    Fiz a revisão do servidor conforme os três tutoriais e não resolveu. O sistema está autenticando no Squid, só não esta validando as regras criadas no SquuidGruard, no Log / Porxy Config, não mostra nenhuma das ACL's criadas.



  • Boa tarde marcospiocolojr!

    Estou com um problema semelhante ao seu e estamos discutindo no tópico https://forum.pfsense.org/index.php?topic=111666.0

    Dê uma olhada nas configurações que coloquei no tópico, talvez elas possa te ajudar.  :)



  • @marcospiocolojr:

    @didonsom:

    @marcospiocolojr:

    @Tomas:

    Tem pelo menos uma Target criada?

    A imagem em anexo mostra que existe Target criada, estão todas como deny para todos GroupsACL e na CommonACL.

    No arquivo de configuração do Squid, não esta indo as configurações do SquidGuard, abaixo mostra o final do arquivo.

    acl password proxy_auth REQUIRED

    http_access allow password localnet
    http_access allow password allowed_subnets

    Default block all to be sure

    http_access deny all

    acesse o console do pfsense e na opção 8, digite squid -k reconfigure e veja se aparece alguma mensagem de erro.

    Abaixo alguns tutoriais de como configurar o squid + squidguard com autenticação LDAP

    http://www.pfsense-br.org/blog/2012/01/pfsensesquidsquidguard-logando-no-active-directory/
    http://pauloxmachado.blogspot.com.br/2012/02/pfsense-20-squidguard-autenticacao-ad.html
    http://pauloxmachado.blogspot.com.br/2012/07/pfsense-201-squid-squidguard.html

    Abraços

    Diego

    Bom dia Diego,

    O comando squid - k reconfigure esta retornando a seguinte mensagem:

    2016/05/16 09:23:46| aclParseAclLine: WARNING: empty ACL: acl throttle_exts urlpath_regex -i "/var/squid/acl/throttle_exts.acl"
    2016/05/16 09:23:46| parseConfigFile: squid.conf:73 unrecognized: 'url_rewrite_bypass'

    Fiz a revisão do servidor conforme os três tutoriais e não resolveu. O sistema está autenticando no Squid, só não esta validando as regras criadas no SquuidGruard, no Log / Porxy Config, não mostra nenhuma das ACL's criadas.

    veja essa linha
    2016/05/16 09:23:46| parseConfigFile: squid.conf:73 unrecognized: 'url_rewrite_bypass'

    esta com erro no squid conf, revise as configurações

    A integração com o Squidguard é incluída automaticamente em integrations , conforme imagem abaixo.

    ![Sem título.png](/public/imported_attachments/1/Sem título.png)
    ![Sem título.png_thumb](/public/imported_attachments/1/Sem título.png_thumb)



  • Bom dia a todos,
    O meu Squid e SquiGuard não integra na ultima versão do pfSense2.3 64bit.

    Já refiz toda a configuração, o comando squid - k reconfigure não gera erro.

    Abraços.


Log in to reply