WAN Pulls DHCP - No Internet Access - Random



  • I am pulling my hair out over this one, and I dont know if its config or hardware but I am about to give up and go Edge Router Lite so the wife doesn't kill me. This is the same problem I had originally, posted here: https://forum.pfsense.org/index.php?topic=105420.msg587542#msg587542 I have just been dealing with it.

    I have this box: http://www.aliexpress.com/store/product/2015-mini-pc-Qotom-T4010P-with-core-i3-Dual-H-D-M-I-6-serial-ports/108231_32549490575.html

    Setup:
    Internet -> SB6183 Cable Modem (Comcast) -> Pfsense Router -> PC

    Pfsense:
    Version 2.3.x amd64

    Pfsense hardware:
    Qotom-T4010P (i3-4010U)
    2 * Intel 82574L - 10/100/1000 Controller
    WAN:
    DHCP External IPV4 & IPV6 – 67.x.x.x

    LAN:
    192.168.1.1/24

    Ever since the first install PfSense will randomly choose to work, or not. If I do get it working, it will be fine (usually) until a reboot, then it fails to work again. To get it working again, I generally just reset to defaults and power cycle everything over and over until it chooses to work. If I hook the modem into my PC, works fine everytime.

    Usually the WAN will pull the DHCP IPv4 (sometimes it will just pull IPv6 only, or have to go through a renew cycle to pull IPv4) but I am unable to ping out. This is on a basic default wizard install, unchecking the two "Block" boxes on WAN for good measure.



  • This may sound obvious, but have you tried setting your WAN address statically? From what you describe, your cable modem is assigning the address to your WAN interface, is this so?


  • LAYER 8 Global Moderator

    so your wan has an IP, can you ping your gateway…  If you have an IP.. is your lack of internet just a dns related problem?



  • So, oddly now I can not even pull an IPV4 IP through DHCP.

    Other than that, I dont think it is DNS only because inside of the router I was unable to ping 8.8.8.8 (when I did have DHCP).

    Presently they just end up pending:

    And Gateways page:

    And WAN settings:

    I have not tried setting static, but when it pulls DHCP it appears correct.



  • You're losing your IP on WAN. What logs do you have from dhclient in your DHCP log?



  • Seems pretty straightforward now for not getting a lease anyway:

    May 16 09:56:33 dhclient FAIL
    May 16 09:56:49 dhclient ARPSEND
    May 16 09:56:51 dhclient ARPCHECK
    May 16 09:58:08 dhclient FAIL
    May 16 09:59:24 dhclient FAIL
    May 16 10:00:40 dhclient FAIL


Log in to reply