Please test wireless in latest snapshots



  • We made some changes to the kernel configuration.  Please retest the latest 1.2.1 snapshots that where just copied up.

    Thanks!!



  • can i update my embedded or should it be fresh install?



  • Hello,

    Running 1.2.1 snapshot July 24 23.13 running on Alix (full version on Microdrive) is working now with Wireless. Previous versions of 1.2.1 did not work with WiFi,

    regards,
    Hans



  • Upgraded this morning to this version: pfSense-Full-Update-1.2.1-TESTING-SNAPSHOT-20080724-2313

    Still no go for wireless client. It say connected fine but cant access internet though pfSense. I post some screenshot to explain some.










  • seems to fire up ok using an atheros card and do some basic browsing, but

    pfsense:~#  athstats
    /libexec/ld-elf.so.1: Shared object "libc.so.6" not found, required by "athstats"

    also straight after rebooting managed to get the dreaded

    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)
    ath0: stuck beacon; resetting (bmiss count 4)

    and

    ath0: ath_chan_set: unable to reset channel 6 (2437 Mhz, flags 0x490 hal flags 0x150)

    more testing todo and findling with settings



  • Running the snapshot built "Fri Jul 25 13:43:33 EDT 2008". Wireless doesn't work when bridged with LAN. However, it does work if setup on it's own subnet.



  • Did some testing, not sure if anyone found this before. Anyway…

    After bridging the Wireless with the LAN, the following is appears when running dmesg:

    bridge0: invalid MTU for re0

    I checked the bridge0 interface, and it had an MTU of 2290, just like ath0. Obviosly that MTU is invalid for a standard ethernet NIC, thus it refuses to join bridge.

    From there, I attempted to set ath0 (Wireless) MTU via pfSense webConfigurator, but the MTU setting was ignored. So, I manually set it via the shell. However, bridge0 still had an MTU of 2290 after changing ath0's MTU.

    Finally, I decided to manually destroy bridge0, and recreate it. Now, that I had ath0 set with an MTU of 1500, both ath0 and re0 would have the same MTU.

    ifconfig bridge0 destroy
    ifconfig bridge create
    ifconfig bridge0 addm ath0 addm re0 up

    After recreating the bridge with both devices having an MTU of 1500, the bridge worked properly. The only left was to create a firewall rule to allow traffic in on the Wireless interface, which I did via the webConfigurator.

    Hopefully the above is of use to somebody.



  • @JTY:

    Did some testing, not sure if anyone found this before. Anyway…

    After bridging the Wireless with the LAN, the following is appears when running dmesg:

    bridge0: invalid MTU for re0

    I checked the bridge0 interface, and it had an MTU of 2290, just like ath0. Obviosly that MTU is invalid for a standard ethernet NIC, thus it refuses to join bridge.

    From there, I attempted to set ath0 (Wireless) MTU via pfSense webConfigurator, but the MTU setting was ignored. So, I manually set it via the shell. However, bridge0 still had an MTU of 2290 after changing ath0's MTU.

    Finally, I decided to manually destroy bridge0, and recreate it. Now, that I had ath0 set with an MTU of 1500, both ath0 and re0 would have the same MTU.

    ifconfig bridge0 destroy
    ifconfig bridge create
    ifconfig bridge0 addm ath0 addm re0 up

    After recreating the bridge with both devices having an MTU of 1500, the bridge worked properly. The only left was to create a firewall rule to allow traffic in on the Wireless interface, which I did via the webConfigurator.

    Hopefully the above is of use to somebody.

    Hi,

    thank you…
    I can verify this... I had the exact same problem, manually changing the MTU and recreating the Bridge worked perfectly...

    Now I can finally use Itunes remote on my Ipod  ;D



  • after resetting the interface config and this time just choosing 802.11g and running as an accesspoint I've had no more problems, other than the athstats error.

    Thanks guys t is good to finally have a usable wireless connection.



  • @JTY:

    After bridging the Wireless with the LAN, the following is appears when running dmesg:

    bridge0: invalid MTU for re0

    I checked the bridge0 interface, and it had an MTU of 2290, just like ath0.

    How did your ath0 get a MTU of 2290? I just setup a LAN ath bridged to WAN and did not see that, it defaults to 1500.



  • @cmb:

    @JTY:

    After bridging the Wireless with the LAN, the following is appears when running dmesg:

    bridge0: invalid MTU for re0

    I checked the bridge0 interface, and it had an MTU of 2290, just like ath0.

    How did your ath0 get a MTU of 2290? I just setup a LAN ath bridged to WAN and did not see that, it defaults to 1500.

    I had done a fresh install of 1.2.1 TESTING, and setup OPT1 (ath0) during install. Once I rebooted, ath0 was set with an MTU of 2290.



  • i am running build built on Sat Jul 26 21:27:41 EDT 2008

    When I was configuring the interface I had to manualing change the mtu to 1500

    After I changed it I had no more problems.

    I tried to reproduce the error by deleting the interface and reconfiguring it and nothing seemed to reproduce the change in mtu to 2290.

    I then remembered I initially tried to configure turbo G in the wireless configuration>standard drop down menu.  And used channel 6 channel list, which is list as a turbo G channel.

    When I configure my card to these settings I get this

    ifconfig ath0
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    ether 00:11:95:c2:27:a9
    inet6 fe80::211:95ff:fec2:27a9%ath0 prefixlen 64 scopeid 0x3
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
    ssid TAMU channel 6 (2437 Mhz 11g) bssid 00:11:95:c2:27:a9
    authmode WPA privacy MIXED deftxkey 2 AES-CCM 2:128-bit txpower 31.5
    scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi11g 7
    roam:rate11g 5 pureg protmode RTSCTS wme burst dtimperiod 1

    Note even though turbo G is listed on the dropdown menu's it is not supported in freebsd 7(last line in man pages).

    I don't have time to confirm my last statement but I believe I read this about a week ago and I doubt it has changed since then.

    Hope this helps.</hostap></up,broadcast,running,simplex,multicast>



  • OK. I just tried deleting the OPT1 (ath0), then rebooting. After rebooting, I recreated the interface, and once again it was set with an MTU of 2290. And, no I'm not using Turbo mode.



  • Installed the pfSense-Full-Update-1.2.1-TESTING-SNAPSHOT-20080727-1206

    I ran the ifconfig command and got this;
    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    fxp1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 2290
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290

    This is from 1.2 -stable ifconfig log. (works)

    fxp0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    fxp1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
    pfsync0: flags=41 <up,running>mtu 2020
    pflog0: flags=100 <promisc>mtu 33208
    enc0: flags=0<> mtu 1536
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500</up,broadcast,running,simplex,multicast></promisc></up,running></up,loopback,running,multicast></up,broadcast,running,promisc,simplex,multicast></up,broadcast,running,simplex,multicast></up,broadcast,running,promisc,simplex,multicast></up,broadcast,running,simplex,multicast></up,loopback,running,multicast></up,broadcast,running,promisc,simplex,multicast></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast>



  • yeah it won't let me bridge my wireless with my LAN either, i mean it says it does it, but then it just sits on "learning" in the Interfaces tab in the "Bridge (bridge0)" category.

    EDIT: Update, about 20-30 mins after bridging the connections unsuccessfully the router rebooted on it's own which worried me, but then upon loading the connections seem have to successfully bridge!



  • Updated to the latest snapshot, and the problem continues. I have done further testing on this. When booting up the interface is now showing an MTU of 1500. However, after switching to Access Point mode, it automatically changes MTU to 2290. (Disregard the IP, I tested without bridging so I could try to determine which feature/function caused the MTU to change.)

    Before enabling AP mode:

    ifconfig ath0

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 00:c0:a8:c1:6b:82
            inet6 fe80::2c0:a8ff:fec1:6b82%ath0 prefixlen 64 scopeid 0x2
            inet 192.168.2.1 netmask 0xffffffff broadcast 192.168.2.1
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
            status: no carrier
            ssid GoatsBlood channel 1 (2412 Mhz 11g)
            authmode OPEN privacy OFF txpower 31.5 bmiss 7 scanvalid 60 bgscan
            bgscanintvl 300 bgscanidle 250 roam:rssi11g 7 roam:rate11g 5
            protmode OFF burst

    ifconfig ath0

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:c0:a8:c1:6b:82
            inet6 fe80::2c0:a8ff:fec1:6b82%ath0 prefixlen 64 scopeid 0x2
            inet 192.168.2.1 netmask 0xffffffff broadcast 192.168.2.1
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
            ssid GoatsBlood channel 1 (2412 Mhz 11g) bssid 00:c0:a8:c1:6b:82
            authmode WPA privacy MIXED deftxkey 2 TKIP 2:128-bit txpower 31.5
            scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250 roam:rssi11g 7
            roam:rate11g 5 protmode OFF burst -apbridge dtimperiod 1</hostap></up,broadcast,running,simplex,multicast></up,broadcast,running,simplex,multicast>



  • It's definitely Access Point which is causing the MTU to be 2290. If I switch the interface to Ad-Hoc, the MTU is 1500. The moment I switch it back to Access Point, it becomes 2290. My guess is, this is some behavior in the driver itself. Perhaps pfsense could do a 'ifconfig ath0 mtu 1500' after setting the interface parameters.



  • We commited a change to enforce mtu 1500.  Please try a recent snapshot.



  • I have upgraded to the latest RC1 snapshot, and the problem still continues. Once Access Point is enabled, ath0 changes MTU to 2290.



  • I decided to ask on the freebsd-net mailing list, and the response I got was, that 2290 is the default MTU for 802.11.



  • Any chance hostapd is resetting the MTU to 2290? I just looked at it's source code, and it appears that it may be setting it (see line 86), http://hostap.epitest.fi/hostapd/devel/hostapd_8h-source.html and (see line 241) http://hostap.epitest.fi/hostapd/devel/driver__bsd_8c-source.html.



  • weird… the last ifconfig we run on bringing up a wireless card is now 'mtu 1500'. My ath card hasn't shown this behavior in hostap mode, it's always shown 1500 without this recent change so it's not an issue with every ath card.

    If anyone finds additional information on this please let us know. I'll be doing more wireless testing as time permits over the next week.



  • Ok heres the deal with me. (20080730-0226)

    With no security It works fine, I get an IP address, With WEP It also works fine.

    As soon as I enable WPA It will never connect. Even after I disable WPA and either choose no security or wep it still deos NOT work.

    Can anyone else test with WEP or no security on initial install BEFORE enabling WPA to confirm it's the same with other hardware?

    I have not had a chance to look at the MTU in this process, but if it does happen only when WPA get's turned on it may point us in the correct direction.

    (Utilizing a Cisco ABG card in an Acer5620z Laptop.)

    Many thanks,
    Tom



  • pfSense-Full-Update-1.2.1-RC1-20080730-0232

    mtu 2290 on ath0 and bridge0



  • THANK YOU!

    ifconfig ath1 mtu 1500
    ifconfig bridge0 destroy
    ifconfig bridge create
    ifconfig bridge0 addm ath1 addm axe0 up
    (where axe0 is my LAN interface and ath1 is my Wireless (opt1) interface)

    Works perfectly!

    NOTE If you do not have any security or WEP the MTU does not set itself to 2290 so wherever the problem it is, it's only when you enable WPA. Hopefully they can find the piece of code, or create some to set the interface MTU teardown the bridge and recreate!!

    @JTY:

    Did some testing, not sure if anyone found this before. Anyway…

    After bridging the Wireless with the LAN, the following is appears when running dmesg:

    bridge0: invalid MTU for re0

    I checked the bridge0 interface, and it had an MTU of 2290, just like ath0. Obviosly that MTU is invalid for a standard ethernet NIC, thus it refuses to join bridge.

    From there, I attempted to set ath0 (Wireless) MTU via pfSense webConfigurator, but the MTU setting was ignored. So, I manually set it via the shell. However, bridge0 still had an MTU of 2290 after changing ath0's MTU.

    Finally, I decided to manually destroy bridge0, and recreate it. Now, that I had ath0 set with an MTU of 1500, both ath0 and re0 would have the same MTU.

    ifconfig bridge0 destroy
    ifconfig bridge create
    ifconfig bridge0 addm ath0 addm re0 up

    After recreating the bridge with both devices having an MTU of 1500, the bridge worked properly. The only left was to create a firewall rule to allow traffic in on the Wireless interface, which I did via the webConfigurator.

    Hopefully the above is of use to somebody.



  • Loaded the pfSense-Full-Update-1.2.1-RC1-20080804-0805

    After reboot i had no OPT1 interface associated. I reqoqnize that one and went in and set the channel to 6 maually then it got associated (is was set as Auto by default). This the error found in log before i set the channel: kernel: ath0: unable to reset hardware; hal status 12. I have a feeling that WPA Pairwise cant be handle by any client. Is now set to TKIP mode now, which works for me.

    The MTU is fixed now i think, all was at 1500 after reboot. Wireless client (WinXP) connected and I can surf from it. Thanks again for all your works for this GREAT firewall/router. Ill keep try updating to newer version whenever thare time for it and report back unsuall stuff from this machine and this newbie user :p

    Wireless works …. wiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii  :P

    Oh anotherthing, when entering the Status\Traffic Graph, when graphic graph is showing, try click on Status\Traffic Graph again. Menu dont show fully.



  • Wireless is now working for me.



  • i hate to break the party but my wireless still wont work. mtu is 1500, security with wpa2/aes and i don't even see the wireless network in the list on my xp client. interface status for wireless says 'no carrier'



  • @covex:

    i hate to break the party but my wireless still wont work. mtu is 1500, security with wpa2/aes and i don't even see the wireless network in the list on my xp client. interface status for wireless says 'no carrier'

    Goto "Interface" menu and try set your OPT1 channel manually (1-11), then goto Status+interface and check afterward if you still get no carrirer.



  • Goto "Interface" menu and try set your OPT1 channel manually (1-11), then goto Status+interface and check afterward if you still get no carrirer.

    it worked, now i can see the wireless network from my laptop but i still can't conect. well it connects but pfsense wont give dhcp info to the laptop. setting static ip is not helping.
    i can get dhcp info through stand alone ap connected to pfsense no peroblem though.



  • I can confirm the same problem when bridging LAN and WiFi with 1.2.1-RC1 / built on Wed Aug 6.

    My notebook is connected, but no DHCP lease. So I tried with static IP assignment, no ping…

    Regards



  • same here. alix2c3, wistron cm9, wifi bridged to lan.



  • I'm running a build from the 10th, and no problems with wireless.



  • I run pfSense-Full-Update-1.2.1-RC1-20080810-1453, no problem with Wireless



  • Hi everybody,

    I have still problem with bridging.
    If LAN interface is down, WLAN won't work. If I plug ethernet cable, everything is working fine again!

    Hope that helps

    Regards



  • This isnt a bug. This has always been that way.
    If one interface of a bridge is down, the whole bridge will be down.



  • Really, I never saw this problem with 1.2…

    But I trust you. Any tips to avoid this (except plugging something  ;))?



  • I'm not sure about 1.2
    I only remember reading about it.
    A quick search brought this post up: http://forum.pfsense.org/index.php/topic,2131.msg12397.html#msg12397

    Well you can always plug a dummy switch into it ;)
    The only alternative i see is not to use a bridge and route :)



  • Thanks GruensFroeschli!
    I have to buy a switch now :)



  • upgraded to the latest image Aug 14th with the same result. i can see my wifi but laptop is not able to get any dhcp info from pfsense and setting up static wont help either.
    again, separate ddwrt ap connected to pfsend distributes dhcp no problem.



  • @GruensFroeschli:

    I'm not sure about 1.2
    I only remember reading about it.
    A quick search brought this post up: http://forum.pfsense.org/index.php/topic,2131.msg12397.html#msg12397

    Well you can always plug a dummy switch into it ;)
    The only alternative i see is not to use a bridge and route :)

    You could also use mad geek skillz to wire a link-up plug. Check out the ethernet loopback plug schematics here:
    http://www.ossmann.com/5-in-1.html


Log in to reply