Please test wireless in latest snapshots



  • @GruensFroeschli:

    I'm not sure about 1.2
    I only remember reading about it.
    A quick search brought this post up: http://forum.pfsense.org/index.php/topic,2131.msg12397.html#msg12397

    Well you can always plug a dummy switch into it ;)
    The only alternative i see is not to use a bridge and route :)

    You could also use mad geek skillz to wire a link-up plug. Check out the ethernet loopback plug schematics here:
    http://www.ossmann.com/5-in-1.html



  • How do i know if the "Turbo" mode is functioning and active? Running: pfSense-Full-Update-1.2.1-RC1-20080815-2044

    Is thare a command to check with? (webgui command)

    Thanks



  • Do you mean 802.11a turbo?
    To test the speed, the best is to have 2 computers on both sides of the wireless link and use iperf http://www.noc.ucf.edu/Tools/Iperf/ to test the actual throughput.
    On normal 802.11a you can expect about 25 Mbit.
    On 802.11a turbo you can expect about 36 Mbit.
    I only know numbers for 802.11a because i just recently had to do some bandwith test with it.
    Does anyone have numbers for 802.11g ?



  • I have had wireless problems lately too. It works only intermittently. I suspect this happened after I upgraded to 1.2.1-RC1
    built on Tue Aug 12 10:45:41 EDT 2008 but can't be sure because the wireless seemed to be working consistently up until a few days ago.

    I have an Atheros wireless card bridged with a wired NIC. I found DHCP works fine for three computers on the wired network but two computers on the wireless LAN sometimes don't get a DHCP response. Here's an extract from the output of  tcpdump -i ath0

    22:05:29.312493 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 00:1f:3c:19:86:82 (oui Unknown), length 300
    22:05:33.313494 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 00:1f:3c:19:86:82 (oui Unknown), length 300
    22:05:41.313748 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 00:1f:3c:19:86:82 (oui Unknown), length 300
    22:05:57.315457 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 00:1f:3c:19:86:82 (oui Unknown), length 300

    I looked in /var/log/filter.log and saw:

    Aug 18 22:05:29 pfsense pf: 10. 487110 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 27894, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:29 pfsense pf: 000077 rule 68/0(match): block in on bridge0: (tos 0x0, ttl 128, id 33426, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:29 pfsense pf: 000044 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 27314, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:33 pfsense pf: 262309 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 21164, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:33 pfsense pf: 000077 rule 68/0(match): block in on bridge0: (tos 0x0, ttl 128, id 12450, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:33 pfsense pf: 000045 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 11139, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:41 pfsense pf: 5. 628048 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 2725, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:41 pfsense pf: 000081 rule 68/0(match): block in on bridge0: (tos 0x0, ttl 128, id 41427, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:41 pfsense pf: 000043 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 62387, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:57 pfsense pf: 16. 001574 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 9992, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:57 pfsense pf: 000071 rule 68/0(match): block in on bridge0: (tos 0x0, ttl 128, id 29988, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
    Aug 18 22:05:57 pfsense pf: 000044 rule 68/0(match): block in on ath0: (tos 0x0, ttl 128, id 2102, offset 0, flags [none], proto UDP (17), length 328) 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]

    Looks like the firewall is blocking the DHCP requests from ath0. I'm not aware that I have done anything to change any rules so I'm curious why DHCP requests on the wireless LAN sometimes succeed and sometimes don't.

    I did a status display (http://pfsense/status.php) and looked at the rules and noticed these rules:

    @15 anchor "dhcpserverlan" all
      [ Evaluations: 253280    Packets: 0         Bytes: 0           States: 0     ]
      [ Inserted: uid 0 pid 1624 ]
    @16 pass in quick on rl0 inet proto udp from any port = bootpc to 255.255.255.255 port = bootps keep state label "allow access to DHCP server on LAN"
      [ Evaluations: 253280    Packets: 1335      Bytes: 456101      States: 0     ]
      [ Inserted: uid 0 pid 1624 ]
    @17 pass in quick on rl0 inet proto udp from any port = bootpc to 192.168.211.173 port = bootps keep state label "allow access to DHCP server on LAN"
      [ Evaluations: 138       Packets: 295       Bytes: 96892       States: 0     ]
      [ Inserted: uid 0 pid 1624 ]
    @18 pass out quick on rl0 inet proto udp from 192.168.211.173 port = bootps to any port = bootpc keep state label "allow access to DHCP server on LAN"
      [ Evaluations: 39484     Packets: 14        Bytes: 4592        States: 0     ]
      [ Inserted: uid 0 pid 1624 ]
    
    

    but there are no corresponding rules for ath0. OK, so maybe I need to check my configuration and enable dhcp on OPT1 (the ath0). There is nowhere to do that on the Interfaces->OPT1 menu and if I go to Services -> DHCP Server there is no tab for OPT1 (the wireless interface), only for LAN and DMZ (both wired LAN interfaces).

    Perhaps the generated firewall rules for dhcpserver should have specified interface bridge0 rather than rl0?



  • Bridging is working for me now on a wireless interface and I was having issues before.  Using "built on Thu Aug 14 18:19:52 EDT 2008" right now.



  • @adrianhensler:

    Bridging is working for me now on a wireless interface and I was having issues before.  Using "built on Thu Aug 14 18:19:52 EDT 2008" right now.

    I have tried the loopback plug without success (same version as you).
    Interesting, do you have anything plugged into your LAN interface (if it is the one bridged with your WLAN)?

    Regards



  • @luma:

    @adrianhensler:

    Bridging is working for me now on a wireless interface and I was having issues before.  Using "built on Thu Aug 14 18:19:52 EDT 2008" right now.

    Interesting, do you have anything plugged into your LAN interface (if it is the one bridged with your WLAN)?

    Cable modem on WAN; gb switch on LAN side of pfsense.  Wireless card bridged with lan for 802.11g access.



  • what kind of security setting you guys have? it doesn't work for me bridget to lan with wpa2/aes.



  • @covex:

    what kind of security setting you guys have? it doesn't work for me bridget to lan with wpa2/aes.

    wpa2/tkip here.



  • @covex:

    what kind of security setting you guys have? it doesn't work for me bridget to lan with wpa2/aes.

    WPA TKIP



  • @covex:

    what kind of security setting you guys have? it doesn't work for me bridget to lan with wpa2/aes.

    WPA2 TKIP



  • nothing works for me… :(



  • Trying to use rum0 as an AP bridged to LAN. can see rum0 as opt1 but no wireless option under interfaces.
    where should I be looking? or is this a bug that wireless options are recognized ?



  • Trying to use rum0 as an AP bridged to LAN. can see rum0 as opt1 but no wireless option under interfaces.

    Looks as if /etc/inc/globals.inc needs to be updated to include the new WLAN interfaces supported in FreeBSD 7.0: add rum to the WLAN interface list on the line beginning "wireless_regex" => . From the Interfaces menu, (assign) you will probably need to delete the interface and then add it again to have the wireless capabilities displayed.

    Note to pfSense developers: the two VLAN lists in the same file possibly need to be updated also. Does et (the Agere ET1310 driver) need to be in one or more of the VLAN lists?



  • I don't know is this a bug. I have a pfsense box with tree nics, wan, lan, opt1 connected to a zyxel wireless router only used as a wireless accesspoint. With some of the snapshots of 1.2.1 it got disconnected, on the wireless side, and i have to restart the firewall, this never happened in 1.2. This can happen after 1 h or after 1 day. Another thing is that once or twice my firewall has locked and i cannot connect either by web interface or ssh and with no internet access whatsoever.

    Is now using 1.2.1-rc1 build aug 25.



  • Editing /etc/inc/globals.inc allowed wirless options for rum0 to be set
    Thanks Again !!



  • Interface added, thanks!!



  • Hello,

    I just tested the latest snapshot, and my wireless linksys card (based on a ralink chipset) still doesn't work. I can assign the interface, configure it as an access point with WPA. However under status -> interfaces I still get 'no carrier'. That was the issue with the previous snapshots as well. The card works under the stable version of pfsense however, although then there is the issue that the wireless connection fails after some minutes of "high bandwith usage" (copying a file over wireless usually induces the problem). Disabling and re-enabling the interface fixes the problem however. Still, a bit anoying.

    I replaced the wireless nic with another ralink card but I have exactly the same issues. So it's not a faulty nic.

    Best regards,
    Jan



  • Ralink cards should now work, the ral driver in FreeBSD 7.0 wouldn't work with the order we use to bring up interfaces while every other driver does. That's been fixed to an order that works for everything though.



  • I've put up pfSense-20081002-0148.iso.gz a few days ago and everything seemed fine but i just noticed that the wireless is not working.  When trying to connect even the SSID is not being broadcast.  1.2 works fine.  Following is the interface information.  Please let me know if I can put anything else up.

    <opt1><descr>Wireless</descr>
    <if>ath0</if>
    <wireless><standard>11g</standard>
    <mode>hostap</mode>
    <protmode>off</protmode>
    <ssid>Toontown</ssid>
    <channel>8</channel>
    <authmode></authmode>
    <txpower>99</txpower>
    <distance><wpa><macaddr_acl></macaddr_acl>
    <auth_algs>2</auth_algs>
    <wpa_mode>2</wpa_mode>
    <wpa_key_mgmt>WPA-PSK</wpa_key_mgmt>
    <wpa_pairwise>CCMP TKIP</wpa_pairwise>
    <wpa_group_rekey>60</wpa_group_rekey>
    <wpa_gmk_rekey>3600</wpa_gmk_rekey>
    <passphrase>**********</passphrase>
    <ext_wpa_sw></ext_wpa_sw>
    <enable></enable></wpa>
    <apbridge><enable></enable></apbridge>

    <pureg><enable></enable></pureg></distance></wireless>
    <bridge>lan</bridge>
    <ipaddr>dhcp</ipaddr>
    <subnet>32</subnet>
    <gateway><spoofmac><mtu><enable><dhcphostname></dhcphostname></enable></mtu></spoofmac></gateway></opt1>



  • jmorey: what happens when you run /tmp/ath0_setup.sh from a command prompt?



  • After posting I saw and downloaded pfSense-20081011-0859.iso.gz.  Not surprisingly my problem has changed.  Since things seem better with it here is what it is doing.  A laptop running Vista is able to connect without problems.  My Archos 605 WiFi errors out. It will connect to 1.2.  The pfSense log shows the fillowing:

    Oct 13 09:40:16 hostapd: ath0: STA 00:16:dc:50:c4:1b IEEE 802.11: deassociated
      Oct 13 09:40:01 hostapd: ath0: STA 00:16:dc:50:c4:1b WPA: group key handshake
                                    completed (RSN)
      Oct 13 09:39:54 hostapd: ath0: STA 00:16:dc:50:c4:1b WPA: pairwise key handshake
                                    completed (RSN)
      Oct 13 09:39:54 hostapd: ath0: STA 00:16:dc:50:c4:1b WPA: received EAPOL-Key 2/4
                                    Pairwise with unexpected replay counter
      Oct 13 09:39:54 hostapd: ath0: STA 00:16:dc:50:c4:1b WPA: received EAPOL-Key 4/4
                                    Pairwise with unexpected replay counter
      Oct 13 09:39:54 hostapd: ath0: STA 00:16:dc:50:c4:1b IEEE 802.11: associated
      Oct 13 09:39:51 hostapd: ath0: STA 00:16:dc:50:c4:1b IEEE 802.11: associated

    The output of ath0_setup.sh is:

    + + grep hostapd
      + grep ath0
      /bin/ps awwuxx
      + + xargsawk kill { print $2 }

    + /sbin/ifconfig ath0 down
      + /sbin/ifconfig ath0 mode 11g
      + /sbin/ifconfig ath0 channel 8
      + /sbin/ifconfig ath0 -mediaopt turbo
      + /sbin/ifconfig ath0 ssid Toontown
      + /sbin/ifconfig ath0 -hidessid
      + /sbin/ifconfig ath0 -mediaopt adhoc
      + /sbin/ifconfig ath0 protmode off
      + /sbin/ifconfig ath0 mode 11g pureg
      + /sbin/ifconfig ath0 apbridge
      + /sbin/ifconfig ath0 -wme
      + /sbin/ifconfig ath0 authmode open wepmode off
      + /sbin/ifconfig ath0 txpower 99
      ifconfig: SIOCS80211: Invalid argument
      + /sbin/ifconfig ath0 mediaopt hostap
      + /sbin/ifconfig ath0 mtu 1500
      + /sbin/ifconfig ath0 up
      + /usr/sbin/hostapd -B /var/etc/hostapd_ath0.conf
      Configuration file: /var/etc/hostapd_ath0.conf

    Thanks for any help.


Log in to reply