Dangling "Array" text on FW>TrafficShaper>Queue page (occurs on 2.2.6 as well)



  • I don't have any Queues defined, when I click on to that page there is a dangling "Array" shown - doesn't seem like it should be there

    v2.3.1.a.20160513.0931 - gitsync'd this morning

    edit: I noticed this dangler appears on 2.2.6 as well.  2.1.5 doesn't seem do this, not seeing it on 2.2.4 either.  So whatever is causing this looks like it started with 2.2.5 or 2.2.6 and has carried forward into 2.3.x



  • Upon further inspection, looks like 2.2.6 does the same thing.  Hmm!

    What is "supposed" to happen on this page?



  • Just a no queue message should be there.




  • Yep. I have that (see top post) but also have this dangling "Array" text hanging out there in the middle of nowhere.  Found nothing odd in my config.xml.



  • What exactly is in the shaper section of your config.xml ?

    I tried adding some queues manually, and with the wizard, then deleteing them one-by-one and deleting them using the Remove Shaper button. Whatever I do the shaper section goes back to being empty, and no strange "Array" text displayed.

    It is going to be some unusual way that the code is trying to print a variable that it expects to be text, but is actually an array.



  • This is a real strange one.

    My <shaper>and <dnshaper>stanzas are empty…

    
     <dnshaper><shaper></shaper></dnshaper>
    

    I went through about 60+ firewalls that I have access to, around 70% of them are on 2.2.6 and are also displaying that "Array" text.  I found 4 that are on 2.2.6 and DON'T have the glitch. Problem is I can't figure out what those have in common, and what is different about the rest. I have combed through lots of config.xml 's but it must be something very subtle. I wish I knew how to trace through the PHP code better.

    All I can figure out so far is, the variable in question is called "$output" and is concatenated in firewall_shaper_queues.php and the functions/includes therein (maybe $altq_list_queues / build_shortform() in /etc/inc/shaper.inc is to blame?).  The $output var is printed at the bottom of that file, right after theelement.</dnshaper></shaper>



  • Don't recall seeing that, and not seeing it on a handful of systems I spot checked.

    It definitely is $output? The "Array" text ends up being below the "" line if you view the source?

    You can try adding a line below that col-sm-10 with:

    Knowing what's in the var might make it apparent where it's ending up with an array.



  • Hmm good to know about that var_dump function!  8) thank you

    so I added that…

    which now displays this (even stranger?)

    Not sure where that is coming from? RCC-VE is the platform? (this is an ADI unit…)



  • Huh, guessing that's probably a leftover from the use of that variable name elsewhere on a different page.

    Underneath all the require_once lines towards the top of the file, add a line:

    $output = "";
    

    Does that make it stop?



  • @cmb:

    Underneath all the require_once lines towards the top of the file, add a line […] Does that make it stop?

    YES, yes it does! That is weird. Still not sure why this would only affect some systems and not others.  Maybe something is being read from bios??

    I ran this command and see that it ouputs the offending string … maybe a clue??

    # kenv | grep "RCC"
    smbios.bios.version="ADI_RCCVE-01.00.00.08-nodebug"
    smbios.planar.product="RCC-VE"
    smbios.system.product="RCC-VE"
    
    



Log in to reply