Vmware routervm + nat + public IP's



  • Hi!

    I am sure this has been asked in the forums earlier but I am not exactly sure what to search for.

    I have pfsense set up as a router VM set up in my ESXI with a public /29 network attached to it.
    The public network is not shared via DHCP.
    Together with this, I would also like to have a NAT with internal addresses, so that I can set up VM's for test purposes instead of having to wase public IP's on this.

    Question now is, how do I set this up?

    Is there a guide somehwere? Or can someone explain what I need to do?

    Thank you very much!
    /Rickard

    PS.
    I was not sure wether this post should have gone into the virtualization thread, or in the general questions thread. If this question is better suited in another thread, please, by all means, do move the question to the appropriate thread.
    DS.


  • LAYER 8 Global Moderator

    so your /29 is routed to pfsense via a tranist.  Or this /29 sits on the wan of pfsense?  Sounds like its routed to me.

    So you want to also have another segment on pfsense that is nated to one of these routed /29 or natted to the IP that sites on pfsense public IP that would be in the transit network?



  • @johnpoz:

    so your /29 is routed to pfsense via a tranist.  Or this /29 sits on the wan of pfsense?  Sounds like its routed to me.

    So you want to also have another segment on pfsense that is nated to one of these routed /29 or natted to the IP that sites on pfsense public IP that would be in the transit network?

    You are correct, the /29 (5.9.xxx.xxx) network is routed to pfsense via 78.46.xxx.xxx (which is the WAN address of my pfsense).
    On top of this, I want another segment which should be nated to one of those /29 addresses.


  • LAYER 8 Global Moderator

    I would think u could use one of the /29 and put as vip on wan and then nat another segment to that ip



  • Put on wan, as in having two ip's on the wan nic?

    Not sure how you mean otherwise, as 78.46.xxx.xxx, which is my current WAN IP, needs to be there for the /29 subnet to come through at all (unless I am mistaken).



  • @noratx:

    Put on wan, as in having two ip's on the wan nic?

    Not sure how you mean otherwise, as 78.46.xxx.xxx, which is my current WAN IP, needs to be there for the /29 subnet to come through at all (unless I am mistaken).

    Yes, put it as a Virtual IP on WAN.

    The way it works is that your ISP doesn't really care how you use a routed subnet. All they know is that if any requests enters their network bound for an IP in 5.9.xxx.xxx/29 range, they send it to your WAN IP (78.46.xxx.xxx).
    Likewise, when you use the virtual IP as a NAT IP, pfSense simply sends the data out to the gateway for 78.46.xxx.xxx but marks the source IP as your VIP. The gateway doesn't reject it because it's configured to forward/ route for that IP.



  • I see!

    Will try do that tonight.
    Thanks for the suggestion! :)



  • Don't I need to add another interface for the second LAN as well?
    And if so, is there a way to make BSD scan for new hardware instead of rebooting?
    I did actually add a third interface to use as secondary LAN for NATing, but it doesn't show up in dmesg…

    Also, which type should the Virtual IP be? IP Alias, Proxy ARP or other?



  • I am not getting it to work at all, no matter how much I try.
    The only thing I get to work, is the DHCP, but there is no connection what so ever from the VM.

    Is there anyone who can give me some advice on how to get it all to work propely?
    Thanks!

    Edit: Maybe, since this is more a NAT question, I should close this thread and open a new one in the NAT forum instead?


  • LAYER 8 Global Moderator

    Are you creating the outbound nat to use the VIP ip?



  • @johnpoz:

    Are you creating the outbound nat to use the VIP ip?

    Hi!

    Yes, I have added an outbound nat rule with different settings.
    https://gyazo.com/211f10b64fe492b5ab36d91d8a94fcac

    I have tried to change the inteface between the WAN and NAT interface, tried different protocols and different translation rules.


Log in to reply