CARP not working [solved]



  • Hi all…

    I have the symptom of my CARP not working at all.
    To start; has worked in the past. No major changes (in HW/config). I have one box on v2.3.1 (backup unit), and one on v2.3 (main unit). pfSync and XMLRPC Sync are both enabled, with the XMLRPC for all but VIP's.
    So I wanted to upgrade the main one, but if I disable carp all my interfaces get status disabled on the main (as it should), but on the backup unit they (-> as all of them) stay in backup state???

    Logs don't show me much.
    When I disabled CARP on the main, I saw CARP events in the logs of the main unit, but not one entry in the logs from the backup unit.
    If I trigger a sync (by saving in the menu System/High Availability Sync), I get these entries in log on the main unit:

    May 25 14:01:17	php-fpm	53118	/system_hasync.php: Configuring CARP settings finalize...
    May 25 14:01:17	php-fpm	53118	/system_hasync.php: pfsync done in 30 seconds.
    May 25 14:00:46	php-fpm	53118	/system_hasync.php: waiting for pfsync...
    May 25 14:00:45	php-fpm	53118	/system_hasync.php: End of portal.pfsense.org configuration backup (success).
    May 25 14:00:44	php-fpm	5080	/rc.filter_synchronize: The other member is on a different configuration version of pfSense. Sync will not be done to prevent problems!
    May 25 14:00:43	php-fpm	53118	/system_hasync.php: Beginning https://portal.pfsense.org configuration backup.
    May 25 14:00:43	check_reload_status		Syncing firewall
    

    For quick sanity check, I've did packet capture on one of the interfaces of the backup unit, and I do see the VRRPv2 advertisements.
    So as I see no similar topics on this forum, I tend to think I did something obviously wrong. But I can't see what for the moment  ::)

    Someone with a bright moment that can point me out on what I'm missing?

    Tnx & br, Benny.



  • Nevermind… found my the issue.
    As a workaround for a previous issue (carp pre-2.3), I had a difference in master/backup VIP's advertising frequency. And it looks v2.3.x does not like it. I aligned these again, and now it is behaving as it should. Upgrading as I write this update  8)


Log in to reply