DELL R330 + PERC H330 SAS



  • Hello,

    We found that some new Dell R330 using PERC H330 HBAs would install PFSense 2.2.x+ using the 25.3.0.0016 firmware on the H330. We experienced some issues with the RAID and promptly upgraded to the 25.4.0.0017 firmware which would freeze on boot (see attached). However we found that using the mrsas driver (https://www.freebsd.org/cgi/man.cgi?query=mrsas&sektion=4) it worked correctly.

    Therefore our installation procedure consists of:

    • Boot the installer

    • Hit escape on the loader prompt

      • set hw.mfi.mrsas_enable="1"

      • boot

    • Install as usual

    • On reboot, hit escape when booting from the disk to the loader prompt

    • Again enable mrsas and boot by doing:

      • set hw.mfi.mrsas_enable="1"

      • boot

    • When booted we need to make the change permanent by creating /boot/loader.conf.local and adding hw.mfi.mrsas_enable="1" to the bottom

    Is there any reason why pfsense doesn't have mfi set to enable mrsas out of the box? I presume there's an easier way of doing this?

    If upgrading an existing install we found that we needed to (prior to upgrading):

    • Edit /boot/loader.conf.local

    • Add: hw.mfi.mrsas_enable="1"

    I hope this saves some people time!
    -Rob



  • Thank you, yes we experienced the same behaviour with our DELL R330 with PERC H330 and this procedure fixed it for us. Much appreciated! :)



  • Hi, sorry to bother, im having this same issue with this raid controller and im stuck really bad with this and im confused with the steps since i never used freebsd. Any help would be really appreciated.



  • Hi,

    Thank you. I was having the same problems on Dell R230. I fixed the problem.

    Best Regards.



  • Hi

    Same issues here. Had I found this post a little bit earlier.
    Was trying to install pfSense 2.3.2 on a Dell R630 box (2 SAS disks, RAID1, PERC H730 RAID controller). Installing on a single disk was no problem, but as soon as the controller was configured in RAID1, I had the very same error messages.

    Post also much appreciated!  :)

    Thanks and best regards
    S.