SquidGuard 1.2.0_1 & pfsense 1.2 release only works without logging



  • Hi guys,
    i have been using squid and squidguard for about 6 months with no problem until the router had a power cut, since then the only way i can get squidguard to work is disable the logging functions within each preference of squidguard.
    i have looked around and found some permissions issues (possibly) and tried to rectify but to no avail.
    i have reinstalled the package and xml for both squid and squidguard which didnt help.
    has anyone got any suggestions?

    thanks in advance.

    Al



  • Hi
    Sorry i have difficulties in understanding you post
    SG work only if disabled any log (acl, destinations)?
    What permissions in /var/squidGuard and subfiles? Must be 'proxy\644(or 755)'



  • @dvserg:

    Hi
    Sorry i have difficulties in understanding you post
    SG work only if disabled any log (acl, destinations)?
    What permissions in /var/squidGuard and subfiles? Must be 'proxy\644(or 755)'

    yeah thats right, SG only works if you uncheck/disable the logging options in every ACL, in Default, every destination and on the general settings page.
    the permissions of /var/squidGuard and its trees were root:wheel drwxr-xr-x, i have changed them to proxy:proxy and it still wont work.

    i thought it might be something weird with my setup so i backed up the config and reinstalled from a format. restored the config file after adding the necessary packages and it performs exactly the same! so im guessing its a config problem?



  • chown -R -v proxy /var/squidGuard
    chmod -R -v 0755 /var/squidGuard



  • @dvserg:

    chown -R -v proxy /var/squidGuard
    chmod -R -v 0755 /var/squidGuard

    still no luck,
    if i enable a log button this appears in /var/squid/log/cache.log

    2008-08-26 08:23:23 [65179] (squidGuard): can't write to logfile /var/log/squidGuard.log
    2008-08-26 08:23:23 [65179] syntax error in configfile /usr/local/etc/squidGuard/squidGuard.conf line 20
    2008-08-26 08:23:23 [65179] going into emergency mode
    2008-08-26 08:23:23 [65180] (squidGuard): can't write to logfile /var/log/squidGuard.log
    2008-08-26 08:23:23 [65180] syntax error in configfile /usr/local/etc/squidGuard/squidGuard.conf line 20

    then when i turn the logging off -
    2008/08/26 08:24:07| helperOpenServers: Starting 3 'squidGuard' processes
    2008-08-26 08:24:07 [65712] (squidGuard): can't write to logfile /var/log/squidGuard.log

    and it works again.

    thanks for your help…



  • ok, just changed the permissions on the  /var/log/squidGuard.log and that message has gone from squids log.
    in squidGuards log tab i cant view squidGuard.log due to
    "squidguard_log report disabled"
    although there isnt a menu to turn logging on or off. im sure i did see one a few weeks ago on the general settings tab?

    i have just reinstalled the package on squid and squidguard to see if that helps.. it didnt but i got a new version of squid.  :)

    thanks

    Al



  • I'm having the same issue

    with all logs off, squidguard works
    I only enabled log in Default after which

    in /var/log/squidGuard.log:
    syntax error in configfile /usr/local/etc/squidGuard/squidGuard.conf line 61
    going into emergency mode

    my  /usr/local/etc/squidGuard/squidGuard.conf:
    acl  {
            #
            default  {
                    pass worksites whitelist !blacklist !pornsites !media_block all
                    redirect 301:http://myserver/sqerror.htm
    #line 61#    log {SQUIDGUARD_ACCESSBLOCK_FILE}
            }

    I'm not sure if the log {SQUIDGUARD_ACCESSBLOCK_FILE} format is pfsense specific, but all example file use the format is   
    log block.log



  • @ryven:

    I'm having the same issue

    #line 61#    log {SQUIDGUARD_ACCESSBLOCK_FILE}
            }

    I'm not sure if the log {SQUIDGUARD_ACCESSBLOCK_FILE} format is pfsense specific, but all example file use the format is   
    log block.log

    Thanks, this is my bug.. will be fixed in near time



  • Can i manually set the log to block.log
    where should the file be and what permission should it have



  • @ryven:

    Can i manually set the log to block.log
    where should the file be and what permission should it have

    You can find
    "log {SQUIDGUARD_ACCESSBLOCK_FILE}"
    strings in /usr/local/pkg/squidguard_configurator.inc and replace it to
    "log " . SQUIDGUARD_ACCESSBLOCK_FILE
    and 'Apply' in GUI.

    –-
    Possible renew GUI, bug fixed.



  • Did it and all working.
    there were three instances that needed to be changed (that i found in any case)
    Thnx for the help



  • @ryven:

    Did it and all working.
    there were three instances that needed to be changed (that i found in any case)
    Thnx for the help

    Now can renew XML. Bug already fixed.



  • Hell yeah!
    Cheers guys

    ;D

    Al


Log in to reply