Page fault on Alix2c3



  • Just tried pfSense-20080825-1051.img on my test Alix. It's worked fine with older snapshots, but I haven't tried one lately due to wireless being broke. Used physdiskwrite to write the image to a 1GB CF card, card worked with the last version I tried a couple of weeks ago.
    This one lets me assign interfaces, but bombs before finishing boot:
    Setting up microcode and tx/rx offloading…done.
    kernel trap 12 with interrupts disabled

    Fatal trap 12: page fault while in kernel mode
    fault virtual address   = 0x18
    fault code              = supervisor read, page not present
    instruction pointer     = 0x20:0xc076ec5b
    stack pointer           = 0x28:0xcd045994
    frame pointer           = 0x28:0xcd0459a0
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = resume, IOPL = 0
    current process         = 71021 (setkey)
    trap number             = 12
    panic: page fault
    Uptime: 2m25s
    Cannot dump. No dump device defined.

    EDIT: I was thinking this was something with the Alix hardware, but I see it was running setkey, so maybe this is related to IPSec changes.

    EDIT: Yeah, renaming setkey and rebooting gets the system running after it checks the disks.

    EDIT: Looking at CVS suggests this is a known issue and it is being worked on. So, like never mind.


Log in to reply