Simple port forwarding



  • Hello,

    how do i do port forwarding on pfsense, i did but but still not working at all. see screenshot


    ![Screen Shot 2016-10-11 at 10.13.21 PM.png](/public/imported_attachments/1/Screen Shot 2016-10-11 at 10.13.21 PM.png)
    ![Screen Shot 2016-10-11 at 10.13.21 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-11 at 10.13.21 PM.png_thumb)


  • Rebel Alliance Global Moderator

    how are you testing that is working or not?

    Did you look at the troubleshooting doc?
    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting



  • You have to create a corresponding rule on your WAN interface to allow the inbound traffic.



  • @johnpoz:

    how are you testing that is working or not?

    Did you look at the troubleshooting doc?
    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    First trying to access from WAN side second http://www.yougetsignal.com/tools/open-ports/

    is my settings are ok for forwarding port 8000

    ![Screen Shot 2016-10-11 at 10.31.50 PM.png](/public/imported_attachments/1/Screen Shot 2016-10-11 at 10.31.50 PM.png)
    ![Screen Shot 2016-10-11 at 10.31.50 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-11 at 10.31.50 PM.png_thumb)



  • Can you see the traffic being dropped in the firewall log?



  • @acascianelli:

    Can you see the traffic being dropped in the firewall log?

    There is no such log related to port 8000 nothing..



  • Status > System Logs > Firewall

    Just tested this myself against my own IP address and a known closed port, I see the block attempt just fine in the logs.  Are you sure you're testing against the correct internet IP?  I'm not trying to insult you, just a simple mistake.



  • @acascianelli:

    Status > System Logs > Firewall

    Just tested this myself against my own IP address and a known closed port, I see the block attempt just fine in the logs.  Are you sure you're testing against the correct internet IP?  I'm not trying to insult you, just a simple mistake.

    yes nothing even i tried to open WEB GUI port 80 showing closed http://www.yougetsignal.com/tools/open-ports/





    ![Screen Shot 2016-10-12 at 1.06.14 AM.png](/public/imported_attachments/1/Screen Shot 2016-10-12 at 1.06.14 AM.png)
    ![Screen Shot 2016-10-12 at 1.06.14 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-12 at 1.06.14 AM.png_thumb)



  • There's a vital piece of information missing here. Is your pfSense behind another NAT router?



  • or is you isp actively blocking inbound traffic?



  • no no nothing blocked my pfsense connected to via isp provided cable modem and pppoe congigured on

    am i doing correct port forwarding?

    using pfblockerng and squid proxy transparent mode…


  • Rebel Alliance Global Moderator

    well if you have a pppoe interface your interface for the forward wold be the pppoe interface

    I would not suggest you open up webgui to the public internet that is for sure.  If your not seeing traffic to your IP then its not getting to pfsense, so pfsense could never forward it.

    You have rules above your wan rule that blocks pfblocker lists, so that could be blocking it?

    So your cable modem is doing the pppoe?  And pfsense just gets a public IP on its wan interface connect to your isp device.



  • @johnpoz:

    well if you have a pppoe interface your interface for the forward wold be the pppoe interface

    I would not suggest you open up webgui to the public internet that is for sure.  If your not seeing traffic to your IP then its not getting to pfsense, so pfsense could never forward it.

    You have rules above your wan rule that blocks pfblocker lists, so that could be blocking it?

    So your cable modem is doing the pppoe?  And pfsense just gets a public IP on its wan interface connect to your isp device.

    i configured pppoe in pfsense, isp cable modem working as bridging doing nothing just act as MODEM

    just enabling web gui remote access to test



  • What country are you in?  I don't know if any US cable providers that use PPPoE anymore.



  • @acascianelli:

    What country are you in?  I don't know if any US cable providers that use PPPoE anymore.

    pppoe in india



  • ok after doing long searching googling success forwarded port 8000 and 8008 but failed for port 80 tried many times nothing happened. May be due to pfblockerNG doing something math with it so i decided to change http port for my DVR 80 to 8008. (BTW i changed pfsense webgui http port 80 before using port 80 for DVR).

    If anyone know about port 80 whats wrong please update.

    On my ios device App for my CCTV camera not working even forwarding port http 8000, so i tried with my trusty android and valla it worked. :)  ios you traitor wasted my 2 hours :(

    Why i seeing outbound Mapping dim rules can i delete all these?

    Thanks  acascianelli johnpoz heper kpa

    ![Screen Shot 2016-10-12 at 10.10.28 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-12 at 10.10.28 PM.png_thumb)
    ![Screen Shot 2016-10-12 at 10.10.28 PM.png](/public/imported_attachments/1/Screen Shot 2016-10-12 at 10.10.28 PM.png)
    ![Screen Shot 2016-10-12 at 10.09.01 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-12 at 10.09.01 PM.png_thumb)
    ![Screen Shot 2016-10-12 at 10.09.01 PM.png](/public/imported_attachments/1/Screen Shot 2016-10-12 at 10.09.01 PM.png)



  • If anyone know about port 80 whats wrong please update.

    Are you running WebGUI in HTTP mode?…


  • Netgate

    Why is the destination address on your 8008 port forward not WAN address?

    The answer is probably here:

    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    Check the default gateway on the 8008 DVR.



  • @KOM:

    If anyone know about port 80 whats wrong please update.

    Are you running WebGUI in HTTP mode?…

    yes sir running pfsense web gui on http port 80 but trying to forward port 80 no success :(

    **Why is the destination address on your 8008 port forward not WAN address?

    @Derelict ok sir i changed it to Wan Addres**