[SOLVED] intel pro/1000 mt dual port server adapter not working



  • Hello All!

    I bought 4 Intel PRO/1000 MT Dual Port Server Adapter (PCI / PCI-X) to put in some PfSense boxes.
    I am using Dell optiplex 740 / 390 / 7020 for my pfsense boxes.  They have one PCI slot

    Only one port on any of he nic cards  works.  I can manually set an IP for the second port ( ex:" 192.168.20.1/24").  The PC connected picks up an IP (192.168.20.10)  but cannot ping to 192.168.20.1, nor gain access to web.  The first of the dual port was set as 192.
    168.10.1 and works flawlessly.
    I have opened all 4 nic cards and tried them all on 3 PfSense boxes.

    I installed all (one at a time) on windows 10 pc's.  Each is recognized in Device Manager and both ports work fine.

    I found a comment via google suggesting editing the loader.conf file to include:
    hint.agp.0.disabled=1

    This has no impact.

    Any suggestions would be appreciated.

    Does anyone have any suggestions?



  • Hard to imagine that all 4 are bad (unless used/refurbished, but still).

    Test them on another machine and even with a different OS (Windows to make it easy).

    I bought a quad port Intel from China. First one died in 6 months.
    The other 2 I bought after have been working fine for a year or more.

    @detox:

    Hello All!

    I bought 4 Intel PRO/1000 MT Dual Port Server Adapter (PCI / PCI-X) to put in some PfSense boxes.
    I am using Dell optiplex 740 / 390 / 7020 for my pfsense boxes.  They have one PCI slot

    Only one port on any of he nic cards  works.  I can manually set an IP for the second port ( ex:" 192.168.20.1/24").  The PC connected picks up an IP (192.168.20.10)  but cannot ping to 192.168.20.1, nor gain access to web.  The first of the dual port was set as 192.
    168.10.1 and works flawlessly.
    I have opened all 4 nic cards and tried them all on 3 PfSense boxes.

    I installed all (one at a time) on windows 10 pc's.  Each is recognized in Device Manager and both ports work fine.

    I found a comment via google suggesting editing the loader.conf file to include:
    hint.agp.0.disabled=1

    This has no impact.

    Any suggestions would be appreciated.

    Does anyone have any suggestions?



  • pppfsens,

    I did try them on a windows pc and all worked fine.
    That is my confusion.

    They work fine on other pc's but not on pfsense



  • @detox:

    Only one port on any of he nic cards  works.  I can manually set an IP for the second port ( ex:" 192.168.20.1/24").  The PC connected picks up an IP (192.168.20.10)  but cannot ping to 192.168.20.1, nor gain access to web.  The first of the dual port was set as 192.
    168.10.1 and works flawlessly.
    I have opened all 4 nic cards and tried them all on 3 PfSense boxes.

    Erm…  I assume the 2nd port is setup as OPT1?

    If so, did you actually setup the firewall rules to allow ANY to ANY on that interface tab?

    Also, have you setup the NAT for that subnet (if not already picked up by Automatic NAT).


  • Netgate Administrator

    Yes it sounds like the second port simply isn't configured yet.

    If both ports, probably em0 and em, are listed in Interfaces > assign then they are being detected correctly by the OS.

    Steve



  • Then, I cannot help you further as we would need a lot more info/screenshots.

    If the cards/ports work somewhere else, it is a configuration issue.

    @detox:

    pppfsens,

    I did try them on a windows pc and all worked fine.
    That is my confusion.

    They work fine on other pc's but not on pfsense



  • Thanks for the suggestions.

    Here is what I did as a result:

    Started with fresh install of PfSense (to make sure I did not goober something up)

    (  Note:  The onboard nic ( Dell optiplex 740) is functional prior to installation
    The dual nic was tested on a windows pc and both are recognized and worked on Win 7)

    During install I am asked to identify WAN, using the autodetect, it lists bge0 (onboard), em0, em1 (dual nic)

    I select bge0 for WAN and do not select anything else  after install completes I can ping out to google etc

    I reinstall fresh (Yes this is OCD overkill, but it is what I did)  (Auto detect shows bge0, em0, em1)
    Using Auto detect, WAN = bge0, LAN = em0
    Save
    Can ping from terminal, and have internet and PfSense interface access from LAN connect
    Then added OPT 1 using autodetect,  would not recognize em1.  Set IP anyway.
    PC on em1 shows valid IP but cannot ping OPT1 (192.168.6.1)

    I think at this point I will resign myself to having WAN and 1 LAN.  All my PC's are fairly old optiplex with only 1 pci slot avail.


  • Netgate Administrator

    By default there will not be any firewall rules to allow any traffic on OPT1.

    Go to Firewall > Rules, OPT1 tab. And add an allow all rule. Make sure to set protocol to 'any'. YOu should be able to connect out from the OPT1 subnet after that.

    Steve



  • –-  stephenw10
    I ensured the "any" rule was on OPT1.  I copied it exactly from LAN.

    Now, from the pfsense cosole, I can ping both net's  LAN = 192.168.20.1  OPT1 = 192.168.30.1
    I can even ping specific computers on both.
    My pc on OPT1 still cannot ping to 192.168.30.1 nor access web

    This is where I growl "GGRRRRRRRRRRRRRR"  I just do not get it.  Even disabled DHCP6 server and no change.  Do you have any farie dust to sprinkle on it?


  • Netgate Administrator

    Hmm, do you have the 'block private networks' rule on OPT1 maybe?

    You can disable that in Interfaces > OPT1.

    Otherwise please give us a screenshot of the firewall rules on OPT1 and the Status > Interfaces page.

    Steve



  • I'm very confidant that this is a configuration problem.

    pfSense doesnt work "out of the box" as its a full firewall, no comparison to your consumer routers, you need to setup everything from scratch.

    I'm at work at the mo, but a quick google and this guide should help you.. if you're still stuck I can give you a hand later this evening.

    http://www.cyberciti.biz/faq/how-to-pfsense-configure-network-interface-as-a-bridge-network-switch/

    I would suggest undoing anything you've already done and start with fresh rules.


  • Netgate Administrator

    I would recommend almost certainly not doing that.

    You should not setup multiple ports in a bridge unless you really need that. An internal switch will work much better in the vast majority of circumstances.

    The current setup you have with two separate internal /24 subnets should work fine. At the very least you should get that working before moving onto a more complex setup if you need to.

    Steve



  • I'm still very novist, could you please help me to understand in which scenario you would use bridge then?


  • Rebel Alliance



  • One definite scenario for a bridge is when your ISP brings you a subnet with their equipment and that equipment is locked down so that the subnet assigned to you is terminated on the LAN interface of the router they provide (where you have no access to its configuration). In this scenario your best option is just to install pfSense as a filtering bridge on network segment connected to the LAN inteface of the ISP router.



  • Thank you Guys!  For the great assistance.  I will take screenshots or just make a video of each page for interfaces /firewall for WAN , LAN, and Firewall for each.  I do not have access until tomorrow.  Where would you suggest I post the screenshots / video (video if I cannot get whole screen visible)

    Thanks again for all your help.  I believe it is something simple I am just not seeing, that is why it is driving me crazy



  • Thank you ptt, kpa



  • Hello All Again!

    I really appreciate the time you have taken to provide possible solutions to my problem.  Several of  you asked for screenshots.  Because I could not get all the data to display well, I made a short video showing all settings discussed plus ssh-ing into the PfSense box to show a few things there.
    The nic card is:  Inte; PRO/1000 MT Dual Port Server Adapter PCI/PCI-X version A85412-006
    The PC PfSense is installed on is:  Dell OPtiplex 740 ; 4 gig ram; hd is 25o gig

    Here is the link to the video:  http://www.screencast.com/t/5ZPOrnhNaijN

    If anyone can see a possible solution, you would be elevated to hero status and I'd feed you coffee for a day if  you are in eastern North Carolina  Had to edit this to include the finest happy meal mcdonalds can provide as well  (low budget operation here)



  • Oh Happy Day!

    A person noticed the mistake in t he OPT1 firewall rule.
    The selection for source was LAN, not OPT1 net.    (GAK)
    Made the change and now I have internet access!

    Darn fingers and fuzzy eyeballs staring a  screen at 0200…..

    A BIG public thank you to PiBa-NL in the ##pfsense chat room on FreeNode.

    And, thanks again to all here who did their best to help before I sent the video of the configuration online.  If anyone wants to use this video as an example of what NOT to do, it seems it is a good example for that

    Thanks again to all!



  • Resolution  has bee accomplished.  Thanks to all who responded and gave suggestions