New to VPN's, please help me with config.



  • I am trying to set a site to site with OpenVPN. Both locations are using PfSense.
    Central office is server with IP address 192.168.0.0/24
    Remote office is client with IP address 192.168.254.0/24
    Using shared key.

    In the central office, I have set Peer to Peer (shared Key), UDP protocol, device tun, WAN interface, port 9998, AES-256-CBC and RSA-SHA256, ipv4 tunnel network is 10.0.6.0/24,
    ipv4 remote network 192.168.254.0/24, enabled adaptive compression, with no ipv6 traffic.

    In the remote office, I have set  Peer to Peer (shared Key), UDP protocol, device tun, WAN interface, port 9998, AES-256-CBC and RSA-SHA256, ipv4 tunnel network is 10.0.6.0/24,
    ipv4 remote network 192.168.0.0/24, enabled adaptive compression, with no ipv6 traffic.

    In both firewall rules I have set WAN ipv4 UDP * * WAN Address 9998 * none VPN - An any/any rule
    In both firewall rules I have set OpenVPN rule ipv4 UDP * * * * * none VPN - An any/any rule

    The VPN connects fine, but no traffic will pass. Does abything stand out, that I am missing? I followed a video setup guide from here:  https://www.youtube.com/watch?v=8f13lfnEKY8

    Please post if any information is missing!



  • Are both pfSense boxes the default gateway in their LANs?



  • Yes, both are the gateway device in their respective LAN's.

    Central Office Server is GW 192.168.0.1
    Remote Office Client is GW 192.168.254.1

    Edit Central Office Server GW IP to correct value.



  • @Neut:

    In both firewall rules I have set OpenVPN rule ipv4 UDP * * * * * none VPN - An any/any rule

    On OpenVPN interface you also need other protocols like TCP and ICMP. So change the protocol to any will meet your needs.



  • I have modified the Central office, and will modify the remote office tomorrow. Will post the results.



  • That was it. Thank you very much.


Log in to reply