Redirecionar conexão externa para interna [RESOLVIDO]



  • Prezados

    Temos um server que publicamos na net através do NAT do Pfsense. Em nosso gerenciador externo de DNS, cadastramos um subdomínio apontando para o nosso IP do gateway.
    No NAT do PfSense, todas as requisições que chegarem no IP do gateway e na porta 60000, seja redirecionado para o IP interno.
    Este server hospeda uma aplicação. Temos usuários externos que acessam este sistema.
    Gostaria que, todas as requisições da rede interna, chamando o endereço xxx.xxx.net, o acesso seja redirecionado para o IP interno.

    Eu tenho um DNS Bind + AD. Eu tentei fazer isso no Bind, porem, se eu criar uma nova zona, vou ter que cadastrar todos os IP's do nosso domínio externo.
    O domínio interno é diferente do externo.

    É possível fazer isso ?



  • pelo que entendi, seu problema é apenas quando tenta acessar interno certo?

    se for este o caso, cadastre seu dominio no seu AD (que obviamente deve ser o que você entrega para os clientes locais) apontando pro endereço interno

    dessa forma, fica assim:

    usuarios fora da sua rede –> vai usar algum DNS publico ---> vai acessar seu DNS externo e pegar o endereço do ip público
    usuarios dentro da sua rede ---> vão receber o DNS interno (AD) ---> vao consultar este DNS e pegar o endereço interno



  • Olá chipbr
    Agradeço o contato.

    Você está correto, o problema ocorre quando usuários externos utilizam a rede interna.
    Eu tinha imaginado o cenário que você indicou, porem, não foi muito bem visto aqui, pois teremos que cadastrar vários hosts de serviços externos (ambientes de homologação, produção e etc…).

    Vamos aguardar para ver se surgi mais uma dica valiosa ai.



  • Faça um teste:

    Vai nas configurações de NAT/Portforward, edite a regra de redirecionamento a vc criou e mude a configuração do "NAT reflection" p/ "ENABLE  (NAT+PROXY)

    veja se funciona



  • Prezado rlrobs

    A sua dica foi super importante.
    Problema resolvido. Funcionou perfeitamente.
    Obrigado!


Log in to reply