SQUID+SQUIDGUARD NÃO INICIA (Resolvido)



  • Boa tarde!

    Realizei uma atualização do squid para versão 0.4, o mesmo parou de funcionar juntamente com squidguard, não sei se foi devido a atualização, gostaria de saber se existe uma forma de volta a versão anterior?

    Versão que foi instalada na atualização: squid-0.4.32



  • Defina o parar, você não consegue mais iniciar? ou ele da um start e depois da um stop



  • @charadasu:

    Boa tarde!

    Realizei uma atualização do squid para versão 0.4, o mesmo parou de funcionar juntamente com squidguard, não sei se foi devido a atualização, gostaria de saber se existe uma forma de volta a versão anterior?

    Versão que foi instalada na atualização: squid-0.4.32

    Explique direito o que exatamente você fez no seu fire.



  • Não inicia, andei mechendo hoje atualizei o squid para essa versão 0.4, instalei tambem lightsquid



  • Quando você migrou para a nova versão, você fez o update dos pacotes também? Você tem que fazer o passo a passo direitinho, primeiro instala o squid, configura o cache, depois instala o squidguard antes de ativar ele, der o comando parse:

    /usr/local/sbin/squid -k reconfigure
    

    Depois de instalado o squidguard você cria uma target categories, depois baixa black list e tenta ativar ele.



  • Onde tem esse passo a passo? eu atualizei as configurações se manteve, eu baixei a blacklist mais não foi mesmo, quando entro em pacotes não tem mais nada a atualizar. derrepente se puder reverter a atualização ja servia tem como?



  • @charadasu:

    Onde tem esse passo a passo? eu atualizei as configurações se manteve, eu baixei a blacklist mais não foi mesmo, quando entro em pacotes não tem mais nada a atualizar. derrepente se puder reverter a atualização ja servia tem como?

    É só você refazer o passo a passo de novo. Desinstala e instala novamente. depois que você instala o pacote do squidguard ele dar a mensagem pedindo pra você dar o comando ou via shell ou em command mesmo.



  • Se o seu Squid não subir execute o seguinte comando

    /usr/local/etc/rc.d/squid.sh

    Depois nos informe o resultado.



  • Reinstalei os dois pacotes ja veio com as configurações anteriores,

    configurei as target category e nada!



  • Me chama ai no skype



  • @BGB:

    Se o seu Squid não subir execute o seguinte comando

    /usr/local/etc/rc.d/squid.sh

    Depois nos informe o resultado.

    Executei deu nada.. Pelo jeito vou ter que formatar mesmo  :'(



  • @charadasu:

    @BGB:

    Se o seu Squid não subir execute o seguinte comando

    /usr/local/etc/rc.d/squid.sh

    Depois nos informe o resultado.

    Executei deu nada.. Pelo jeito vou ter que formatar mesmo  :'(

    Não precisa formatar, basta você restaurar configurações default e tentar tudo novamente. Vai passo a passo.



  • desculpa faltou um restart

    /usr/local/etc/rc.d/squid.sh restart



  • A solução foi retirar toda a configuração do squid pois tinha alguns dados inseridos de maneira errada.



  • Compartilhe a solução



  • @BGB:

    Compartilhe a solução

    Ele bloqueio o proxy dele em blacklist no squid em acl, fora outros detalhes básicos que ele também deixou de explanar para ajudarmos ele.



  • A solução foi retirar toda a configuração do squid pois tinha dados de entrada invalidos…


Log in to reply