[RESOLVIDO] Configurar acesso ao IP da WAN pela rede local (LAN)



  • Olá.
    Estou com um problema que nao encontrei a solução até então.
    Tenho um pfsense configurado para 200 usuarios com registro de MAC para segurança e atribuições de IP.

    Estou tendo problema para acessar o ip da minha WAN pela rede LAN, ou seja, qualquer IP da minha rede local que tenta acessar o ip da minha WAN na porta 80 (http) ele não acessa.

    Na minha porta WAN tem um NAT configurado liberando essa porta 80 (http) para conexão ao meu IP local. Ou seja, quem acessa de fora da minha rede local, consegue acesso normalmente, tudo funciona, porém quando tento acessar da minha rede local nao funciona.

    Ja tentei criar um NAT na LAN pra redirecionar mais nao funcionou.

    Alguma Ajuda?

    att.
    Edgard Wetler



  • Pra que tu quer acesso ao IP da WAN?



  • Testou NAT reflection?



  • @empbilly:

    Pra que tu quer acesso ao IP da WAN?

    Minha empresa tem um site, dentro dele existe um link que redireciona pro meu IP da WAN na porta 80.
    No meu firewall PFSENSE eu faço um NAT pra que esse ip da WAN redirecione pro meu ip local.
    Quem acessa de fora da rede da empresa consegue acesso normal.
    Mas quem ta na minha rede local não acessa esse ip da WAN pra poder redirecionar pro IP local.

    Uma solução seria colocar quem precisa acessar esse sistema configurar o ip da LAN manual em cada micro, porem são quase 200 maquinas, o mais viável seria configurar tanto quem acessa de fora como quem acessa da rede local funcionar e redirecionar normalmente.



  • @Tomas:

    Testou NAT reflection?

    Teste sim, mas sem sucesso.
    No caso vc diz o NAT reflection do NAT da WAN que eu criei, correto?



  • Va em System -> Advanced

    Aba Firewall & NAT

    logo abaixo onde tem Network Address Translation

    NAT Reflection mode for port forwards : PURE NAT

    Enable automatic outbound NAT for Reflection : Deixe marcado essa opção



  • @Edgard:

    @empbilly:

    Pra que tu quer acesso ao IP da WAN?

    Minha empresa tem um site, dentro dele existe um link que redireciona pro meu IP da WAN na porta 80.
    No meu firewall PFSENSE eu faço um NAT pra que esse ip da WAN redirecione pro meu ip local.
    Quem acessa de fora da rede da empresa consegue acesso normal.
    Mas quem ta na minha rede local não acessa esse ip da WAN pra poder redirecionar pro IP local.

    Uma solução seria colocar quem precisa acessar esse sistema configurar o ip da LAN manual em cada micro, porem são quase 200 maquinas, o mais viável seria configurar tanto quem acessa de fora como quem acessa da rede local funcionar e redirecionar normalmente.

    O pessoal da rede interna não consegue acessar teu site utilizando o IP interno?



  • @fabianofilhu:

    Va em System -> Advanced

    Aba Firewall & NAT

    logo abaixo onde tem Network Address Translation

    NAT Reflection mode for port forwards : PURE NAT

    Enable automatic outbound NAT for Reflection : Deixe marcado essa opção

    Opa, Procedimento realizado, porem, sem sucesso.
    Continuo nao tendo acesso pela rede local.



  • @empbilly:

    @Edgard:

    @empbilly:

    Pra que tu quer acesso ao IP da WAN?

    Minha empresa tem um site, dentro dele existe um link que redireciona pro meu IP da WAN na porta 80.
    No meu firewall PFSENSE eu faço um NAT pra que esse ip da WAN redirecione pro meu ip local.
    Quem acessa de fora da rede da empresa consegue acesso normal.
    Mas quem ta na minha rede local não acessa esse ip da WAN pra poder redirecionar pro IP local.

    Uma solução seria colocar quem precisa acessar esse sistema configurar o ip da LAN manual em cada micro, porem são quase 200 maquinas, o mais viável seria configurar tanto quem acessa de fora como quem acessa da rede local funcionar e redirecionar normalmente.

    O pessoal da rede interna não consegue acessar teu site utilizando o IP interno?

    O pessoal da minha rede interna consegue acessar pelo ip interno.
    Eles só nao conseguem acessar o ip da WAN, que é o ip que redireciona o site.



  • Bom dia. mais alguma ajuda por favor?
    obrigado



  • Bom dia,

    deixa eu ver se eu entendi:

    Você tem um site na sua rede interna exemplo: www.edgardwetler.com.br e quer acessar ele da rede interna sem ter que
    digitar o IP da rede interna é isso?

    Poste sua configuração de NAT.



  • @rogeriorabelo:

    Bom dia,

    deixa eu ver se eu entendi:

    Você tem um site na sua rede interna exemplo: www.edgardwetler.com.br e quer acessar ele da rede interna sem ter que
    digitar o IP da rede interna é isso?

    Poste sua configuração de NAT.

    vamos lá,

    Eu tenho um link no site que redireciona pro meu IP válido, que é o ip da wan, certo?
    Fiz o NAT pra esse ip da WAN direcionar pro meu ip local.
    Com essa configuração, qualquer ip externo que tenta acessar meu link dentro do meu servidor, funciona normalmente.
    O meu problema é os ips da minha rede local acessar esse ip da wan, que redireciona pro meu servidor.

    Deu pra entender?



  • Entendi.

    É o que o Tomas Waldow disse.

    Só você ir nessa regra NAT e mudar o NAT reflection para Enable( NAT + Proxy).



  • @rogeriorabelo:

    Entendi.

    É o que o Tomas Waldow disse.

    Só você ir nessa regra NAT e mudar o NAT reflection para Enable( NAT + Proxy).

    Então, ja foi feito esse procedimento
    Porem sem sucesso
    Segue foto da configuração




  • Habilite o NAT + Proxy somente na regra NAT, indo em Firewall >>>NAT>>Port Forward "EDITANDO A REGRA QUE VOCÊ CRIOU"



  • Teste o seguinte:

    Firewall > NAT > Outbound - Selecione manual e crie a regra.

    Interface Source Source Port Destination      Destination Port       NAT Address NAT Port Static Port     Description
    LAN        LAN net            *              192.168.1.7              *                    WAN address          *                NO                teste

    Poste se funcionou.



  • @rogeriorabelo:

    Habilite o NAT + Proxy somente na regra NAT, indo em Firewall >>>NAT>>Port Forward "EDITANDO A REGRA QUE VOCÊ CRIOU"

    Fiz conforme orientação.
    Sem sucesso.
    Algo mais que posso verificar?



  • @empbilly:

    Teste o seguinte:

    Firewall > NAT > Outbound - Selecione manual e crie a regra.

    Interface Source Source Port Destination      Destination Port       NAT Address NAT Port Static Port     Description
    LAN        LAN net            *              192.168.1.7              *                    WAN address          *                NO                teste

    Poste se funcionou.

    Fiz como me orientou, quando clico em manual outbound e salvo, ele aplica mas volta pra automático novamente.
    Quando crio a regra ele salva e aplica, porem a regra fica meio apagada, como se estivesse desabilitada.



  • @Edgard:

    @empbilly:

    Teste o seguinte:

    Firewall > NAT > Outbound - Selecione manual e crie a regra.

    Interface Source Source Port Destination      Destination Port       NAT Address NAT Port Static Port     Description
    LAN        LAN net            *              192.168.1.7              *                    WAN address          *                NO                teste

    Poste se funcionou.

    Fiz como me orientou, quando clico em manual outbound e salvo, ele aplica mas volta pra automático novamente.
    Quando crio a regra ele salva e aplica, porem a regra fica meio apagada, como se estivesse desabilitada.

    Estranho acontecer isso. Aqui comigo depois que coloquei pra "manual", permaneceu assim.

    Esquecia de avisar no post anterior.

    O 192.168.1.7 é exemplo e você deve mudar pro endereço privado do teu webserver.



  • @empbilly:

    @Edgard:

    @empbilly:

    Teste o seguinte:

    Firewall > NAT > Outbound - Selecione manual e crie a regra.

    Interface Source Source Port Destination      Destination Port       NAT Address NAT Port Static Port     Description
    LAN        LAN net            *              192.168.1.7              *                    WAN address          *                NO                teste

    Poste se funcionou.

    Fiz como me orientou, quando clico em manual outbound e salvo, ele aplica mas volta pra automático novamente.
    Quando crio a regra ele salva e aplica, porem a regra fica meio apagada, como se estivesse desabilitada.

    Estranho acontecer isso. Aqui comigo depois que coloquei pra "manual", permaneceu assim.

    Esquecia de avisar no post anterior.

    O 192.168.1.7 é exemplo e você deve mudar pro endereço privado do teu webserver.

    Olha como esta minha regra, esta correto?




  • Remove tua imagem, pois tem um IP publico ali.

    Tenta fazer da forma que esta na imagem em anexo.




  • @empbilly:

    Remove tua imagem, pois tem um IP publico ali.

    Tenta fazer da forma que esta na imagem em anexo.

    Então. segui sua orientação, porem quando eu clico em outra sub-rede em tradução ele nao exibe um lugar pra colocar o ip. so a porta.
    se coloco o ip no lugar da porta da erro.
    estranho. uma hora ele nao aceita configurar manual, depois nao ativa o lugar do ip.
    segue foto abaixo para verificar se nao to fazendo algo errado.




  • **Consegui resolver o problema da seguinte maneira.
    Criei uma regra no DNS local que tenho instalado no windows server 2008 pra redirecionar aquele link pro meu ip local.
    assim, quem ta de fora ganha acesso pelo pfsense e quem acessa de dentro da rede, o DNS resolve e redireciona pro ip local do servidor.

    Obrigado pela atenção galera.**



  • @Edgard:

    **Consegui resolver o problema da seguinte maneira.
    Criei uma regra no DNS local que tenho instalado no windows server 2008 pra redirecionar aquele link pro meu ip local.
    assim, quem ta de fora ganha acesso pelo pfsense e quem acessa de dentro da rede, o DNS resolve e redireciona pro ip local do servidor.

    Obrigado pela atenção galera.**

    Bacana!! Pra ficar mais organizado, edita teu primeiro post e coloca no titulo como [RESOLVIDO].

    Vlw.  ;D