Nintendo Switch - Needs static port on its outbound NAT


  • Rebel Alliance Developer Netgate

    At least with the one online multiplayer game I have used so far (Fast RMX) the only requirement for Nintendo Switch online multiplayer is static port outbound NAT. It did not appear to require UPnP, but it's safer to enable that in case another game needs it later.

    So as with the Wii U, 3DS, and other similar consoles the best course of action is:

    1. Set a static IP address for the device via DHCP static mappings

    • Status > DHCP Leases, find the device, click + to add a mapping, set a static address, save, etc.

    2. Switch to Hybrid Outbound NAT

    • Firewall > NAT, Outbound tab
    • Select Hybrid Outbound NAT, Save

    3. Add Outbound NAT rule

    • Firewall > NAT, Outbound tab
    • Click +
    • Set the console address as the source (Type = Network, then enter the IP address, pick /32 for the CIDR)
    • Check Static Port
    • Save/Apply

    4. (Optional, So far) Enable UPnP & NAT-PMP

    • Enable UPnP & NAT-PMP
    • Allow UPnP Port Mapping
    • Pick External (WAN) and Internal Interfaces (LAN)
    • Set other options as desired
    • Save

    EDIT: My son is using the Splatoon pre-release global test fire and the online multiplayer is working fine, still only using static port outbound NAT. No UPnP.



  • Thank you jimp.  This is a great reminder and advice for everyone on the forum.



  • Are you sure about this?

    I just tried and you can't set the console IP as the source as the only options are Network, Any or This  Firewall.

    think you may have applied Static Port to the whole LAN not the Switch specifically, in which case you do not need a new rule, just modify the existing one.


  • Rebel Alliance Developer Netgate

    Nope, just the switch. Use network and /32 for a single host on the outbound NAT source.



  • Thanks for this!  I just spent the hour trying to get the Splatoon 2 test fire working and for all I know, the entire event was to show off their new "Unable to connect" screen (I have a screenshot if you want to see it - it is very pretty!)

    I had UPNP enabled for the right addresses and it did nothing.  I then unchecked the 'deny access by default' option and it still did nothing.  If that didn't help, what good is UPNP anyway?  Or is this just Nintendo writing bad network code?

    Anyway, thanks again!


  • Rebel Alliance Developer Netgate

    Well UPnP is for inbound connections, outbound NAT is for outbound. Apparently the way their multiplayer code works, it needs to send back to the console on a particular port, which needs to be static so it's the same in both directions. Not sure why game servers can't just send back to the port it came from, but who knows…

    So UPnP does nothing for that kind of setup. Just setup the static port outbound NAT as I laid out above and it should be fine.

    At least there are two more days of test fires so keep trying. There are times tomorrow and Sunday. And even one more tonight. See attached (times in EDT)

    Edit: Not my pic. Shamelessly lifted from Reddit.




  • Still annoying that Nintendo did it this way.

    For a portable device that most likely will get used a fair bit on public networks that you CAN'T specify their outbound NAT settings, it seems like a very poor design indeed.

    Thanks for reminding me about the /32, it was only hours later I realised my mistake.  Its just been one of those days.



  • I made a thread dealing with these issues (https://forum.pfsense.org/index.php?reportsent;topic=127837.msg705258#msg705258) and followed your directions which were already mostly done besides hybrid NAT. I had no luck with those changes sadly and it's the end of the testfire so I'm unable to test further for now.



  • Just to confirm, making those changes did make it work for me.
    Thanks again.

    sirjorj



  • Good advice jimp! I will purchase it this weekend



  • This worked for me like a charm for months. Yesterday I received a second DSL and setup a multi-wan. Got the usual error again. So I added the static NAT for the second WAN line as well and to ne safe added a firewall rule so that the console only uses the original first WAN.

    Now sometimes it works and sometimes it does not. In the states diag I only see the first DSL being used. I am puzzled by this.


  • Rebel Alliance Developer Netgate

    If your Multi-WAN setup is using Load Balancing, you might need to force the switch to a failover group instead so it is not balanced. It might be sending some traffic out WAN1, other traffic out WAN2, and since the far side sees different addresses it may be cutting that off.



  • Already did that… Quote: "added a firewall rule so that the console only uses the original first WAN. "

    One day later everything seems to be fine. Maybe some missing old states.... Will monitor it...



  • These kind of posts are why I love this platform. I've never seen a platform where the actual people working on it post informational things like this for everyone to use.

    Major kudos to the Pfsense team.



  • This worked for the Switch AND for the PS4 that had NAT type 3.



  • Sorry for reviving an old post but should I disable static ports on all other mappings? For example, the automatically created rules for localhost to WAN, LAN to WAN, OPT1 to WAN, etc.? I also have multiple game systems that require the static port on. Is it all right to have static ports on all of them ON at the same time? I'm still very new to pfSense (this is my post here, in fact!).



  • Thank you very much a very simple and elegant solution. You made my son very happy. I will be adding other console to help with gaming.

    Thank Again. :)


  • Netgate

    @AkiraSensei:

    Sorry for reviving an old post but should I disable static ports on all other mappings? For example, the automatically created rules for localhost to WAN, LAN to WAN, OPT1 to WAN, etc.? I also have multiple game systems that require the static port on. Is it all right to have static ports on all of them ON at the same time? I'm still very new to pfSense (this is my post here, in fact!).

    As long as they do not need the same source port to talk with the same destination address:port it should be OK. There can only be one state for each local_wan_ip:port <-> remote_ip:port combination. Setting static port just means that the source port is left untranslated when connections are made outbound. If the local machine connects using source port 55000, then that port will be used on the WAN interface as the source port. Without static set, the port can be randomly selected from the ephemeral port space (1024 to 65535) and translated on WAN.



  • this solved my problem on both the wii u and switch. thank you!



  • Hi thank you for this guide.  I had problems getting the NAT type from a D to a C or B even after following your steps but I eventually figured out what was happening.

    In the step below, I found that the Mappings order was important.  I originally added the rule as the last entry.  When I moved the Mappings entry up above the other LAN entries I started getting NAT type B.

    @jimp:

    3. Add Outbound NAT rule

    • Firewall > NAT, Outbound tab
    • Click +
    • Set the console address as the source (Type = Network, then enter the IP address, pick /32 for the CIDR)
    • Check Static Port
    • Save/Apply

    ...



  • Well, i did exactly this, but my switch still says its type D :(

    Maybe someone sees anything I missed here: https://forum.pfsense.org/index.php?topic=141535.0



  • I posted this in a different thread by accident ….

    having some trouble here - I'm getting the error Nintendo code:

    error code: 2618-0516
    NAT traversal process has failed
    etc…

    I've attached the firewall/nat/outbound screen - have I missed anything?



  • Rebel Alliance Developer Netgate

    @c4bcons:

    I posted this in a different thread by accident ….

    having some trouble here - I'm getting the error Nintendo code:

    error code: 2618-0516
    NAT traversal process has failed
    etc…

    I've attached the firewall/nat/outbound screen - have I missed anything?

    Looks like your NAT rule is set on the internal (LAN) interface when it should be on the WAN interface. Edit that rule, change it to WAN, Save, Apply.



  • Yes!  ;D as simple as that.  Just changed it to "WAN".  Nothing else.  Thank you very much for a helpful thread!!



  • @jimp:

    At least with the one online multiplayer game I have used so far (Fast RMX) the only requirement for Nintendo Switch online multiplayer is static port outbound NAT. It did not appear to require UPnP, but it's safer to enable that in case another game needs it later.

    So as with the Wii U, 3DS, and other similar consoles the best course of action is:

    1. Set a static IP address for the device via DHCP static mappings

    • Status > DHCP Leases, find the device, click + to add a mapping, set a static address, save, etc.

    2. Switch to Hybrid Outbound NAT

    • Firewall > NAT, Outbound tab
    • Select Hybrid Outbound NAT, Save

    3. Add Outbound NAT rule

    • Firewall > NAT, Outbound tab
    • Click +
    • Set the console address as the source (Type = Network, then enter the IP address, pick /32 for the CIDR)
    • Check Static Port
    • Save/Apply

    4. (Optional, So far) Enable UPnP & NAT-PMP

    • Enable UPnP & NAT-PMP
    • Allow UPnP Port Mapping
    • Pick External (WAN) and Internal Interfaces (LAN)
    • Set other options as desired
    • Save

    EDIT: My son is using the Splatoon pre-release global test fire and the online multiplayer is working fine, still only using static port outbound NAT. No UPnP.

    THANK YOU!!!! For taking the time to outline this. Works perfect for the new Nintendo Switch in the house. Kids have been trying to play Splatoon 2 online and kept having issues until I found this.

    Thanks again for helping a NOOB who loves pfSense!



  • Hey Dude,
    Thanks a million for that post.  I just spend my whole afternoon trying to get Splatoon 2 multiplayer working on my son's Nintendo Switch
    After I found this post it worked in a flash

    THANK YOU !!!


  • Rebel Alliance Developer Netgate

    Please keep future posts in this thread related to the Nintendo Switch only, thanks!

    I split off an tangent conversation into a new thread.



  • I'm not having any luck getting the NAT type to report anything other than type D

    Hopefully I'm just missing something.. Here are my settings.

    0_1533177079256_2018-08-01_22-31-00.png

    0_1533176924933_2018-08-01_22-26-25.png

    thanks


  • Rebel Alliance Developer Netgate

    @tvaldes said in Nintendo Switch - Needs static port on its outbound NAT:

    I'm not having any luck getting the NAT type to report anything other than type D

    Hopefully I'm just missing something.. Here are my settings.

    As long as your switch is actually being assigned 10.0.0.139 that outbound NAT rule is OK.

    What exactly is reporting "type D" for NAT? I haven't played any online games on my switch lately.

    Have you enabled UPnP? It's possible a game may want that enabled as well.



  • @jimp said in Nintendo Switch - Needs static port on its outbound NAT:

    @tvaldes said in Nintendo Switch - Needs static port on its outbound NAT:

    I'm not having any luck getting the NAT type to report anything other than type D

    Hopefully I'm just missing something.. Here are my settings.

    As long as your switch is actually being assigned 10.0.0.139 that outbound NAT rule is OK.

    What exactly is reporting "type D" for NAT? I haven't played any online games on my switch lately.

    Have you enabled UPnP? It's possible a game may want that enabled as well.

    My switch is definitely getting the IP.
    The NAT type D is coming from the Nintendo Switch Connection Test
    I also configured UPnP as described in Step 4

    0_1533220814568_nintendo_switch_config_test.jpg


  • Rebel Alliance Developer Netgate

    Hmm, my setup is configured the same way (static port outbound for the switch, UPnP enabled) and I get NAT Type B here. Maybe you have another device between the switch and pfSense, or between pfSense and the Internet, that is altering its behavior?



  • @jimp It's wireless so the only device is my access point and an unmanaged switch

    order from internet to nintendo switch

    cable modem
    pfsense
    unmanaged switch
    wireless AP
    nintendo switch

    Is there an associated firewall rule I might be missing?


  • Rebel Alliance Developer Netgate

    No, a firewall rule wouldn't prevent anything there, unless you have a second WAN or VPN that the switch is getting policy routed out so it doesn't hit that static port rule.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy