Disk usage shows 100% after updating to squid 2.6.18.1_06



  • hi,

    i a running pfs 1.2, i updated squid last night, and since my disk usage shows 100% and clients coudnt get lease from dhcp, help really apreciated

    thanks in advance

    hadi57



  • @hadi57:

    i a running pfs 1.2, i updated squid last night, and since my disk usage shows 100% and clients coudnt get lease from dhcp, help really apreciated

    I also had this. The quick way - to get you started again - is to:

    Stop squid
    Get into a root shell on your pfSense box
    Run "rm /var/squid/cache/swap.state"
    I can't remember if you need to run "squid -z" but there should be no harm in running it.
    Start squid

    You'll start off with an empty cache but it should start working.



  • I´m running squid 2.6.21_07 on a Pfsense 1.2.1-RC2  and yesterday the proxy crashed. I checked the machine 4 hours before the chrash and it showed 2% disc usage. Then, suddenly 100%. So, on 4 hours the swap.state file had filled up 120gb with… something.

    I deleted the file and rebooted the machine and everything runs again. But, I still dont know what caused the problem. Anyone got an idea? Or, have found a solution wich prevents it from happening again.



  • @Bern:

    @hadi57:

    i a running pfs 1.2, i updated squid last night, and since my disk usage shows 100% and clients coudnt get lease from dhcp, help really apreciated

    I also had this. The quick way - to get you started again - is to:

    Stop squid
    Get into a root shell on your pfSense box
    Run "rm /var/squid/cache/swap.state"
    I can't remember if you need to run "squid -z" but there should be no harm in running it.
    Start squid

    You'll start off with an empty cache but it should start working.

    tx man i have 1.2.2 and there is still this problem width pf.



  • I am now using diskd for "Hard disk cache system" of squid.
    I hope this is solution!



  • Nope it is not. Is there hope that 1.2.3 RC1 solved this problem?
    What about captive portal is it working width squid transparent cache?



  • no one?
    i am removing lightsquid… and i will see if there is hope


  • Rebel Alliance Developer Netgate

    I had this happen on one system, had to completely delete the cache. For some reason it was using twice as much space as I configured it to use.

    Following bern's post above should get it working again.



  • @jimp:

    I had this happen on one system, had to completely delete the cache. For some reason it was using twice as much space as I configured it to use.

    Following bern's post above should get it working again.

    yeap, i learned. but i want to setup pf box and be sure that won't happen more than once :)



  • happened again. pf & squid is useless now 4 me.
    can anyone point me how to upgrade or install newer version of squid v2.x ?



  • Good afternoon. Same problem here too. I setup 3 boxes of 1.2.2. The 1st one got 100% full disk. So I manually "rm" the swap. But then this afternoon i still got the problem 100% full disk again..The other 2 boxes have no problem.. Strange isnt it… Tried reinstalled the squid same thing 100% swap cache disk full. I even reformat the 1st box same thing 100% disk full cache swap..But the 2 boxes still running and no problem... Anyone?

    Thanks,
    jigp 1.2.2



  • Looks like it might be time for some people to take a look in the bounty forum…$250 to create a 2.7 stable 6 package.



  • 1.2.3-RC2
    built on Sat Sep 5 07:02:34 UTC 2009

    this snapshot and widthout lightsquid 'till now and no problem width 100% disk usage. finnaly stable.



  • i can confirmed this. problem solved.



  • 3 boxes here both of them have lightsquid+squid+sg ..but box1 failed and 100% full disk again whew!… 1.2.2



  • update to last snapshot. it worked 4 me



  • Correction, do not upgrade to R3!! I have now same problem, because I was bored and upgrade my firmware to R3. S**T



  • Works fine here RC3 downloaded September 23 http://snapshots.pfsense.org/FreeBSD_RELENG_7_2/pfSense_RELENG_1_2/livecd_installer/pfSense-1.2.3-20090923-1717.iso.gz..

    I'm still monitoring it. seems like my disk usage is 2% (users: 16)

    jigp



  • i am now using
    1.2.3-RC3
    built on Mon Sep 21 07:02:42 UTC 2009
    3 days is uptime, no crash 'till now



  • @Bern:

    @hadi57:

    i a running pfs 1.2, i updated squid last night, and since my disk usage shows 100% and clients coudnt get lease from dhcp, help really apreciated

    I also had this. The quick way - to get you started again - is to:

    Stop squid
    Get into a root shell on your pfSense box
    Run "rm /var/squid/cache/swap.state"
    I can't remember if you need to run "squid -z" but there should be no harm in running it.
    Start squid

    You'll start off with an empty cache but it should start working.

    thanks man it's work with me



  • Same problem for. So I stop squid -> rm cache -> Suppress Squid and Reinstall.
    All works good but … If I set auth settings to LDAP, squid crashed with an error :

    Oct 21 16:19:30 squid[44415]: The basicauthenticator helpers are crashing too rapidly, need help!
    Oct 21 16:19:29 squid[37416]: Squid Parent: child process 44415 started
    Oct 21 16:19:26 squid[37416]: Squid Parent: child process 37418 exited due to signal 6
    Oct 21 16:19:26 kernel: pid 37418 (squid), uid 62: exited on signal 6
    Oct 21 16:19:26 squid[37418]: The basicauthenticator helpers are crashing too rapidly, need help!
    Oct 21 16:19:26 check_reload_status: reloading filter

    Any idea ?


  • Rebel Alliance Developer Netgate

    For good measure (and the archives), this swap.state file will be compacted every night when you run squid -k rotate.

    This is run in a cron job on pfSense but only if you specify the number of days to keep squid log files (option "Log rotate").

    That is the long term solution to make sure this doesn't recur, it would seem.



  • i am having this crash again, even width last snapshot and squid 2.7 update.
    didn't understand this "compact" is it wish feature or implemented. if it is it doesn't work.


  • Rebel Alliance Developer Netgate

    @sartic:

    i am having this crash again, even width last snapshot and squid 2.7 update.
    didn't understand this "compact" is it wish feature or implemented. if it is it doesn't work.

    You have to set a value in the "log rotate" field of the squid configuration to enable the compacting.

    You can also just go to the console (or Diagnostics > Command) and run:

    squid -k rotate

    Which will do it immediately.



  • it was always defined (10 days).


  • Rebel Alliance Developer Netgate

    Can you install the Cron package and verify that you have a cron job present for squid?



  • http://www.endrigo.com/temp/cron.jpg

    every time i have crash i update pf. but crashes r more often now. i even change 10 days to 2.
    i had no problem width RC2 snapshots



  • today i had same crash again. i stopped squid as usual, erase state and state.new files as always …. bla bla
    and then i update firmware to last snapshot. after reboot pf was totally broken.
    i was totally mad. removed oldish 4GB ata disk width newer 160GB and restored xml.
    i won't touch update until stable release on this pf box.



  • again crash. today i uninstalled squid. who cares for 10% of hits, i give up



  • I'm using pf 1.2.2 + squid 2.6.21_10 + squidGuard 1.3-2 in production stable without any crash (about 2 months uptime) but without caching to disk, lets said, disk cache disabled. Not sure if it is usefull for you guys.

    Cheers



  • my friend is trying now width store log disabled. i will ask him after 10 days.



  • I'm experiencing this weird issue with pfSense 1.2.3-RELEASE and squid 2.7.8_1, all of a sudden my disk is full and squid and related services stopped. As suggested in this same thread I was able to find out that my /var/squid/cache ballooned to 33GB for no logical reason, and as also suggested I've deleted said directory but after deletion my hard drive is still around 97% full and then 100% full again, how can this be correct if I've just deleted 33GB worth of space? After this squid stopped working then my hard drive free disk space was suddenly back to normal, this is really weird!

    As last resort I did a windows thing (rebooted the box) and what do you know it's working again with disk capacity of only 9% which is normal.

    Anybody experiencing this?

    Culprit?


  • Rebel Alliance Developer Netgate

    If you deleted the directory but did not stop squid first, then squid probably still had files open and the space wasn't released yet.

    See:
    http://doc.pfsense.org/index.php/Why_is_squid_using_100%25_of_my_drive_space%3F
    and
    http://doc.pfsense.org/index.php/Squid_Package_Tuning#Compact_swap.state



  • try to disable store log for squid. wish u luck


Log in to reply