Can't update from 2.3.3 to 2.3.4