Just moved from the UK to China - problems



  • I have just moved from the UK to China for job purposes. When I log on to dashboard:
    My pfsense qotom i5 -5250:
    WAN 100baseTX (up green arrow) <full-duplex>  0.0.0.0
    LAN  (up green arrow)  1000baseT <full-duplex>  192.168.1.1

    DNS server(s) •127.0.0.1

    I have tried to connect qotom box via its HDMI output to a full HD TV which says
    "no signal". Powered down via the round off button on the qotom, no signal seen on TV.

    My set up: to make sure all is working
    from Ethernet wall socket (which normally is connected to an ancient tp link wireless router - still has wpa2 aes encryption)
    to my qotom wan port on the most left hand side (next to the power / hard drive access led which is glowing a dull red). This used to be my wan incoming raw internet which is now only showing an orange led which stays on.

    The ethernet cable on the far right hand side of the qotom connected to my ethernet port of my laptop is showing both: green consistantly on and orange only which flashes randomly.

    I want to when things are working to have this setup:
    internet raw incoming from wall -> to pfsense qotom (port on the most left hand side (next to the power / hard drive access led) then -> Ethernet cable on the far right hand side connected to my Ethernet port of my switch.
    This 5 port switch I will use its Ethernet port 1 to connect from pfsense box (port on the most right hand side) to bring in the pfsense secured internet to connect my laptop directly via ethernet port 2 on switch, I then have to use wireless for my Android phone which will allow the ancient tp link wireless ap to connect via ethernet port 3.

    Is ths correct?

    Why cannot I get a wan connection?

    I have tried two working Ethernet cables, same result, no wan connection.
    ![Interfaces Interface Assignments.png](/public/imported_attachments/1/Interfaces Interface Assignments.png)
    ![Interfaces Interface Assignments.png_thumb](/public/imported_attachments/1/Interfaces Interface Assignments.png_thumb)</full-duplex></full-duplex>



  • OK, I can now see the HDMI output, tried to reconfigure wan then lan. Now pfsense recognises both Ethernet ports, but still no wan and now no lan.
    Tested all Ethernet cables, all are working.



  • Nobody can help me please?



  • @Waqar.UK:

    Nobody can help me please?

    Maybe we're having difficulty understanding what your problem is.  For example:

    I have tried to connect qotom box via its HDMI output to a full HD TV which says
    "no signal". Powered down via the round off button on the qotom, no signal seen on TV.

    Does that mean the TV is getting no signal from the qotom (whatever that is) box?  Or the box is not getting a signal?  What happens if you connect that box directly to your internet connection, without going through pfSense?



  • The Qotom is the box pfSense is running on.

    Assuming you can see the shell output from pfSense as it boots, if you get to the shell menu and login it should give you the IP addresses of both the WAN and the LAN interface, does it?

    Edit…

    That should read login and get to the shell menu.  ;)



  • on the screenshot you posted, clock WAN then post a screenshot of what your settings are there.



  • @marjohn56:

    The Qotom is the box pfSense is running on.

    Assuming you can see the shell output from pfSense as it boots, if you get to the shell menu and login it should give you the IP addresses of both the WAN and the LAN interface, does it?

    Edit…

    That should read login and get to the shell menu.  ;)

    I tried auto recognition of interfaces, /I get iG0 = wan and iG1 = wan. Both have no IP from console.
    Also I cannot log onto the web interface now.



  • @JKnott:

    @Waqar.UK:

    Nobody can help me please?

    Maybe we're having difficulty understanding what your problem is.  For example:

    I have tried to connect qotom box via its HDMI output to a full HD TV which says
    "no signal". Powered down via the round off button on the qotom, no signal seen on TV.

    Does that mean the TV is getting no signal from the qotom (whatever that is) box?  Or the box is not getting a signal?  What happens if you connect that box directly to your internet connection, without going through pfSense?

    The TV is now seeing the HDMI output from my pfsense box.


  • Banned

    Yeah that's wonderful. Perhaps draw some network diagram, completely failed to understand your description in the first post.



  • I have the qotom box with the Ethernet ports facing towards me. First port is on the left hand side (same side as red hard drive and yellow power light).

    Internet Ethernet cable-> qotom first Ethernet port on left hand side is seen in shell menu as iG0 as my wan port when I chose auto recognition -> most right hand side port I have chosen as my lan so in shell menu iG1 - > connected to Ethernet port of my Win 7 64 laptop.

    When I type in any browser 192.168.1.1, I used to get the web interface. Now no more web interface since I tried to re -recognise my wan and lan ports.
    I have backed up my previous config file when my qotom box was working back home in London.



  • @belt9:

    on the screenshot you posted, clock WAN then post a screenshot of what your settings are there.

    Since trying to re - recognise my wan port, I cannot get to a web interface anymore.



  • HDMI ??
    What ports (NICS ?)  ?
    This guy https://forum.pfsense.org/index.php?topic=137702.0 also struggles with the same device  …

    How are you sure that what you think the LAN is, is really the LAN port.
    And WAN ?
    The rest will be OPT1 and OPT2.

    Remember, we have only your words - nothing to test, no images.



  • @Gertjan:

    HDMI ??
    What ports (NICS ?)  ?
    This guy https://forum.pfsense.org/index.php?topic=137702.0 also struggles with the same device  …

    How are you sure that what you think the LAN is, is really the LAN port.
    And WAN ?
    The rest will be OPT1 and OPT2.

    Remember, we have only your words - nothing to test, no images.

    I am using the HDMI port on the qotom to output to  HD TV.
    I have installed pfsense on this machine while back home, it worked perfectly. I remembered which was LAN and the other was WAN. Yes, others will be OPT1 and OPT2.



  • What pfSense version are you running? When was the last snapshot update carried out?



  • @Waqar.UK:

    I have installed pfsense on this machine while back home, it worked perfectly. I remembered which was LAN and the other was WAN. Yes, others will be OPT1 and OPT2.

    So, it works.
    You shut it down - put it in a box, put it out of the box, hooked it up and … interfaces are lost.
    Without no more info : that's not a software issue. More a hardware (power ?)  issue.
    LAN would be up right away. WAN would be different, because more "ISP" related.

    If the situation exists that because WAN is down, LAN is also down then your setup was broken to begin with.

    What about resetting it ? Use the console access - assign a LAN - FIND the LAN port (it will give you an IP etc - you can access the GUI on it) and then setup your WAN, etc.



  • @marjohn56:

    What pfSense version are you running? When was the last snapshot update carried out?

    Latest stable version.



  • @Gertjan:

    @Waqar.UK:

    I have installed pfsense on this machine while back home, it worked perfectly. I remembered which was LAN and the other was WAN. Yes, others will be OPT1 and OPT2.

    So, it works.
    You shut it down - put it in a box, put it out of the box, hooked it up and … interfaces are lost.
    Without no more info : that's not a software issue. More a hardware (power ?)  issue.
    LAN would be up right away. WAN would be different, because more "ISP" related.

    If the situation exists that because WAN is down, LAN is also down then your setup was broken to begin with.

    What about resetting it ? Use the console access - assign a LAN - FIND the LAN port (it will give you an IP etc - you can access the GUI on it) and then setup your WAN, etc.

    I will try again to get a LAN IP.
    I will use choose a for auto detection.
    How do I setup a WAN within the GUI?



  • Oh Dear….

    Basics, first things first. In the shell set the Interfaces correctly, until those are correct you are never going to get anywhere. Once you have a valid LAN connection/configuration, then you can use the web interface to set it the rest up.



  • @marjohn56:

    Oh Dear….

    Basics, first things first. In the shell set the Interfaces correctly, until those are correct you are never going to get anywhere. Once you have a valid LAN connection/configuration, then you can use the web interface to set it the rest up.

    Hello marjohn56,

    sorry to be a pain, I am trying to follow your instructions, now I cannot even see the console via HDMI. The cable works between my laptop and TV.



  • @Waqar.UK:

    @marjohn56:

    Oh Dear….

    Basics, first things first. In the shell set the Interfaces correctly, until those are correct you are never going to get anywhere. Once you have a valid LAN connection/configuration, then you can use the web interface to set it the rest up.

    Hello marjohn56,

    sorry to be a pain, I am trying to follow your instructions, now I cannot even see the console via HDMI. The cable works between my laptop and TV.

    O.K. Power off the Qotom, unplug it!

    Next remove the HDMI cable from the laptop and plug it into the Qotom,  power on the Qotom - watch the screen…..

    Do you see anything?

    If the answer is yes, then tell us what you see. If the answer is no, then the Qotom is borked.



  • @marjohn56:

    @Waqar.UK:

    @marjohn56:

    Oh Dear….

    Basics, first things first. In the shell set the Interfaces correctly, until those are correct you are never going to get anywhere. Once you have a valid LAN connection/configuration, then you can use the web interface to set it the rest up.

    Hello marjohn56,

    sorry to be a pain, I am trying to follow your instructions, now I cannot even see the console via HDMI. The cable works between my laptop and TV.

    O.K. Power off the Qotom, unplug it!

    Next remove the HDMI cable from the laptop and plug it into the Qotom,  power on the Qotom - watch the screen…..

    Do you see anything?

    If the answer is yes, then tell us what you see. If the answer is no, then the Qotom is borked.

    Yes, I see console now, after leaving it off for a few minutes:
    WAN (wan) -> igb0 ->
    LAN (lan) -> igb1 ->



  • What is the ip address given for the LAN?



  • @marjohn56:

    What is the ip address given for the LAN?

    LAN IP is:  https://192.168.1.1

    LAN  (up green arrow)  1000baseT <full-duplex>  192.168.1.1  both green and yellow LEDs yare lit.

    My Internet Ethernet is plugged into the ancient tp link router, when I un plug it and put it into my Ethernet port that I have designated as a WAN igb0 only the yellow LED lights up.</full-duplex>


  • Banned

    ZOMG. At the interfaces autodetection, get ALL cables unplugged. Let it probe for WAN. Plug in the cable to what you think is your WAN. Does it get an IP lease? If not, plug in the cable in what you think is your LAN.



  • Progress…

    Now, goto your laptop and set a STATIC ip address on the lan of 192.168.1.50. Mask 255.255
    255.0. Gateway should he .1 but it's not important at this point. Now open a cms prompt and if Windows then ping 192.168.1.1 -t and connect a cat cable between the laptop and qotom, if you see a response you vs found the lan, if not.move to the next port until you find a response. Once you have a response you can then browse to offense and set the rest up.



  • I am getting:

    Microsoft Windows [Version 6.1.7601]
    Copyright © 2009 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>ping 192.168.1.1 -t

    Pinging 192.168.1.1 with 32 bytes of data:
    Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=3ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=3ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=64

    again and again



  • @doktornotor:

    ZOMG. At the interfaces autodetection, get ALL cables unplugged. Let it probe for WAN. Plug in the cable to what you think is your WAN. Does it get an IP lease? If not, plug in the cable in what you think is your LAN.

    I have tried that, only the LAN is recognised, the WAN only flashes orange.



  • Ok, you should now be able to browse into pfsense. Connect the wan port after you have browsed to the control panel.



  • Assuming you can now browse to the control panel AND you have connected the WAN cable, you will the need check your wan settings are correct and your lan dhcp server settings are correct before restoring your laptop lan setting to DHCP.



  • @marjohn56:

    Ok, you should now be able to browse into pfsense. Connect the wan port after you have browsed to the control panel.

    I have connected my WAN cable (same one that goes into the old tp link router which allows me internet access), but all I get is a orange flashing led with no green led.



  • @marjohn56:

    Assuming you can now browse to the control panel AND you have connected the WAN cable, you will the need check your wan settings are correct and your lan dhcp server settings are correct before restoring your laptop lan setting to DHCP.

    How do I, do that please? As the internet was set up by the estate agent who only gave me the ssid and password to connect wirelessly.

    Attached is a screen grab of my WAN settings.

    ![WAN in China.png](/public/imported_attachments/1/WAN in China.png)
    ![WAN in China.png_thumb](/public/imported_attachments/1/WAN in China.png_thumb)



  • What are you connecting the WAN port to?

    Dok, is this you having a laugh?  :o



  • @marjohn56:

    What are you connecting the WAN port to?

    Dok, is this you having a laugh?  :o

    I am connecting my Ethernet coming into my flat to my pfsense box WAN.



  • This has been super entertaining!

    How certain are you that this WAN cable you are connecting to has a live WAN connection?

    Turn the wifi adapter on your laptop completely off, then plug the ethernet cable you think is WAN into you laptop or desktop.

    Can you access the internet?

    If not, restart the computer and try again.

    If you still can't access the internet, see if you can ping something ubiquitous.

    Try```
    ping www.baidu.com

    
    If that doesn't work, then the cable you think is WAN, is actually not WAN at all.

  • Banned

    @belt9:

    How certain are you that this WAN cable you are connecting to has a live WAN connection?
    If that doesn't work, then the cable you think is WAN, is actually not WAN at all.

    The guy is just NOT reading.



  • This is perfect. I'm wondering if he had the interwebs turned on when he moved?
    Would his new location be a part of the issue? Doesn't China proxy everything, to protect its citizens, or is that just DPRK?
    On a lighter note, I too have a Qotom box, however my nics register as re0 and re1.

    @belt9:

    This has been super entertaining!

    How certain are you that this WAN cable you are connecting to has a live WAN connection?

    Turn the wifi adapter on your laptop completely off, then plug the ethernet cable you think is WAN into you laptop or desktop.

    Can you access the internet?

    If not, restart the computer and try again.

    If you still can't access the internet, see if you can ping something ubiquitous.

    Try```
    ping www.baidu.com

    
    If that doesn't work, then the cable you think is WAN, is actually not WAN at all.


  • @doktornotor:

    @belt9:

    How certain are you that this WAN cable you are connecting to has a live WAN connection?
    If that doesn't work, then the cable you think is WAN, is actually not WAN at all.

    The guy is just NOT reading.

    I still think it's you on a wind-up.



  • @mtarbox:

    This is perfect. I'm wondering if he had the interwebs turned on when he moved?
    Would his new location be a part of the issue? Doesn't China proxy everything, to protect its citizens, or is that just DPRK?
    On a lighter note, I too have a Qotom box, however my nics register as re0 and re1.

    I think it all has to go through the Great Firewall of China. Quite surprised he's managed to get this far, but no mention of the party please, otherwise he'll be Peking Ducked.



  • @Waqar.UK:

    @marjohn56:

    Ok, you should now be able to browse into pfsense. Connect the wan port after you have browsed to the control panel.

    I have connected my WAN cable (same one that goes into the old tp link router which allows me internet access), but all I get is a orange flashing led with no green led.

    That could mean that all you have is 100Mbps connection or even 10Mbps ( yuk ).

    I think I am now understanding that the WAN cable as it comes in is currently connected to the old TP-Link router, for which you have been given the SSID and password.

    OK, let's see how close I am to the truth, connect the WAN cable to pfSense, go to the pfSense control panel and what does it say about the interfaces, they should both be up ( if your laptop is connected to the LAN port that is! ). Does the WAN show it is connected at all ( Speed wise )?

    Ideally, you would need to log into the old TP-Link and see how the WAN connection is set-up, it may be a static IP for all you know on the WAN side.


  • Banned

    @marjohn56:

    Ideally, you would need to log into the old TP-Link and see how the WAN connection is set-up, it may be a static IP for all you know on the WAN side.

    Could also be a MAC filter on the other side, trying to prevent the use of different hardware. So it could help to use the WAN MAC of the TP-Link for the WAN interface in pfSense.


Log in to reply