Upgrade to 2.4 killed my SG-2220



  • Hi guys

    I made sure I had enough free disk space, only 37% percent used.

    Upgrade ran without any notice in GUI,- rebooted.

    It never came up again, the console runs normal procedures, but ends up with this:

    login: : PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/rrd.so' - Shared object "libglib-2.0.so.0" not login: required by "librrd.so.8" in Unknown on line 0
    login:
    login: : PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/zmq.so' - /usr/local/lib/libsodium.so.18: Undeflogin: mbol "explicit_bzero" in Unknown on line 0
    login:  2.4.0-RELEASE (Patch 1) amd64 Tue Oct 10 06:44:22 CDT 2017
    login: complete
    login:
    login: /amd64 (Amnesiac) (ttyu1)
    login:

    Any idea,- or should I downgrade to 2.3 and wait for bug fixes?


  • Rebel Alliance Developer Netgate

    How exactly did you run the upgrade?

    What is in /conf/upgrade_log.latest.txt ? What about /conf/upgrade_log.txt ?

    A fresh install of 2.4 using an ADI memstick image, then using the 'rescue config.xml' option during the installation will get you up and running faster than anything else.



  • 2.4 also killed my SG-2220. If you need the upgrade_log.txt I saved a copy. My main issue now is that I can't find the reinstall image for this board. The docs say "Retrieve the appropriate installer image after logging in on the Portal account page" but my portal page doesn't really let me access anything since I don't have a current gold subscription.


  • Rebel Alliance Developer Netgate

    @andy:

    2.4 also killed my SG-2220. If you need the upgrade_log.txt I saved a copy. My main issue now is that I can't find the reinstall image for this board. The docs say "Retrieve the appropriate installer image after logging in on the Portal account page" but my portal page doesn't really let me access anything since I don't have a current gold subscription.

    You can use the CE ADI install memstick from https://www.pfsense.org/download/



  • [37/164] Extracting pear-Net_URL2-2.2.1: .......... done
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/ldap.so' - Shared object "libssl.so.7" not found, required by "libldap-2.4.so.2" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/mbstring.so' - Shared object "libonig.so.2" not found, required by "mbstring.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/openssl.so' - Shared object "libssl.so.7" not found, required by "openssl.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/readline.so' - Shared object "libreadline.so.8" not found, required by "readline.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/ssh2.so' - Shared object "libssl.so.7" not found, required by "libssh2.so.1" in Unknown on line 0
    install ok: channel://pear.php.net/Net_URL2-2.2.1
    [38/164] Installing pear-Net_Socket-1.0.14...
    [38/164] Extracting pear-Net_Socket-1.0.14: .. done
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/ldap.so' - Shared object "libssl.so.7" not found, required by "libldap-2.4.so.2" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/mbstring.so' - Shared object "libonig.so.2" not found, required by "mbstring.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/openssl.so' - Shared object "libssl.so.7" not found, required by "openssl.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/readline.so' - Shared object "libreadline.so.8" not found, required by "readline.so" in Unknown on line 0
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/ssh2.so' - Shared object "libssl.so.7" not found, required by "libssh2.so.1" in Unknown on line 0
    install ok: channel://pear.php.net/Net_Socket-1.0.14
    [39/164] Installing libunistring-0.9.7...
    [39/164] Extracting libunistring-0.9.7: .......... done
    [40/164] Deinstalling openvpn23-2.3.17...
    [40/164] Deleting files for openvpn23-2.3.17: .....
    openvpn23-2.3.17: missing file /usr/local/man/man8/openvpn.8.gz
    [40/164] Deleting files for openvpn23-2.3.17........ done
    [41/164] Upgrading webp from 0.5.2_1 to 0.6.0_4...
    [41/164] Extracting webp-0.6.0_4: .......... done
    [42/164] Upgrading strongswan from 5.5.1_1 to 5.6.0...
    [42/164] Extracting strongswan-5.6.0: .......... done
    [43/164] Upgrading sqlite3 from 3.17.0 to 3.20.1_1...
    [43/164] Extracting sqlite3-3.20.1_1: .......... done
    [44/164] Reinstalling php56-session-5.6.31...
    [44/164] Extracting php56-session-5.6.31: .......... done
    [45/164] Reinstalling php56-pdo-5.6.31...
    [45/164] Extracting php56-pdo-5.6.31: .......... done
    [46/164] Reinstalling php56-mcrypt-5.6.31...
    [46/164] Extracting php56-mcrypt-5.6.31: ........ done
    [47/164] Reinstalling php56-hash-5.6.31...
    [47/164] Extracting php56-hash-5.6.31: .......... done
    [48/164] Reinstalling php56-dom-5.6.31...
    [48/164] Extracting php56-dom-5.6.31: .......... done
    [49/164] Reinstalling php56-curl-5.6.31...
    [49/164] Extracting php56-curl-5.6.31: ....... done
    [50/164] Reinstalling pecl-radius-1.4.0.b1...
    [50/164] Extracting pecl-radius-1.4.0.b1: .......... done
    [51/164] Upgrading pciids from 20170316 to 20170916...
    [51/164] Extracting pciids-20170916: ..... done
    [52/164] Upgrading openldap-client from 2.4.44 to 2.4.45...
    [52/164] Extracting openldap-client-2.4.45: .......... done
    [53/164] Reinstalling nettle-3.3...
    [53/164] Extracting nettle-3.3: .......... done
    [54/164] Reinstalling lzo2-2.10_1...
    [54/164] Extracting lzo2-2.10_1: .......... done
    [55/164] Upgrading libzmq4 from 4.1.5 to 4.2.2...
    [55/164] Extracting libzmq4-4.2.2: .......... done
    [56/164] Reinstalling libucl-0.8.0...
    [56/164] Extracting libucl-0.8.0: .......... done
    [57/164] Upgrading libedit from 3.1.20150325_2,1 to 3.1.20170329_2,1...
    [57/164] Extracting libedit-3.1.20170329_2,1: .......... done
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_history_end.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_history_init.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_tok_end.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_tok_init.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_tok_line.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_tok_reset.3.gz
    libedit-3.1.20150325_2,1: missing file /usr/local/man/man3/el_tok_str.3.gz
    [58/164] Reinstalling libdaemon-0.14_1...
    [58/164] Extracting libdaemon-0.14_1: .......... done
    [59/164] Reinstalling json-c-0.12.1...
    [59/164] Extracting json-c-0.12.1: .......... done
    [60/164] Reinstalling idnkit-1.0_6...
    [60/164] Extracting idnkit-1.0_6: .......... done
    [61/164] Reinstalling freetype2-2.8...
    [61/164] Extracting freetype2-2.8: .......... done
    ERROR: It was not possible to identify which pfSense kernel is installed
    ERROR: It was not possible to identify which pfSense kernel is installed
    ERROR: It was not possible to identify which pfSense kernel is installed
    ERROR: It was not possible to identify which pfSense kernel is installed
    
    


  • Hi

    Sorry for the delay, I'm fighting my SG-2220.  ;)

    I ran the upgrade from 2.3.4 to 2.4 from the GUI.

    Before anyone here wrote, I found a 2.3.4 file and mounted it. Now it's back.

    I'm sorry for not beeing able to answer questions about files and such, everything is erased now.

    New problem …. My backup conf's is not in sync with the SG-2220 now.
    It want to download packages,- but not before I've upgraded to 2.4 it says  :D

    WARNING: Current pkg repository has a new OS major version.
            pfSense should be upgraded before doing any other
            operation
    Failed

    Me and my SG is not BFF's right now  ;)

    Upgrading via USB, as Jim says ...

    What does it ask for here?:

    Mounting from ufs:/dev/ufs/FreeBSD_Install failed with error 19.

    Loader variables:
      vfs.root.mountfrom=ufs:/dev/ufs/FreeBSD_Install
      vfs.root.mountfrom.options=ro,noatime

    Manual root filesystem specification:
      <fstype>: <device>[options]
          Mount <device>using filesystem <fstype>and with the specified (optional) option list.

    eg. ufs:/dev/da0s1a
            zfs:tank
            cd9660:/dev/cd0 ro
              (which is equivalent to: mount -t cd9660 -o ro /dev/cd0 /)

    ?              List valid disk boot devices
      .              Yield 1 second (for background tasks)
      <empty line="">Abort manual input

    mountroot></empty></fstype></device></device></fstype>


  • LAYER 8 Moderator

    Yes, the problem with not able to install packages is biting me with an erroneous 2.3.x installation, too. Not being able to recover those is a real showstopper atm!



  • Yup, it's points to a direction of only running pfSense virtualized.
    Blows up … roll back ... no problems. Wait for bug fixes.
    If this was a customer 500 miles away, and I remote upgraded, I would be in trouble now.

    I just really fancy pfSense hardware, high quality.



  • Same issue here..  Ran the upgrade from the GUI on my SG-2220

    Trying to rebuild from the USB stick right now on site.

    Can someone tell me which image I should be using?


  • Galactic Empire

    Use the Netgate ADI labeled memstick.



  • @ivor:

    Use the Netgate ADI labeled memstick.

    Thank You!  found it and got it up.


  • LAYER 8 Netgate

    Take a backup of the config before you upgrade so you are not trying to restore a config from a LATER version on an older version. That is not and has never been supported.



  • Hi again

    After much fumbling, I'm back to 2.3.4

    Now I get this message in promt

    [2.3.4-RELEASE][root@pfSense-Konge.localdomain]/root: pfSense-upgrade -4
    Shared object "libssl.so.8" not found, required by "pkg"
    Shared object "libssl.so.8" not found, required by "pkg"
    ERROR: It was not possible to identify which pfSense kernel is installed

    Now, what's that all about?



  • It got my SG-2440 too.

    Did an usb install and everything is back up now.

    Don't forget to install the Netgate_Coreboot_Upgrade



  • Thanks oppland

    But part of the problem is, that in the package section I got this message:

    Unable to retrieve package information.

    It simply won't tell anything, search anything,- but is connected to the internet, it really want to test me :)



  • Reporting in…

    My standalone SG2440 upgrade failed, too. The GUI said upgrade failed and the box became unresponsive. After digging up a console cable and driver, I bounced it to see a bunch of PHP library errors. I was up and running in a little less than an hour, after burning a stick with the latest release.

    I've got a bunch of other boxen to upgrade. How do I tell what broke? I've got the uprade_log.txt, but nothing's obvious so far.


Log in to reply