Pacote não oficial Sarg para software pfsense®



  • Ressuscitei o sarg para o pfSense, está no repositório não oficial de pacotes

    Como eu atualizei a estrutura de arquivos recentemente,  baixa o arquivo de configuração do repositório novamente antes de instalar o pacote

    fetch -q -o /usr/local/etc/pkg/repos/Unofficial.conf https://raw.githubusercontent.com/marcelloc/Unofficial-pfSense-packages/master/Unofficial.conf
    




  • vai funcionar com e2guardian no pfsense 2.4.3 proxytransparente?



  • @dnascimento86:

    vai funcionar com e2guardian no pfsense 2.4.3 proxytransparente?

    Sim. Testei nele com log no formato squid.



  • Usava o sarg, depois passei pro squidanalyser e sinceramente, nem o acompanho mais, nem sei se ainda ta funcionando hahaha

    Lembro que o sarg era muito mais rápido, porém o squidanalyser mais "bonito" de visualizar e com mais informações

    Qual sua opinião marcelloc ?



  • @chipbr:

    Qual sua opinião marcelloc ?

    Como utilizo do e2guardian, sou 100% sarg  :)

    O squidanalyzer não consegue interpretar os logs do e2guardian, mesmo no formato squid. Por isso fui atrás de ressuscitar o sarg mesmo fazendo o pacote do squidanalyzer pro pfSense.

    E com umas firulas a mais, consigo deixar o sarg bem atrativo.  ;) 8)






  • Utilizo pfsense 2.4.3 e squid, ao visualizar o relatório aparece a mensagem: "Error: Could not find report index file.
    Check and save Sarg settings and try to force Sarg schedule.""
    Forcei o agendamento mas a mensagem continua. Pode me ajudar?



  • digita sarg na console/ssh para ver o que está acontecendo de errado.



  • SARG: Cannot set the locale LC_ALL to the environment variable



  • @wagolah , roda o comando que está agendado no cron, pra ver se retorna erro também.



  • @marcelloc Observei que nos últimos dias, o SARG não rodou.
    Tentei executar o comando manualmente, tive o seguinte retorno;

    code
    SARG: Cannot set the locale LC_ALL to the environment variable
    

    Pesquisei na internet e executei o comando LOCALE tive o seguinte retorno;

    code
    LANG=en_US.UTF-8
    LC_CTYPE="C"
    LC_COLLATE="C"
    LC_TIME="C"
    LC_NUMERIC="C"
    LC_MONETARY="C"
    LC_MESSAGES="C"
    LC_ALL=
    

    Tentei pelo export informar este campo, mas não foi possível.
    Não encontrei no PF pelo menos onde editar para concluir esta configuração.

    Aqui no fórum encontrei este procedimento
    https://forum.netgate.com/topic/80536/sarg-cannot-set-the-locale-lc_all-to-the-environment-variable

    Sigo-o ou sugere outra coisa?

    No aguardo.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy