SG-2440 Netgate boots to red status and no console access



  • Hey everyone,

    Been a crazy morning fighting with our Netgate SG-2440.

    We ran a firmware update, I believe we were at 2.3 install and were trying to go to 2.4 (sorry I can’t be more concrete on that).

    The device never rebooted (update ran remotely), was able to screen into the device the day before and had luckily exported a config file.

    The device will now power on to a red status light, after a while it will completely power down. I have tried to do a hard reset from the button on the back. No activity after holding the reset button (10 seconds - 2 minutes held).

    When we try to screen into the device via the console cable, it will bring up a blank terminal window with a cursor. CTRL+C, Enter, Space… etc will not bring anything up.

    Thankfully we have a newer Netgate which was in a lab scenario which I was able to pull, load the config and get back into production.

    Trying to figure out what next steps I have with the SG-2440. Any advice on how I can flash the firmware and start again?

    Definitely not under any support contract with this device, can reach out to Netgate next if necessary, but thought I’d check the community first.

    Thanks



  • I had a similar problem with my ?SG-4860. I don’t know why, but even though I couldn’t access the console, I could reinstall from a USB thumb drive. Here’s the SG-2440’s version of the process I used:

    https://www.netgate.com/docs/pfsense/solutions/sg-2440/reinstall-pfsense.html

    Hopefully, that’ll help.



  • I think that if the status/sata lights never go green the unit is bricked. Had the BIOS been updated for the Atom bug? Warranty was extended for the Atom issue, so you might want to contact support.
    beremonavabi- that process requires you to have console access. How did you re-install without the console?



  • @dotdash Oops. You’re right. My status light was green, not red. So, I agree that the OP should contact support. As to how I was able to update without console access, I couldn’t access the console if the unit tried booting with its own installed image. But, if I put the USB thumb drive in with the new software, it would boot from that and I then had access to the console.


  • Galactic Empire Netgate Administrator

    @robalees Please contact our support and they will be able to help. Submit a ticket at the following portal:

    https://go.netgate.com/support/login



  • I have reached out to support, thanks for the advice everyone.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy