Cannot get 10Gbase-T on LAN (only 1000baseT)



  • Dear PFSense community,

    I've installed an intel x540-t2 in my pfsense Box for the LAN but it's only detecting as 1000baseT. I've been stumped on this for a while.

    If anyone out there has experience with this and can throw me some help, I would really appreciate it.

    Good day!



  • What's on the other end of the cable? 10G has to be supported on both ends.


  • Netgate Administrator

    Assuming the other end is 10G capable perhaps it's fixed to 1G?

    If it isn't have you tried setting a fixed 10G link speed in pfSense?

    Steve



  • @jknott Hi JKnott, the Intel NIC is dual port. So, so one port is connected to a 10 gigabit pro safe switch and second port on the nic is connected to my 1 gigabit shaw modem. Could that be why? Is pfsense normally supposed to detect 10g automatically?



  • @stephenw10 Hi stephenw10, the Intel NIC is dual port. So, so one port is connected to a 10 gigabit pro safe switch and second port on the nic is connected to my 1 gigabit shaw modem. I think I have tried forcing 10 gigabit on the LAN interface and it didn't work. I'll try it again right now though to double check



  • @techgeek055 odd, when i click apply I get:
    PPP Password and confirmed password must match!
    PTPP Password and confirmed password must match!

    Never got that before :D


  • Netgate Administrator

    Sounds like your browser might be filling in some form field when you try to edit the interface. Or maybe you have a left over setting somewhere.

    I would expect that NIC to auto-negotiate 1G/10G but I have seen some Intel cards that did not and would only establish a link when hard set.

    Steve



  • @techgeek055 Actually Pfsense, the App, doesn't preocuppy itself with NIC speeds, other than ask the OS what is and display it to you. This maybe a case of living on the bleeding edge, may need a proper NIC driver for FreeBSD.



  • @stephenw10 You were right about the browser trying to fill in a password causing the two errors :D

    I am going to try moving the WAN connected to the 1gigabit shaw modem off of the 10 gigabit intel nic and onto it's own NIC and see if that makes any difference!



  • looks like leaving just the 10g connection for lan on the intel nic didn't get pfsense to detect 10g conneciton. (and removing the 1Gb connection from the intel nic)

    It let's me pick 10Gbase-T on the interface settings but when I look at the main page that monitors the interfaces, the LAN still says: 1000baseT <full-duplex,rxpause,txpause>

    On my WAN interface settings there is no 10Gbase-T option, only 1000Base-T. So it appears that the drop down at least detects 10Gbase-T and allows you to select it as an option but it appears to do nothing and the monitor still says 1000base-T.

    :(



  • @sammywoo It lets me pick 10Gbase-T on the LAN interface settings but when I look at the main page that monitors the interfaces, the LAN still says: 1000baseT <full-duplex,rxpause,txpause>.

    If I try to pick 10Gbase-T on my WAN connection which is using a 1000base-T nic, the option of 10Gbase-T is not there. So at least in the interface settings, it seems to detect the 10Gbase-T and you can pick it. But monitor still says my LAN is on 1000base-T :(

    Do you think it's the driver still? If so, is the process easy? do you have a resource for instructions?


  • Netgate Administrator

    If you set it to 10G and it make no difference I'd say that setting hasn't applied. Reboot to be sure.

    If the other end is set to 1G for some reason then setting it to 10G fixed should cause the link to fail.

    It could be a cable that can't support 10G perhaps?

    Steve