Upgrade from 2.3.5 to 2.4.3 now shows version error.