2.4.3P1 from 2.4.3



  • I am not able to upgrade to 2.4.3P1 from 2.4.3.
    I tried with GUI but it’s displaying version 2.4.4 as a latest.
    Please suggest how to upgrade to 2.4.3_p1?


  • Rebel Alliance Developer Netgate

    When you view updates, make sure it is set to see the Stable updates, not development snapshots. Use the drop-down on the update check page or the update settings tab.



  • Thanks jimp for replying.
    it is set to stable release
    0_1528720926570_Capture.PNG

    But as you can see it’s showing 2.4.3 as up to date but i need 2.4.3_P1.



  • Go to the update settings tab and flip the branch once to something else, save, and then flip it back to Latest stable version and save again.



  • Tried but getting the status as up to date.



  • This is what it should show as of today :
    0_1528781028423_3b0bb03a-2800-44c6-bba2-0ca027ba731e-image.png

    It seems your pfSense has no way to get out and locate the latest version.
    I suggest you try the console update option (see look for the many forum messages about this issue).



  • pfsense is able to connect with net because when i flip the branch then i am getting the option to upgrade it to 2.4.4
    0_1528801903543_Capture1.PNG

    how did you install p1 over 2.4.3, Using UI only or console?
    and is thre any iso available which have 2.4.3_1in it?



  • Go to the console (or connect with SSH), select option 8 (shell) and run:

    pkg-static install -f pkg
    pkg-static update -f
    pfSense-upgrade
    


  • @kpa getting below error:

    [2.4.3-RELEASE][admin@pfSense.localdomain]/root: pkg-static install -f pkg
    Updating pfSense-core repository catalogue…
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg-static: https://beta.pfsense.org/pfSense_v2_4_3_amd64-core/meta.txz: Not Found
    repository pfSense-core has no meta file, using default settings
    pkg-static: https://beta.pfsense.org/pfSense_v2_4_3_amd64-core/packagesite.txz: Not Found
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue…
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg-static: https://beta.pfsense.org/pfSense_v2_4_3_amd64-pfSense_v2_4_3/meta.txz: Not Found
    repository pfSense has no meta file, using default settings
    pkg-static: https://beta.pfsense.org/pfSense_v2_4_3_amd64-pfSense_v2_4_3/packagesite.txz: Not Found
    Unable to update repository pfSense
    Error updating repositories!

    I have tried a lot to upgrade it but no success .



  • @kpa said in 2.4.3P1 from 2.4.3:

    pkg-static install -f pkg

    When I ran this command, after a minute or so :

    [2.4.3-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: pkg-static install -f pkg
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be DOWNGRADED:
            pkg: 1.10.5 -> 1.10.3_1 [pfSense]
    
    Number of packages to be downgraded: 1
    
    Proceed with this action? [y/N]: N
    

    Well, I’m running 2.4.3_1 and it asked me to downgrade the pkg package.
    Didn’t accept that … but no ‘file not found error’ errors.

    See the forum for

    access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed
    

    messages.

    Also :

    [2.4.3-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: ls -al /var/db/pkg/
    total 50628
    drwxr-xr-x   2 root  wheel       512 Jun 13 06:58 .
    drwxr-xr-x  19 root  wheel      1536 Jun 13 07:06 ..
    -rw-r--r--   1 root  wheel       246 May 17  2016 FreeBSD.meta
    -rw-r--r--   1 root  wheel   4734976 Jun 13 06:58 local.sqlite
    -rw-r--r--   1 root  wheel       246 May 10 22:14 pfSense-core.meta
    -rw-r--r--   1 root  wheel       246 Jun 12 11:18 pfSense.meta
    -rw-r--r--   1 root  wheel  45684736 May 17  2016 repo-FreeBSD.sqlite
    -rw-r--r--   1 root  wheel    212992 May 10 22:14 repo-pfSense-core.sqlite
    -rw-r--r--   1 root  wheel   1024000 Jun 12 11:18 repo-pfSense.sqlite
    

    Btw : Do not upgrade to beta version except if you want to live on the bleeding edge of developmental. And that case, and any case : export settings, re install with a fresh current, re import settings. Done. (takes 5 minutes ?).
    Do the upgrade test again using the console.
    It didn’t work : so your settings are to blame - but also check hardware (files on disk etc).
    It did work : no worries, no one will never know what happened, but you’ll be fine.



  • @Gertjan, on my system that is 2.4.3-p1 the newest version of pkg is:

    pkg-1.10.3_1
    Name           : pkg
    Version        : 1.10.3_1
    

    You must have mixed repositories at some point if you have 1.10.5.



  • @kpa said in 2.4.3P1 from 2.4.3:

    You must have mixed repositories at some point if you have 1.10.5.

    Well, yes, I’m selecting very often the ‘dev’ version like this :

    0_1528871712393_414d2f41-fbd7-493c-9d0b-599c9160a3ab-image.png
    to see what happens, making screenshot (like just now).
    But I never ever actually ungraded - or partially upgrade if that is possible - to the dev “2.4.4.a.2018abcd.xxxxx” version.

    Maybe comparing the command lines command, that I actually ran, produced this upgrade.
    So I’m having my very special pfSense version “2.4.3-RELEASE-p1a☺

    Also : it takes more then 2 minutes before the wheel stops turning and a result (see image) shows, this was faster in the past.



  • @gertjan Tried with new installation but again getting the same error.
    In setting i have added the proxy only

    0_1528964602568_Capture2.PNG

    any other suggestion you can give?



  • Proxy ? Now where did that came from ?
    The suggestion is easy : remove the proxy and related settings, and I guess you will be fine.



  • @gertjan that’s how it’s connected to internet , i have checked proxy logs it seems fine.



  • A proxy behind a firewall, ok. That has been done all the time.

    I was just asking myself : what of de package business of pfSense doesn’t know sh*t about proxies in front of pfSense ?

    I know that no proxy in front of pfSense works very well - because that’s what I’ve been doing for the last decade or so.

    So, I suggest you remove the proxy for a small moment, just to check what happens then.



  • Whatever the proxy is for or is doing is probably messing up DNS resolution for your pfSense. The package management system needs a completely clean DNS resolution to operate properly, namely there can not be any filtering or tampering with SRV records, the pkg package manager uses those all the time for finding suitable mirrors for the packages.

    Either that or the proxy is doing something to the http(s) downloads of the package catalogs to mess up the update system.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy