PLEASE HELP !!! updating my Netgate SG-4860 from 2.3.4-RELEASE-p1 to latest, and now it is STUCK.



  • Hello,

    I bought my appliance about 6 months ago.
    Tried updating to latest release.
    It gave an error, and now it is stuck.
    I've tried everything I could find on the Forums, but nothing seems to work.
    I have Web and SSH access to it. I don't have console access as it is sitting remotely.
    Please help me fix this issue.



  • Oh PS: this is the message:

    ERROR: It was not possible to identify which pfSense kernel is installed



  • Is there a support number to call? I am still within a year. Don't seem to get anyone from Netgate responding here on the Forum???


  • LAYER 8 Global Moderator

    2.3.4-RELEASE-p1 is the latest.. Where you trying to update it to some development snapshot?

    Do you have a support contract?
    https://www.netgate.com/support/contact-support.html

    edit: Oh I misread that as 2.4.3p1... So were you trying to update to 2.3.5 or to 2.4? How do you have a sg4860 that is only 6 months old on such an old version? 2.3.4p1 released on july 20 2017.. Are you saying that your box you just got 6 months ago was on 2.3.4? I have had mine about 6 months as well - and I don't recall to be honest what version it was on, because first thing i did before putting it into production was make sure it was current.. But pretty sure it was on the 2.4 branch when I got it.

    What I would suggest is install clean and restore you config from your backup.



  • Hi and thank you for your response.
    I never upgraded this box as it has been working just fine. We got it in October last year and then plugged it in finally on Jan and I think did one upgrade.

    Recently, I hit the “update” on dashboard and then hell broke loose. I think it tried to update it to the latest stable release. I wanted the update so I can download new packages.

    Now I cannot make any updates or packages.

    The box is remote with Static IP so whatever I have to do is remote, web or SSH. I cannot do it from console so fresh install isn’t going to work.

    What are my options.


  • LAYER 8 Global Moderator

    Take a look here
    https://redmine.pfsense.org/issues/5493

    Disabling ramdisk followed by a reboot makes upgrades available again.

    Prob read through the linked fourm thread as well
    https://forum.netgate.com/topic/91937/failed-upgrade-console-and-gui



  • I tried that earlier, but let me try again.
    RAM disk has always been off for me.

    But let me give it another go, and I’ll report back.


  • Galactic Empire

    @suebee Please contact our support. Simply submit a ticket at the following link and they will be able to assist https://go.netgate.com/support/login



  • Ok, I tried the Ram Disk route. Turned it on, set it to 256, rebooted.
    Turned it back off, rebooted.

    Still there is nothing under the update tab.

    So now i've raised a ticket.


Log in to reply