dns resolver not working for dhcp clients

  • Re: [SOLVED] DNS resolver- PFSENSE unable to resolve dns's

    after combing through tons of topics and articles, this seemed to be the closest to my problem.
    What i have is a 2.4.3-RELEASE-p1 (amd64)
    my issue is with dns resolving.
    What I ultimately want to accomplish is to block ads and in order to do that, i would need pfsense to handle dns queries for all my clients within the network.
    I have a simple setup.
    internet ---- cable modem ---- pfsense ---- lan
    at the moment i can resolve hostnames within pfsense. I ran the dns lookup tool.
    all clients can pick up ip. dhcp works.
    i can also see the gateway and dns is pointed to my pfsense ip address for all my clients within the network.
    dns resolver enabled
    listen port 53
    network/outgoing network interfaces all
    system domain local type zone transparent
    DNSSEC Enabled =Checked (i also disabled it to see if it had an impact)
    DNS Query Forwarding =Unchecked
    DHCP Registration =Checked
    Static DHCP= Checked

    under dhcp services
    dhcp server lan interface =checked
    the rest is blank and default including dns server (by default it should pick up the ip address of pfsense)

    i installed 3 different boxes with a fresh pfsense each time and never got dns to work. i always had to put an external dns server.
    How do i get pfsense to resolve names and hopefully block ads for my dhcp clients?
    any type of help or direction is highly appreciated.
    thanks in advance...

  • in addition to my explanation.
    I have another box which i have installed recently which is 2.3.4 release p1 (i386). New version not supported apparently.
    exact same configuration as the previous box. I compared it each section one by one.
    on (i386) dns is working for both pfsense and for the dhcp clients. Just the way it is supposed to.
    The only difference i can think of is the version and also a package i had installed earlier (ntop) was not functioning on (amd64) so i removed the package. I assume that may have messed it up. Instead of a clean install, I am wondering if there is a shortcut fix to this problem.
    thanks again.

  • ok. Here is the update.
    I have a fresh install of 2.4.3 release p1 amd64
    i used the wizard on setup and at the moment;
    Clients picking up ip via dhcp are able to go online and use pfsense as dns server.
    However, when i created a vlan on the same interface, clients on vlan are picking up ip on designated vlan but cannot resolve. So i am back to where i started on vlan portion of the network. I can not get it to resolve using pfsense.
    What am i doing wrong?
    i see that my posts had some views but I had no response from anybody.
    any type of help would be appreciated.
    drop a line, say hi....

  • nevermind.
    fixed it.

  • @madfrog80 said in dns resolver not working for dhcp clients:

    fixed it.

    Please, how?? I have the same issue. DNS does not work for DHCP-clients.

  • I am sorry, i do not have a quick fix solution for you. I had to backup the configuration and reset everything. You will have the option to reset if your pfsense box is hooked up to a monitor.
    What I can tell you is, my previous settings were not different than the settings after reset. So may be on my first install, I may have screwed up during ip assignment...(I still don't think so)
    Anyhow, I know it is not much but this is how I resolved the issue for me.
    I hope it helps.

  • @biggestnoob i for got to tag you on the previous post. :)☺

  • Thank you for answering. Does not make sense, not in my configuration either. But I guess I have to give it a try...

Log in to reply