pfSense cannot get WAN IP address



  • First I've ready many posts about this same issue, but have not found a resolution.

    Last night about 2:30AM my router lost connection to the internet. My investigation shows that the pfSense router will not get an IP address from Comcast DHCP.

    I can connect a laptop to the modem, that is running in bridge mode, and get an IP address.

    I am running version 2.3.5 of pfSense.

    What I see on the status dashboard for my WAN interface is a green up arrow and n/a or sometimes 0.0.0.0. If I SSH into the router the initial status page shows blank for WAN, although once I saw it with a valid IP very briefly.

    In the logs I see an entry like this:

    /rc.Linkup: The command '/sbin/route change - inet default '24.16.40.1'' returned exit code 1, the output was 'route: writing to routing socket: no such process route: writing to routing socket: Network is unreachable change net default: gateway 24.16.40.1 fib 0: Network is unreachable'

    Before this happened my IP address was 24.16.42.2

    I'm at a loss for how to resolve this so any help would be awesome.


  • Netgate

    I would:

    1. Disconnect the pfSense WAN from the modem
    2. Power cycle the modem
    3. Let it sync back up
    4. Reconnect to the WAN port.


  • Thanks. I've done that many times, but no joy.


  • Netgate

    This post is deleted!


  • DHCP from Comcast


  • Netgate

    @weswitt What is the WAN provisioning? DHCP? Static? PPPoE?

    Ah I see DHCP. What is in the DHCP logs?



  • I was able to get things working again by reinstalling pfSense 2.4.3. Sad that I had to nuke my router to get it working again


  • Netgate

    Doubtful that was actually necessary. But if that's what you have done, that's where you are now.