Can't reach internal web server



  • Hi everybody,

    I'm a real beginner using pfsense, and any help is much appreciated. In my home network, i have a web-server, which runs a small website. believe i have successfully created a NAT rule to forward any traffic asking on port 80 to my web-server. Unfortunately i can't reach it.

    Can you guys check what i did wrong? I added some info of my rules.

    Firewall:
    NAT rule that forwards ports 80 to the local hosted web server.
    If: WAN, Proto, TCP, Src. addr: *, Src. ports: *, Dest. addr: WAN address, Dest. ports: Web Ports, NAT IP: Web Server, NAT Ports: Web Ports

    Firewall rule that passes ports 80 to the local hosted web server.
    Proto, IPv4 TCP, Source: *, Port: *, Destination: Web Server, Port: Web Ports, Gateway: *, Queue: none

    WAN type : Dynamic IP Address
    DynDNS : no-ip

    when i try to access my web server using xxxx.ddns.net , i will be redirect to pfsense web gui login instead going to my web server.



  • Just taking a guess
    I believe there is the anti lock out rule for port 80 that might be causing request to go to login screen...
    Is the web server on your home network and servers to the public as well? or is it remote?
    How do you have your network set up? Never ran anything like this in the past to be honest but sounds as something I may be able to assist on pinpointing the issue.



  • @crisdavid

    1.) yes, i have anti lock out rule (port 80) on LAN interface
    2.) the web server is on my home network.
    3.) I have a simple home setup, where pfsense is my gateway. I can reach my web server from local network but when i try to access it using ddns address that i create, it will not reach the web server

    0_1534141554203_88.jpg

    System - Firewall / NAT:
    Network Address Translation
    NAT Reflection mode for port forwards: Enable (Pure NAT)
    Reflection Timeout: (not specified)
    Enable NAT Reflection for 1:1 NAT: Disabled (box NOT checked)
    Enable automatic outbound NAT for Reflection: Enabled (box checked)
    TFTP Proxy: (not specified)

    other info :

    if i use this rule, nothing happen when i try to access xxxx.ddns.net either from lokal or extrenal network

    Firewall:
    NAT rule that forwards ports 80 to the local hosted web server.
    If: WAN, Proto, TCP, Src. addr: *, Src. ports: *, Dest. addr: WAN address, Dest. ports: Web Ports, NAT IP: Web Server, NAT Ports: Web Ports

    but if i change th dest add,, i can access my web server from local network but when i try to access it from outside, it will redirect me to pfsense web gui

    Firewall:
    NAT rule that forwards ports 80 to the local hosted web server.
    If: WAN, Proto, TCP, Src. addr: *, Src. ports: *, Dest. addr:xxxx.ddns.net, Dest. ports: Web Ports, NAT IP: Web Server, NAT Ports: Web Ports

    btw, sorry for my broken english..



  • You have to set the webconfigurator to listen to other ports than you've forwarded to internal web servers.
    Go to System > Advanced > Admin Access

    Set a TCP port other than 80 or 443 and also check "Disable webConfigurator redirect rule".


  • Netgate

    Probably testing from the inside using NAT reflection and hitting the redirect rule. Do all of that ^.



  • @viragomann i already set the webconfigurator to listen to other ports but i still cannot access from outside



  • @derelict how do i do that?

    this is my NAT config right now :

    System - Firewall / NAT:
    Network Address Translation
    NAT Reflection mode for port forwards: Enable (Pure NAT)
    Reflection Timeout: (not specified)
    Enable NAT Reflection for 1:1 NAT: Disabled (box NOT checked)
    Enable automatic outbound NAT for Reflection: Enabled (box checked)
    TFTP Proxy: (not specified)


  • Netgate



  • @derelict 0_1534213714507_port forward.jpg

    WAN type : Dynamic IP Address



  • when im using local network, everything fine. i can access all my server.. but when i try to access from outside.. i got nothing. Then if i try to replace dest. address to xxxx.ddns.net , i will redirect to pfsense web gui instead..



  • @fendy : I remember that GUI style vaguely. .... you do upgrade your pfSense ones in a while, right ?
    (If not, we have to deal with all the errors and bugs from all these old versions, and help becomes pretty impossible)



  • @gertjan i'm still using the old ver. 2.1-RELEASE



  • @fendy said in Can't reach internal web server:

    I'm a real beginner using pfsense, and any help is much appreciated.

    Let me give you a big advise : ditch 2.1 right away.
    Use a current version. Live will be easier.

    When you start using a PC today, will you be looking for Windows 95 also ? ;)


  • Netgate

    Upgrade then come back.



  • Consider doing a new install ;)
    This way you know what its is to install something different as "install windows from CD".
    The next time you need to re install pfSense for any reason, you'll be in a hurry (because your network is down at that moment) and you know what to do.

    Btw : just for the record : why did you install 2.1 ? Where did it came from ? Didn't you find https://www.pfsense.org/download/ ?


  • Rebel Alliance Global Moderator

    Also where did you come up with this 200.10.1 ?? That is not rfc1918 space.. Its owned by

    inetnum: 200.10.0/22
    owner: Administradora BANCHILE de Fondos Mutuos
    Country: CL

    You do not just pull space out of thin air and try and use it, even if behind a nat.

    Your HOME Network should be using rfc1918 space..


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy