Upgrade 2.3.5 to 2.4.3



  • Hi,

    i want to upgrade my pfSense from 2.3.5 to 2.4.3, the following is what Shows on Dashboard.
    0_1536658728588_Dashboard.JPG

    the processor is 64 bit. now the Problem is i can't find 2.3.4 update in WebGUI and console.
    in console i tried these commands:
    pfSense-upgrade -d
    pkg-static install -f
    and it says all the time:
    "pfSense repository is up to date.
    All repositories are up to date."

    is there a way to upgrade my pfsense to 2.4.3 without fully reinstall.
    thanks.



  • Just set the right Branch:

    0_1536673939393_299f35df-bbfd-4c3f-aec7-8e5ccfe9875e-image.png



  • @bismarck thanks for reply
    thats my Problem because it Shows only 2.3.x, there is no Version 2.4.x.
    thats why i tried from console but same result.0_1536674941936_Bild1.png



  • Oh wait you have 32 bit pfSense, AFAIK 2.4 is 64 bit only.


  • Netgate Administrator

    Yes you are running 32bit but on a 64bit capable system. You cannot upgrade between them.
    Re-install to 2.4.3p1 directly and restore your config.

    Steve



  • @stephenw10
    thanks for the reply. Actually that's what i guessed also. but i have Problem axactly at this Point i mean fully reinstall.
    we use pfsense on an external Hardware. i know the new Version of pfsense can easily be installed on for example a Laptop through usb or live CD. but how can i install it on external Hardware. the previous Version is installed by another Person which is not accessable anymore. can somebody give me some hints how can i do it.
    currently pfsense has been saved in a SD_Card and boot and run from there. i tried to save new Version of pfsense in sd_card, but at boot time i receive the following error:

    Default: 0:ad(0,a)/boot
    boot:

    any tips can be helpful. thanks.



  • @alivdel said in Upgrade 2.3.5 to 2.4.3:

    the previous Version is installed by another Person which is not accessable anymore.

    The person or the device ?

    To re install you need the device to get to you, or you need to go to the device.
    Remote installing IS possible, but all kind of conditions need to be met, like having a KVM or comparable access, there should be no hardware issues, etc.
    Installing will take you 10 minutes or so.

    It's like adding that turbo engin in your car : you have to bring it to the garage - can't do it without leaving the highway.



  • @Gertjan
    sorry maybe i wasn't really clear, i meant the Person is not here anymore, i have the device but i don't know what should i do to install a complete new Version of pfsense on it.
    as i said i saved new Version on sd_card and after power on the device i get the error on booting time.



  • @alivdel

    Assuming the sdcard is you installation target device, you need to copy the installation image to a usb stick first, boot from the stick and install it on the sdcard and afterwards recover your config.xml backup.



  • Ah, ok.

    Then it all boils down to what you did when you "saved to". Just copying ? That's a no-go.
    The manual shows how to build a boot USB key with pfSense.
    I guess it's also possible with a SD card.


  • Netgate Administrator

    Yes, you're not running Nano which might have been the case with 2.3.X on an SD card.

    So you need to install to the SD card exactly as though it was HD.

    What hardware is this exactly? Is SD card your only option there?

    There are some caveats to running full install from SD. You should remove the swap slice during the install and then move /var and /tmp to RAM drives from System > Advanced once booted.

    Steve



  • @stephenw10
    hi,
    thanks for reply, i was busy last days with another Thema.
    i tried to install new Image from usb on SD_Card.
    now i can boot Sd_Card without Problem in Computer, but when i put the Sd_Card in my Hardware, it can be booted but with the following error:

    0_1537435353410_Unbenannt6.JPG

    it dose not Show the pfsense menu and i have no Access on Web_GUI as well.
    booting from Computer Shows the menu.
    can you please tell me what is wrong?
    thanks.


  • Netgate Administrator

    Did you do the install on a different device?

    What image did you use to install from exactly?

    Those errors could be because /var is set to RAM but has not been created for some reason.

    More info needed!

    Steve



  • Look to me that "syslogd" has difficulties writing to /var/.... (like /var/log/routing.log: Operation not supported by device).

    Son ..... RAM is not writable : ditch the device right away
    Or read this again :
    @stephenw10 said in Upgrade 2.3.5 to 2.4.3:

    You should remove the swap slice during the install and then move /var and /tmp to RAM drives from System > Advanced once booted

    edit : @stephenw10 replied faster ;)



  • @stephenw10
    i install it in my compter with an application "Qemu Manager" on Sd_Card.
    the Image i used is : pfSense-CE-2.4.3-RELEASE-amd64
    i forgot to remove swap slice and now installing again to see if with removing swap slice it works or not.
    i created only one Partition : da0s1a : free_BSD-ufs


  • Netgate Administrator

    Ok it looks like you're accessing the device using a serial connection (putty on com1) but that image will give you a VGA console by default.
    If you can boot it on something else so to System > Advanced > Admin Access and make sure the serial console is at least enabled. You might need to set it as the primary console but that might cause problems on whatever you're booting on.

    Steve



  • @stephenw10
    thanks a lot, i boot it from another Computer with 2 Network_card, had Access to web_GUI. and changed what you said: - System > Advanced >Serial console enabled,
    - System > Advanced >Miscellaneous: moved /var and /tmp to RAM
    and now it works in my Hardware as well.


Log in to reply