Unable to resolve certain sites DNS Resolver



  • Has anyone seen this issue? I set 5 machines on my LAN for DHCP static registration. I did that to allow those IP's to route around the VPN. This was working fine for months, no issues All of a sudden, some sites were not able to resolve any longer, The site would just timeout. I deleted the DHCP registrations, deleted the ARP cache and restarted the DHCP service. Each device picked up a new IP but is still unable to resolve certain sites, request just times out. On my DMZ using the DNS Resolver, all sites resolve just fine.

    I have no idea what to try next Any suggestions. This has me stumped.I stopped pfblocker and Sqiud.

    My setup:

    pfsense 2.3.4_1
    pfblocker
    Sqiud
    Squidgard
    ntop

    Thanks

    RandY



  • @bigraz1968 said in Unable to resolve certain sites DNS Resolver:

    some sites were not able to resolve any longer

    This somewhat confirms that your LAN is working fine.
    It confirms that your machines have an local IP, a gateway, and a DNS.
    So no need to look at DHCP server settings.
    You could even ask to your machines if everything is ok. Like releasing the IP info, renew and check.

    What happens if you enter console mode, option 8 and test DNS from there ?
    Like

    dig facebook.com
    

    or, if you want to see everything :

    dig facebook.com +trace
    

    (can also be done from GUI I think)

    This :
    @bigraz1968 said in Unable to resolve certain sites DNS Resolver:

    On my DMZ using the DNS Resolver, all sites resolve just fine.

    is important info.
    Compare firewall rules on both interfaces, LAN and DMZ.
    Do you filter any DNS traffic on LAN ? (show us your rules for LAN and DMZ please).

    Of course, if your

    @bigraz1968 said in Unable to resolve certain sites DNS Resolver:

    some sites

    became "pfblocker-listed" then everything is quiet normal : pfSense does what you are asking for ;)



  • Gertjan Thanks for you response.

    The other machines on the LAN work fine. The issue only occurs on the machines that were assigned a DHCP reservation. My machines in the DMZ resolve the same sites just fine. Other machines on the LAN resolve just fine. Only machines in that were assigned a static reservation has the issue.

    I don't filter DNS. I do route all my traffic thru a VPN.

    Randy



  • @bigraz1968 said in Unable to resolve certain sites DNS Resolver:

    The other machines on the LAN work fine

    Compare IP config on working and not working machines and you'll find the answer.



  • I did all that. All of the clients on the LAN are getting their IP configuration from the same DHCP server.

    Thanks

    Randy



  • IP ok, but DNS ? Gateway ?



  • I checked and all the same.


  • Rebel Alliance Global Moderator

    So your saying something resolve for this client and other things do not - or dns is not not working at all?

    What error do you get when you do a dig or nslookup?



  • It seems like the firewall is holding some stale information somewhere and rebooting isn't fixing the issue.



  • Hi John

    The two clients are my TV's have the issue My Netflix smart app. doesn't work I get the message 'Unable to connect' I use the builtin browser to load Netflix and Netflix still doesn't load. Other sites will load. Sharp TV support worked on the issue and finally said the problem is my router.

    I hookup my Chromebook and Netflix.com doesn't load. It just says 'Waiting on cache' an then it stops loading

    I hookup another laptop and that laptop loads Netflix without issue.

    The common denominator is machines that had a static DHCP reservation don't work, but machines not assigned statically have no issues


  • Rebel Alliance Global Moderator

    doesn't answer the question.. What happens when you query - and does it happen for all things or just some sites?

    Lets see an example dig or nslookup query (dig is BETTER) from client that works, and from client that doesn't work.

    edit: Well what are you doing different in your static reservation? You know you can point to different dns.. Or you could have different rules, etc.

    Simple solution would be to sniff on pfsense to see exactly what the client is trying to do, etc. Netflix apps can be hard coded to try and query say google dns.



  • DNS is working. Just a couple frequent sites I use will not resolve. I picked Netflix because in my house it is used frequently. I can do a working client but unable to perform dig on a broken client. I am at work.



  • Nslookup query from working machine

    C:\Users\rdevone-desktop>nslookup netflix.com
    Server: pfSense.localdomain
    Address: 192.168.1.1

    Non-authoritative answer:
    Name: netflix.com
    Address: 45.76.252.24


  • Rebel Alliance Global Moderator

    ok well that is a cached response from 192.168.1.1 (assume pfsense IP since it resolve to pfsense.localdomain)... so lets see something broken when you get home..

    I take it you did not mess with the the unbound views and acls..



  • I take it you did not mess with the the unbound views and acls.. No I don't know what that is. I haven't made any changes at all.

    You always have been so helpful. I really appreciate your help. My family is going to kill me if I don't get this fixed soon.

    Thanks

    Randy



  • Johnpoz;

    I did a dig on one of the clients that is having a issue and the dig command completes successfully as it did on a client that has no issue.

    Thanks

    Randy



  • Johnpoz;

    I made a mistake. I did the dig with the wrong DNS server. I switched the DNS to my resolver and I get 'connection timed out, no servers can be reached'.

    Thanks

    Randy


  • Rebel Alliance Global Moderator

    so you can not get any sort of answer from pfsense? From this client? Or you saying that certain looks fail?



  • Correct. for Netflix.com Most sites do resolve. If I switch to a client in my DMZ. Netflix resolves successfully. DMZ uses the resolver as well.


  • Rebel Alliance Global Moderator

    Here is the thing the resolve doesn't care what network your on local - if you can talk to it, then it the same no matter what local network your on.. UNLESS you have messed with the acls or created views.

    What are your firewall rules on this interface?



  • @johnpoz said in Unable to resolve certain sites DNS Resolver:

    What are your firewall rules on this interface?

    +1 (again).



  • 0_1537268329063_babfa03d-7fe9-43dc-8836-56ed0d152705-image.png



  • Ok,
    The questions :
    Who is / what interface is 192.168.1.1 ?
    192.168.1.50 ?

    What are you hiding here :
    0_1537274165818_7a4b01cc-3675-40fa-b781-8a6ba6246343-image.png

    What are you doing here :
    0_1537274343106_47eb0137-01ab-4b4c-91a3-ad760fa7aee0-image.png

    The image is not complete.

    What happens if you put on position 2 a "Pass all rule" like this :
    0_1537274267478_9cd907fe-8c05-4892-8f42-76fdfe096db5-image.png


  • Rebel Alliance Global Moderator

    Rule are evaluated top down, first rule to trigger wins no other rules are evaluated.. Shoving stuff out your wan dhcp could cause you problems.

    Do you have any rules on floating?

    So your doing dns redirection? Also curious what this 192.168.1.50 if its on your lan 192.168.1/24? Then that rule would NEVER come into play since devices don't talk to their gateway to talk to device on their own network. So not sure what this is expected to do.

    Lets see your full rule set both on this interface and your floating and any redirections (port forwards your attempting) Also anything using explicit proxy would not do dns itself - it asks the proxy to do do the dns for it.. When it sends the proxy the FQDN it wants to get too.

    These rules not making much sense to be honest.



  • Gertjan;
    192.168.1.50 is my AD server. That rule isn't needed anymore and can be removed. 192.168.1.1 is my firewall. I haven't tried this: What happens if you put on position 2 a "Pass all rule" like this : but I will try when I get home

    Johnpoz;

    I route out of my Wan_DHCP because some of my services can't work through the VPN. I'm not doing any DNS Redirection, not on purpose

    0_1537276807676_37d61168-96ee-4976-9000-2feda28890ae-image.png

    0_1537276945805_db644f56-1c7a-4509-b765-abe06040f6fb-image.png



  • My rules can be cleaned up but this has been working for a long time before this resolution issue started happening.



  • Also : de activate pfBlocker (thus cleaning your Floating rules) for the time being.

    This rule :
    0_1537274267478_9cd907fe-8c05-4892-8f42-76fdfe096db5-image.png

    on interface LAN - on position 2 - and test.
    Then 3, and test.
    etc.
    When things (DNS) start to not-work anymore, you have found your offending rule.


  • Rebel Alliance Global Moderator

    I understand letting stuff out your wan vs vpn - but that is NOT how you should do it.. You prevent any intervlan traffic with such a rule..

    Move the anyrule to the top.. Does that make your problem go away... Looking at such a mess makes my brian hurt! ;)

    What are you expecting to happen with the multicast rule? And what the F is wan service ports? And your blocking from talking to pretty much the whole planet there with your pfblocker rules? Good luck resolving when the authoritative name server you need to ask is blocked, etc..

    What is the IP of the clients that are having problems? And are they in this TV alias? What is in that TV alias?



  • I will do as you both suggested when I get home this evening. Most of the rules you see is based on the configuration AirVPN suggested. I'm not an expert with any of this, nor do I claim to be. I try to do my best and learn along the way.

    I removed all of the alias. That rule is now stale.

    All of this as flawed as it may be, was working and I haven't made any changes.

    Thanks or your help