Newly bought SG-1000 on 2.3 with no additional packages fails to upgrade.