Auto configuration backup shows no backups



  • On one of my two routers (the other works fine), I am seeing:

    No backups could be located for this device

    on the restore tab for auto config backup.

    It was doing this with 2.4.3_1 and is still doing it with 2.4.4. There are no errors indicated in the system log. If I manually trigger a backup, it will report success. Switching to the legacy gold repository will also show no backups.

    If I enter the device key from my working router, it will pull up the list for that router.

    I'm not sure what else to try or to look at and am hoping someone here has suggestions. Thanks!


  • Rebel Alliance Developer Netgate

    And Enable is checked?

    Does Device key on the Backup Now tab have a value?

    Is SSH enabled on this firewall?



  • yes, yes, and yes. thanks


  • Developer Netgate

    PM me the device key and I'll check the server logs.



  • Steve did check the server logs and there was nothing there. The router is communicating with the acb server when attempting to retrieve backups (and it can pull the backup list for my other router), but it is not sending any packets out when I trigger a backup (despite reporting success).

    Anyone else seeing something like this?


  • Developer Netgate

    @ericmc1 If you can copy/paste the device key from you "other" router into this one, and it lists the backups of that "other" router, it confirms that this router has never (successfully) made any backups.

    Plug this into the PHP Command section of the Diagnostics->Commands page. How does do the working and non-working routers compare?

    print_r($config['system']['acb']);
    


  • @steve_b

    The only difference between the two is that the router that is not backing up has a hint in the array, and the one that is successful does not.


  • Developer Netgate

    Please visit the ACB page and see if you see any backups listed now. I made a test with your user key. You will NOT be able to view the backup, but you should see it listed.



  • @steve_b

    yep, I see it. I tried to trigger one again but I still only see the test you did


  • Developer Netgate

    Take a look at the System -> Logs page. On the System - General tab, do you see any entries such as this:

    Nov 12 18:19:24	php		/etc/rc.packages: Beginning configuration backup to .https://acb.netgate.com/save
    Nov 12 18:19:26	php		/etc/rc.packages: End of configuration backup to https://acb.netgate.com/save (success).
    


  • @EricMc1 Are your routers in a Multi WAN configuration? If so then I just resolved my problem and made notes here: https://forum.netgate.com/topic/137680/auto-configuration-backup-shows-no-backups-us-too.



  • @steve_b

    yes, I see entries just like those.

    @fmccourry

    Thanks for the pointer. I do have multiple WANs. I tried your suggestion of setting a DNS per gateway, but unfortunately that didn't work. I do run local DNS and the ACB service doesn't have any issue getting to the server for pulling the restore list. I also didn't have the errors in the log you had.


  • Developer Netgate

    @steve_b said in Auto configuration backup shows no backups:

    Beginning configuration backup

    Please attempt another manual backup, then look for the file /tmp/backupdebug.txt
    ACB uses PHP_curl to upload encrypted backups. Any errors reported by curl will appear in that file.



  • @steve_b
    okay, I'm seeing inconsistent behavior here and I haven't been able to pin down why.

    router 1 (the originally not working one):
    While looking for the debug logs, I noticed that the log entries for success had disappeared. I traced this to a check for boot completion that was failing, preventing the backup from starting (this is a different issue. I also don't know why the boot is no longer finishing).

    I manually deleted the booting file so that the backup would run, and it started working. I then walked back the firewall and DNS config (and the debugging stuff that I had added in acb.php) that I had done before to try to get it to fail again, and it would not fail. So, I don't know what changed to make it work.

    router 2 (the originally working one):
    This one started exhibiting the behavior seen before on router 1 (backups report success in web ui, but they are not occurring). This one does have a backupdebug.txt indicating a timeout on the save. I can still ping and curl acb.netgate.com.