Chelsio Utility Tools



  • Hello

    I am trying to install T580-SO-CR on DELL R320
    This adapter should work out of the box if the firmware on R320s are:

    BIOS : v2.5.1
    Lifecycle Controller : v1.1.1.18

    I want to play with the adapter little bit, but Chelsio Utility tools are not included in the latest release

    I have installed FreeNAS of this same box and when I run chalsio_adapter_config command
    I've change the mode on the adapter to 2x40G witch should be default mode on the card when is brand new and some how after restarting the server this adapter came online

    but when I installed pfsense back on. I've got only the embedded network adapter came online Only bge0 and bge1 are listed on "Assign interfaces" - I can't see cxl0, cxl1 witch should be the chelsio Interface

    Thank you


  • Netgate Administrator

    Check the boot logs for errors attaching the driver.

    Steve



  • @stephenw10 I solved this problem by upgrading the firmware to the latest version

    currently pfsense or freebsd provide only old version of the firmware for this card and it is ok for some versions of the chips on T580-SO-CR

    the output of --- sysctl -a | grep t5nex should be

    dev.t5nex.0.%desc: Chelsio T580-LP-SO

    some chips with version
    dev.t5nex.0.firmware_version: 1.19.1.0
    witch is what freebsd/pfsense provide are giving output
    dev.t5nex.0.%desc: Chelsio T580-LP-SO-CR
    it should be upgraded to version
    dev.t5nex.0.firmware_version: 1.21.5.0
    in order to work properly I think version 3 of the chips must be upgraded to v1.19.1.0
    otherwise won't work on pfSense

    Thank you

    P.S I am not an engineer I am explaining it the best I can :)


  • Netgate Administrator

    Hmm, 1.19.1 is indeed what we ship in 2.4.4:
    https://github.com/pfsense/FreeBSD-src/tree/RELENG_2_4_4/sys/dev/cxgbe/firmware

    However that's the most recent version even in FreeBSD master:
    https://github.com/freebsd/freebsd/tree/master/sys/dev/cxgbe/firmware

    Steve



  • @stephenw10 You should consider upgrading the firmware on the next version. Seems not all of them are properly working with this version v1.19.1.0. The card I ordered was brand new so probably there are new versions of that card's chip and required v1.21.5.0 and I mean it because I even could not make it to work with Windows Server nor FreeNAS and Ubuntu latest. So far I have no problems with this card. The version I have is a compact design with a small heat sink on the right

    0_1541892744424_photo_2018-09-29.jpg

    I've never be able to run the other version on the left with long heat sink. I don't know why!!!!

    This server is my second node of my HA cluster and so far I encounter no issues even working better then I expected.

    Now I am going to build FreeNAS server with the same card and Dell R620 and will see how it goes.


  • Netgate Administrator

    If there's a problem with that firmware there should be bug open and it should be against FreeBSD. We often have our own bug to mirror it but we would not want to update the firmware separately from FreeBSD master unless there was a very good reason. Like we are using some feature that FreeBSD does not and as far as I know that isn't the case.

    Steve