Unresponsive SG-4860 after firmware upgrade 2.4.4

  • Everything was working perfectly fine on my SG-4860, until I went to update to the newest firmware 2.4.4. Once it went ahead and updated the firmware and went to auto reboot after the installation. It never responded and kept saying not ready, and would add another 20 seconds to the countdown timer. Well after like the 10th time I gave up.

    So right now it does not respond at all. I have tried to connect via console via the serial connection, and it will not connect. I have drivers installed, know it is COM3, and have putty installed and with the correct setting (115200, 8, 1, XON/XOFF). Putty connection says connected to COM3, however I can hit enter as many times as I want and nothing responds or outputs to putty.

    I am at a loss right now and have no idea what to do or where to even start. I could not even do a memstick re-install to 2.4.4 or even older firmware since I cannot seem to get anything to show on console output on putty.

    Not sure what went wrong during the install but right now dead in the water and any help would be greatly appreciated.

    Thanks|-|-left aligned paragraph

  • LAYER 8 Rebel Alliance

    Did you install the correct driver? https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
    Checked in Device Manager COM3 is correct?


  • @rico
    Rico yeah I downloaded the window 10 driver from the exact same link you sent. I went to check again and it was the same.

    When I check device manager under ports, it shows up as COM3 and there is no issue with the driver (i.e. red or yellow !).

    I can have the putty connection to the 4860 via console and if I unplug the USB from the computer it terminated the connection and will kill the putty session. So I would assume everything is good (from what I can tell). Just nothing happens when I hit enter in the putty terminal. The cursor just stays at the top. I even went and tried changing the baud rate just to see if maybe that would do it but it didn't.

    I just tried to see if by dumb luck I could connect through the web interface but not luck either.

    So I am stuck as to what to do, since I cannot get anything to work. And everything was totally fine and I was accessing pfsense through the web portal right up until I hit the update button.

  • LAYER 8 Rebel Alliance

    Try to play with the flow control, set it to OFF when you are on XON/OFF. And RTS/CTS must be disabled.
    I'd also try with another Console program. If nothing helps try with another machine or drop some message to Netgate support.


  • Rebel Alliance Developer Netgate

    What are the lights on the units showing? Green? Red?

    Drop a line to the support team at https://go.netgate.com and someone can help you get it back online (or potentially setup an RMA if it's a hardware issue)

  • @jimp the lights on the back are green. Only turn red briefly when I power cycle, but goes back to green.

    Thanks for the negate link.

  • Rebel Alliance Developer Netgate

    Green is a good sign!

    If you can get the console connection working you should be able to get it going again then. There could be a larger issue at play but it has to be booting at least partially for the lights to go green.

  • @jimp I got it to connect once a couple minutes ago but then was just stuck after I hit f1 to boot and did nothing. I have not been able to get it to connect again since then. I even tried duplicating the exact things I did when it did respond for a couple seconds.

    This is what putty showed when I was able to get it to connect the one time, then after the Boot: F1 it does nothing and just sits there and cannot get it to respond to anything .

    SeaBIOS (version SageBIOS-20170207_214005-localhost.localdomain)

    iPXE (http://ipxe.org) 00:14.0 C100 PCI2.10 PnP PMM+7FB7AF80+7FADAF80 C100

    iPXE (http://ipxe.org) 00:14.1 C200 PCI2.10 PnP PMM 7FB7AF80 7FADAF80 C200

    iPXE (http://ipxe.org) 00:14.2 C300 PCI2.10 PnP PMM 7FB7AF80 7FADAF80 C300

    iPXE (http://ipxe.org) 00:14.3 C400 PCI2.10 PnP PMM 7FB7AF80 7FADAF80 C400

    Press F12 for boot menu.

    F1 pfSense

    F6 PXE
    Boot: F1

  • LAYER 8 Rebel Alliance

    Please try to boot without any Network Cable connected, just Power and Console.


  • Rebel Alliance Developer Netgate

    Try to boot a pfSense installer (either Factory image, which you can get from the support crew if you don't have already), or a CE ADI memstick installer image. If it boots that, try to reinstall and perform a recovery installation.

  • @rico that's what I have been doing. Haven't had anything but those 2 connected to the 4860. As I moved it over to my desk where my computer is so just bare bones hooked to it right now.

  • @jimp I downloaded 2.4.4 memstick image and followed the instructions on website for writing image to a flash drive.

    I have tried to gave the memstick in the USB port when I rebooted and tried connecting to console, but haven't gotten console to respond. The one time console did respond (which is the copy and paste I put in her above) I didn't have the memstick in at the time.

    I am correct all I need to do is have the flash drive in the USB port and power cycle the 4860 and 🤞 hope it connects to console so I can start the install, correct? Want sure if I was missing a step but that is what I believe to be the steps.

  • Rebel Alliance Developer Netgate

    Which memstick did you download, specifically? Make sure it's marked as an ADI memstick

  • @jimp Looks like I downloaded the wrong version. I downloaded the serial one (pfSense-netgate-memstick-2.4.3-RELEASE-p1-amd64.img). I am downloading the ADI version now (pfSense-netgate-memstick-ADI-2.4.4-RELEASE-amd64.img.gz) and also this one just in case (pfSense-netgate-memstick-ADI-2.3.5-RELEASE-amd64.img.gz).

    I will write it to the flash drive and try it and let you know how it goes.

  • @jimp well looks like that did the trick. Was able to get it to get into console mode and show it start up pfsense.

    I will get back with you because I get stuck, but right now am watching my daughter so I can't be at the computer right now.

    But I get to step #5 in here


    And I cannot get it to let me select option #6 configure boot options. I keep hitting the #6 but it just starts booting or doing something. It eventually stops asking what terminal type I want vt100, etc

    Either way that is what I got to, but I will be back once I put my daughter down for a nap. But progress so far 👍

  • Rebel Alliance Developer Netgate

    If it asks for the console, you can use vt100 or xterm, if you're using PuTTY for example, then xtrerm is probably best. After that it should proceed through to the installer.

  • @jimp Thanks yeah once I did that looks like ti started the install. Nice. I maybe winning now.

    Question for you I went to try and recover a backup from previous install, it gives me 4 options for partitions. Any idea which partition it would be on by chance?

    da0s2a freebsd-ufs (715M)
    dalsla freebsd-ufs (20G)
    diskid/DISK-000000022500lsla freebsd-ufs (20G)
    diskid/DISK-2004351423165190c8f6s2a..... freebsd-ufs (715M)

    Figured if I could recover my xml file it will save me time once I get it up and running again.

  • Rebel Alliance Developer Netgate

    Probably the 20G drive. Both of those are likely the same disk. The 715M might be your USB drive.

  • @jimp thanks I will try that one then. Some I had no idea. Thanks will let you know if I have any other questions. Much appreciated.

  • @Rico and @jimp thanks guys. I have it up and running finally. I really do appreciate you guys helping me out. So much, thank you both.

    Had one last question, is there a good tutorial or article out there for first things you should do one you setup pfsense router? I thought when I initially set it up the first time I followed a tutorial on things to consider doing.


  • LAYER 8 Rebel Alliance

    Well right after Installation when you login into the WebGUI some wizard comes up and you will end up with a working and secure basic Setup. :-)


Log in to reply