Possible hardware failure sg-3100



  • SG-3100 wasn't working. I attempted to reinstall. I get errors
    "MMC: block number 0x11 exceeds max(0x4)" and then it hangs.

    here's what I see on the console when boot from a "pfSense-netgate-SG-3100-recover-2.4.4-RELEASE-armv64.img" USB stick and type "run recovery".

    I'd like to know: Is this error recoverable in some way? Do I have a failed board? Is it likely I can install optional storage and it will work?

         \___/    |____/ \___/ \___/ \__|
    

    ** LOADER **

    U-Boot 2013.01-02873-g5e4ac3c (Aug 11 2017 - 13:12:40) Marvell version: devel-17.06.0

    Board: Rogue-1
    SoC: MV88F6820 Rev A0
    running 2 CPUs
    CPU: ARM Cortex A9 MPCore (Rev 1) LE
    CPU 0
    CPU @ 1600 [MHz]
    L2 @ 800 [MHz]
    TClock @ 250 [MHz]
    DDR4 @ 800 [MHz]
    DDR4 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
    DRAM: 2 GiB
    MMC: mv_sdh: 0
    DBG: Calling spi_flash_probe from env_relocate_spec()
    SF: Probing bus 0 cs 0 @ 20000000Hz mode 3
    SF: Detected N25Q128 with page size 64 KiB, total 16 MiB
    PCI-e 0: Detected No Link.
    PCI-e 1: Detected No Link.
    USB2.0 0: Host Mode
    USB3.0 1: Host Mode

    Map: Code: 0x7fedc000:0x7ff975a8
    BSS: 0x7ffef600
    Stack: 0x7f4cbf20
    Heap: 0x7f4cc000:0x7fedc000
    U-Boot Environment: 0x00100000:0x00110000 (SPI)

    Board configuration detected:
    Net:

    port Interface PHY address
    egiga0 RGMII 0x00
    egiga1 RGMII 0x01
    egiga2 SGMII In-Band

    egiga0 [PRIME], egiga1, egiga2
    Hit any key to stop autoboot: 0
    sdhci_transfer_data: Transfer data timeout
    MMC: block number 0x11 exceeds max(0x4)
    ** No partition table - mmc 0 **

    Starting application at 0x00200000 ...


  • Rebel Alliance

    In your place I'd drop some Ticket to the support guys: https://go.netgate.com

    -Rico