WAN choking with bridged cable modem



  • Hello!

    I have been facing a very odd behavior with a cable modem on bridge mode connected to pfSense which I have no clue how to debug.

    First let me give you some background. I have had ADSL WAN link for quite some time with the modem in bridge mode and it has always worked flawlessly.
    I recently acquired an additional Cable WAN link (DOCSIS 3.x) and configured it to work in bridge mode and it just doesn't seem to work right and I cant easily explain how but it goes like this: as soon as DHCP is acquired and there is no network activity I can ping IPs (e.g. 8.8.8.8) and resolve names just fine, but it seems as soon as network activity goes higher (e.g. many internet tabs open or I open up a torrent client) it seems to start to "choke". Suddenly simple ping wont work for some time (first X ICMP requests wont get replies) or TCP connections will take a long time to establish although previously running ping or ongoing connection will keep working.

    For example: have torrent client open and then ping 8.8.8.8

    root@OPNsense:~ # ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    64 bytes from 8.8.8.8: icmp_seq=7 ttl=43 time=62.375 ms
    64 bytes from 8.8.8.8: icmp_seq=8 ttl=43 time=58.086 ms
    64 bytes from 8.8.8.8: icmp_seq=9 ttl=43 time=58.837 ms
    64 bytes from 8.8.8.8: icmp_seq=10 ttl=43 time=61.004 ms
    

    As you can see it lost first 6 packets and from then on an icmp request is never lost again.

    Additional comments

    • It does seem related to pfSense/FreeBSD -- I have tried using Linux and Windows also in bridge mode and it works just fine, I dont see the described behavior
    • Configured dual WAN with my ADSL and once I failover to ADSL everything starts to work normally
    • Also configured with Cable alone (no ADSL), problem persists
    • Ran tcpdump on it while presenting the behavior and the only odd thing I noticed is that I get a very high TCP SYN retransmission rate
    • netstat -in does not show any errors or dropped packets
    • I am using intel driver (igb) and also tried external USB ethernet adapter

    I am clueless to what the problem could be. Any clues would be very much appreciated!
    Please let me if there is any additional information I can provide.
    Thank you!