Erro ao enviar anexo em sites externos



  • Prezados amigos, boa tarde!

    Peço perdão já antecipadamente caso já exista algum tópico relacionado ao problema que estou tendo abaixo.

    Recentemente na empresa onde trabalho, instalei o PFSENSE 2.4.4-RELEASE-p1 (amd64) FreeBSD 11.2-RELEASE-p4. Junto a ele, instalei também o SQUID, SQUIDGUARD e o LIGHTSQUID.
    Percebemos que em alguns sistemas WEB que possuímos em uma rede Externa (MPLS), não conseguimos anexar PDF, JPG entre outros. Ao clicar no botão enviar, aparentemente ele inicia o Upload do arquivo mas para no meio do caminho, como se interrompesse o processo. Fiz o processo diversas vezes, de diversos computadores diferentes e constatei que existe algo no Pfsense que está impedindo, pois quando ligo o computador diretamente no Router ou crio uma rota que não passe pelo Pfsense no computador, ele envia o anexo normalmente.

    0_1547734870166_pfsense2.JPG

    Pensei que pudesse estar relacionado ao SQUID, mas inseri o endereço do meu sistema no Bypass Proxy for These Destination IPs e o problema persistiu.

    Estou anexando a tela das minhas regras. Pass any Origem da Minha LAN para uma NETWORK/16 any TCP Flags e Gateway do meu Router da rede MPLS.

    0_1547734850366_pfsense1.JPG

    Gosto muito do Pfsense, e nunca havia me deparado com algo assim. Alguém pode me dar uma luz do que pode estar ocorrendo?
    Agradeço muitíssimo!



  • Amigo, faça um teste do link para ver como está a taxa de Upload, tive problemas esses dias com um novo cliente x instalação.

    Já testou acessar o site sem ter o squid rodando ? por fora no caso ?



  • @leobozzi fiz o teste do Upload e está bom. Link de 3MB.
    Também tentei sem o SQUID estar rodando. O site está abrindo normal ok? Mas na hora do envio do anexo, o problema persiste. Neste caso eu desativei o serviço do squid, mas as rotas dos pacotes ainda passam pelo pfsense.



  • @davidvalter Já colocou ele na lista whitelist ?

    Definiu algo no Squid Traffic Managment Settings ?

    Em Squid Cache General Settings vá em Do Not Cache e adicione o site ali.

    O site em si usa alguma porta diferente ?

    Tente simular o envio novamente com o tcpdump monitorando.



  • @leobozzi, inseri ele no Whitelist e Do not Cache e deu certo para mim!
    Obrigado!



  • Que bom cara. Dá joinha ai que me ajuda rsrs
    abraço


Log in to reply